PDA

View Full Version : Lightwave loose its preferences !



alexboarolo
11-21-2003, 03:26 AM
from Alexboarolo - Milan - Italy
Lightwave 7.5 registered user
on theese platforms:
- Dual G4 450 - OS Panther 10.3 - 750 Mb Ram - ATI Radeon 9800pro 128Mb
- G4 450 - OS Panther 10.3 - 500 Mb Ram - ATI Radeon 9800pro 128Mb

Reporting this problem:
My Layout and Modeler don't remember preferences. Every time i launch theese apps i need to reconfigure Rendering options and Plug-in list.

I've tried to delete my preferences (user/library/preferences/...) and re-launch Layout or Modeler, re-configured and quitted. The problem persist.

This problem was started with OsX (10.0) and rest !

If someone have the same problem or a solution, please reply me.

Thanks - Alex

Beamtracer
11-21-2003, 03:40 AM
Hello Alexboarolo in Milan. I hope the city authorities in Milan have fixed up that sticky airport runway problem that caused all the planes to stick to the tarmac.

Back to Lightwave... have you tried running the Apple Disk Utility and repairing permissions?

When you install new applications they have to change the permissions (to get access to files) and most don't set them back the right way afterwards. This can then stop files from being saved, including your preferences.

Repairing the permissions may or may not solve your problem, but it's worth trying first. It's a good idea to repair permissions after each time you install new software.

mlinde
11-21-2003, 09:22 AM
In addition, make sure that the command line files for Modeler and Layout (or Hub) have the correct path, or no path, in them. If you change the name of your HD or the directory structure of your disk at all, these files need to be updated.

alexboarolo
11-22-2003, 12:25 PM
1st Step - Repaired the privileges of discs I use for Lightwave.

2nd Step - From Modeler i've exported the preferences (Modeler/Preferences/Export preference file...) on desktop and after renamed i've put it in Library/Preferences folder... GOOD now Modeler start correctly. All setting remain after quitting.

But... Lightwave Layout have'nt the same command ? Yes ? Where is it?
How can I export manually the preferences of Layout ?

Great thanks to Beamtracer and mlinde users for their useful posts.

Alex

riki
11-22-2003, 07:15 PM
Back to Lightwave... have you tried running the Apple Disk Utility and repairing permissions?

I've never had to do this and all my APPs remember my preferences correctly.

BTW when I open Disk Utility I don't see any option for repairing permissions. It looks like it's just for erasing and partioning a disk.

If you want to change file permissions don't you just use 'File Info'??

mlinde
11-23-2003, 12:04 PM
Riki, what version of OS X?
In 10.1.x, the repair permissions utility is a seperate application, downloaded from Apple Support.
In 10.2.x (and I assume 10.3.x) it is in the First Aid tab of Disk Utility.

In addition, the repair permissions issue can affect certain versions of certain applications because the Developer wasn't careful about setting permissions when building and installing applications. Basically, they don't correctly set the r/w flags for files or directories modified in the installation. Imagine Internet Explorer not being able to write a browse history because the history file doesn't allow system access to write to the file. This is the type of issue repair permissions deals with.

riki
11-23-2003, 03:01 PM
Thanks mlinde I'm using 10.1.5 I'll visit Apple and see if I can find the repair permissions utility.

monovich
11-24-2003, 05:04 PM
you already have the utility pre-installed. It's called "Disk Utility"

mlinde
11-24-2003, 07:11 PM
Originally posted by monovich
you already have the utility pre-installed. It's called "Disk Utility"
Please see earlier reply. The repair disk permissions functions were not built into Disk Utility until 10.2