PDA

View Full Version : Best settings for GL viewport speed?



Sebasvideo
04-10-2014, 01:28 PM
There was a thread here not long ago that I just searched for and I can't find, but the user was talking about changing a setting in his Quadro card that made the viewport much faster in Modeler. I remember checking my Nvidia settings and I don't have that setting so I guess it's only for Quadro cards. I have a GTX770 with 4 GB of RAM which is great, but sometimes the viewport in Modeler and Layout is still slow, especially after adding too many instances, even if in bounding box mode.

I just thought we might share settings, which can be either in the Nvidia control panel, or the Modeler and Layout options, that make the viewport faster when orbiting around objects. For example, I found out that setting Layout to GLSL Shaders makes navigation faster than the other option of Multitexture Shaders.

Some other things are obvious, if you enable OpenGL textures, reflections and transparency it will all slow down a larger scene. But some other settings might not be so evident. Sometimes setting Geometry Acceleration to Streaming made it faster for me, and there was a display bug in Buffered that disappeared when I switched to Streaming.

Do any of you have similar findings, again, both in the Lightwave's display settings or the Nvidia control panel?

MarcusM
04-10-2014, 01:54 PM
Here is something about Quadro and LW but Layout:
http://www.youtube.com/watch?v=8zDFeD7z4rQ

jboudreau
04-10-2014, 08:07 PM
There was a thread here not long ago that I just searched for and I can't find, but the user was talking about changing a setting in his Quadro card that made the viewport much faster in Modeler. I remember checking my Nvidia settings and I don't have that setting so I guess it's only for Quadro cards. I have a GTX770 with 4 GB of RAM which is great, but sometimes the viewport in Modeler and Layout is still slow, especially after adding too many instances, even if in bounding box mode.

I just thought we might share settings, which can be either in the Nvidia control panel, or the Modeler and Layout options, that make the viewport faster when orbiting around objects. For example, I found out that setting Layout to GLSL Shaders makes navigation faster than the other option of Multitexture Shaders.

Some other things are obvious, if you enable OpenGL textures, reflections and transparency it will all slow down a larger scene. But some other settings might not be so evident. Sometimes setting Geometry Acceleration to Streaming made it faster for me, and there was a display bug in Buffered that disappeared when I switched to Streaming.

Do any of you have similar findings, again, both in the Lightwave's display settings or the Nvidia control panel?

Hi Sebasvideo

I'm the one who posted on the forumn about making your openGL performance extremely fast by chaning your profile on your Nvidia Quadro card from base line profile to 3D App - Visual Simulation. I'm also the one who uploaded that video above a few days ago.

Here is the thread you were looking for along with another one with more information regarding this tip.

http://forums.newtek.com/showthread.php?133958-Tip-for-a-HUGE!!!-Increase-in-OpenGL-Performance!!-Lightwave-11-to-11-5&highlight=performance

http://forums.newtek.com/showthread.php?140973-Youtube-Video-Tip-Showing-a-huge-increase-in-OpenGL-Performance!!&highlight=performance

Hope this helps

Thanks
Jason

Sebasvideo
04-11-2014, 10:33 AM
Thanks, Jason. The difference between the control panels of the Quadro and GTX cards seem to be that under global settings there is no drop down list for Global presets, it just shows you the settings, and some of those settings are only in the Quadro.

No rush, but if you get a chance, could you please post a screenshot of the individual settings under 3D App - Visual Simulation but scrolling down the list of settings so we can see the ones that are not shown on the video? As far as I can see my settings are the same except for some settings I don't have, which are the difference between Quadro and GTX cards.

jboudreau
04-11-2014, 10:39 AM
Hi Sebasvideo, Here are the settings for the 3D app Visual Simulation profile (preset) I pasted in here again but it can be found under the first link I provided to you above. Their is also more information about the setttings in the second like I provided to you

Here are my settings,

Ambient Occlusion - off (Greyed Out Can't change)
Anisotropic filtering - Application-controlled (Greyed Out Can't change)
Antialiasing - FXAA - Off (Greyed Out Can't change)
Antialiasing Gamma correction On (Greyed Out Can't change)
Antialiasing-Mode - Application controlled (Greyed Out Can't change)
Antialiasing-Setting - Application controlled (Greyed Out Can't change)
Antialiasing-Transparency - Off (Greyed Out Can't change)
Buffering-flipping mode - Auto-select (Greyed Out Can't change)
CUDA-GPUs - All (Greyed Out Can't change)
Deep color for 3D applications - Allow (Greyed Out Can't change)
Enable overlay - Off
Exported pixel types - Color indexed overlays (8bpp) (Greyed Out Can't change)
Maximum pre-rendered frames - Use the 3D applications setting (Greyed Out Can't change)
Multi-display/mixed-GPU acceleration - Multiple display performance mode (Greyed Out Can't change)
OpenGL rendering GPU - Auto-select (Greyed Out Can't change)
Power management mode - Adaptive
Stereo-Display mode - Custom
Stereo-Enable - Off
Stereo-Swap eyes - Off
Threaded optimization - Auto (Greyed Out Can't change)
Triple Buffering - Off
Vertical sync - Use the 3D application setting

I can't gurantee it will work by changing the settings on a per software basis. I tried matching the setting in the 3D app - visual simulation preset but no performance increase. All I can see is with the 3D app - visual simulation preset a lot of setting get greyed out completely where you can't even change anything it's different from just setting it to off. But give it a try and let me know how you make out. Hope it works for you.

Thanks
Jason

Sebasvideo
04-11-2014, 10:42 AM
Oh, thanks, I totally missed that you posted the settings. My performance is usually pretty decent, but it starts to get sluggish when I add millions of instances of things like grass. I'll take a look at these and see how they work out, at least the ones that are available in my card. I always wondered this, but these changes are immediate and at most I have to restart the app but not reboot, correct?

jboudreau
04-11-2014, 10:44 AM
Oh, thanks, I totally missed that you posted the settings. My performance is usually pretty decent, but it starts to get sluggish when I add millions of instances of things like grass. I'll take a look at these and see how they work out, at least the ones that are available in my card. I always wondered this, but these changes are immediate and at most I have to restart the app but not reboot, correct?

Yes there should be no need to restart your computer. Just change the settings and then re-launch the app.

Sebasvideo
04-11-2014, 11:00 AM
It turns out my settings were the same, except for some that are not in your list, and some that are in your list but not in mine. I took two screenshots to show you my full list of settings. These are the settings when "Let the 3D application decide" is selected in the first screen.

121379

121380

jboudreau
04-11-2014, 12:48 PM
It turns out my settings were the same, except for some that are not in your list, and some that are in your list but not in mine. I took two screenshots to show you my full list of settings. These are the settings when "Let the 3D application decide" is selected in the first screen.

121379

121380

So how did you make out? Are you seeing any difference.

You probably won't because the problem with using the base profile settings for all the quadro cards is nvidia has an issue with their quado drivers. Their is a problem with the nvoglv64.dll file that causes slow zooming in/out and rotating performance that usually results in a crash. Using the 3D App - Visual Simulation fixes this issue. I have flagged this to the newtek team a while back and they told me they would get in touch with nvidia to find out why when using this profile lightwaves openGL is extremely faster than the base line profile. I still haven't heard back and still it's not fixed. So this is the only fix that will give you the most performance out of your quadro card. So your card is probably running as fast as it can since you are using a GTX card vs a Quadro card.

Another set of setting you can change in the program settings are:

Under the "Program Settings" tab, add lightwave.exe & Modeler.exe as a program to customize. Specify the settings for the program as follows:

Maximum pre-rendered frames = Use the 3D application setting
Multi-display/mixed-GPU acceleration = Multiple display performance modeOpenGL rendering GPU = Quadro K50000 (this will vary depending on the card)
Vertical sync = Use the 3D application setting

Hope this helps

Thanks
Jason

Sebasvideo
04-11-2014, 12:52 PM
Thanks, I'm going to try that. As far as I've read, Quadro cards have a lot less CUDA cores, but seem to be better for 3D viewports. My card seems fast enough, it only gets sluggish in the project I'm working now when I activate the instances because I have 2 million instances of a 2x2m patch of grass over a surface that is a circle of 3 km diameter. It doesn't cover all of it, but most. Added to that, there are like 200,000 tress in random with a surface map, and 500,000 flowers, all in the same terrain. It still lets me navigate, it's just slow.

jboudreau
04-11-2014, 04:14 PM
Thanks, I'm going to try that. As far as I've read, Quadro cards have a lot less CUDA cores, but seem to be better for 3D viewports. My card seems fast enough, it only gets sluggish in the project I'm working now when I activate the instances because I have 2 million instances of a 2x2m patch of grass over a surface that is a circle of 3 km diameter. It doesn't cover all of it, but most. Added to that, there are like 200,000 tress in random with a surface map, and 500,000 flowers, all in the same terrain. It still lets me navigate, it's just slow.

Yeah my Quadro card has 1536 cuda cores but it has nothing to do with lightwaves viewports since lightwave doesn't use cuda. Wow is this a client project or just a personnel one? I'd like to see how my card would handle all those polygons

Radamanthys
05-11-2014, 02:00 PM
I made a test yesterday that could add some information. I ran the viewperfvlightwave test on a gtx titan and on a quadro k4000

The first result i got was around 20 for the gtx titan and around 45 for the quadro. So, already a 2x increase. Then buy looking at the results detail, i notices scoreśwhere the quadro seems "limited". So i did modifies 2 options in the base settings :

Power usage : set to performance
Desactivate the vsync
The latest is the one that i think has more impact, if u sync at 50 Hz and your card give 90 fps, it will bring it down to 50 fps

Adter changing that, the quadro rises up to 85 score.

I still have to test the titan with vsync off to compare