PDA

View Full Version : Spline Instancing/ChainLink/Drifting problem!



cove
03-30-2014, 03:01 PM
Sorry my image did not load up. See my second post here--

---Spline Instancing/ChainLink/Drifting problem! No 2 with image.--

Hi all.
Using LW11.6.2. o/s vista.
Have been watching this video-----------
Jennifer Hachigian explores the new Spline Instancing mode in
LightWave 11.6 instancing.

http://www.youtube.com/watch?v=yft6Z6wbyM8&list=PLBscyc2_NuECMV8fUHv1mEcbbdRbUT7_R
C:\Program Files\NewTek\LightWave11.6\support\plugins\scripts \Python\Layout\Generic

Ive got as far as, Select spline then add Instance Generator
At 12.25 in video Jenny asked you to select ChainLink from the Add object
But there is no ChainLink item listed/showing.
I did a search for a ChainLink item [.py] in LW11.6 folder. none found.
[I thought it may be like the curve to spline tool you have to install it manually via load plugin].
But if i now select my cube object and select spline/200 instances/tick distribute the cube is distributed
along the spline ok.
When you now move the original cube in it z axis the cube does start to move along the spline then all the cubes drift off the spline
and spread out.
I assumme that you need the missing ChainLink item for the cubes to stay correctly on the spline.
[Incidently the cubes also drift apart when you move the spline itself.]
First time using Attatchment feature so i hope my image shows ok.
Thanks for any help in reply.

Chrusion
04-02-2014, 05:55 PM
No. ChainLink is the object that's being instanced. Since you're using a cube as the instanced object, chainlink is irrelevant.

As you've discovered, you cannot move an object that's being instanced as the instances will also move. Seems logical that this would happen and allows you to do some interesting motion treatments to thousands of 'copies' by altering the original, single object.

The question is: Why do you want/need to move the cube, but not it's instances?