PDA

View Full Version : Is it possible to get a vector map working with MDD?



eondesigner
03-04-2014, 05:13 AM
I mentioned this on another thread but thought it was a problem that warranted its own thread.

Ok, the DP kit, vector map node is great and allows Lightwave to use the full displacement from Mudbox, ZBrush and similar programs. But the issue I'm having is, getting it to work with an MDD on a subdivided object.

Now this may sound simple enough, just add your MDD file, subdivide, then apply vector displacement. If anyone can figure out a method for doing this I'd love to hear it.

RebelHill
03-04-2014, 05:29 AM
Yes... the answer was in the other thread... set the evaluation orders the right way round.

eondesigner
03-04-2014, 05:38 AM
Please just try it. I understand that method works for Normal displacement and texture displacement but it won't work with the vector map node. I went into this after a colleague gave up and said it couldn't be done, his solution (which does kind of work) was to output an object sequence from the MDD and run the vector map on that (not practical in a production pipeline really). So I thought, (just like you) there's surely an easier way to solve this, and I've been looking into it for days now.

RebelHill
03-04-2014, 05:43 AM
I have... and it does.

eondesigner
03-04-2014, 06:02 AM
ok, so I'm not understanding your explanation correctly. The way it seems you have it is, the SubD order set to 'After Bones' and the displacement nodes (with the vector map) set to 'Before Local Displacement' and the MDD added with Lightwaves MD_Reader. This doesn't work. If I've got it wrong, please let me know.

RebelHill
03-04-2014, 06:17 AM
Dunno what to tell ya... Im lookin at it right now and it works for me.

edit;.. oh yeah... and make sure you have after deformation checked in the vecDisp node options.

eondesigner
03-04-2014, 06:19 AM
Screen grab?

eondesigner
03-04-2014, 06:34 AM
OK, I got it. SubD order set to 'After Bones' and the displacement nodes (with the vector map) set to 'Before Local Displacement' then MDD added with Lightwaves MD_Reader and Crucially in the MD_Reader setting 'Apply Cache to' Object Space. This is the bit I was missing all along. Thanks for your help RebelHill.

RebelHill
03-04-2014, 06:55 AM
Crucially in the MD_Reader setting 'Apply Cache to' Object Space.

Ah yes... that too. There had to be something. Glad you got it.