PDA

View Full Version : CHange UI Text Colour?



LWHound
03-04-2014, 03:36 AM
My old eyes are flagging after hours of peering at the black on grey LW UI. Is there a way for me to change the colours for some relief please?

Watching my buddy easily reconfigure his Blender UI made me realise how dark mine was. I guess if I can't change my UI I will have to switch to Blender in order to save my eyesight. Health first.

kindest regards,


LWHound

JonW
03-04-2014, 04:28 AM
I can't stand the current LW colour UI, & would go blind on top of it. I use the old version with some slight modifications which makes it much easier to read architectural drawings and the complex objects in Modeler that one has to cope with.

Having the BG OGL Mesh 000,040,060 you can see the points in the background layer but the BG layer is still dark enough.

The combination text & back ground colours allows you actually to be able to read the "Layers window in Modeler", to put it bluntly! (the dark grey on medium grey, well what does one say....... other than you are less likely to go blind from other activities!)

It is probably just me, but I find that the Layers window for Modeler I can read a touch easier of the left hand side of the monitor than the right. I think it is because one reads left to right, then one's eyes then run into the work space. But I haven't been able to really nail the actual issue. But for me, Layers window on the left.

Also having the grid & axes different greens helps a lot.

White text cut it back from white to lower the contrast.

I also calibrate the monitor with a Spyder, display 5800K, 90 cd/m2 which is must easier to look at hour after hour. But you need to have a working environment with modest light. Try this for a week with the computer if you haven't done so.

Most people have their monitors far far far too bright!

The UI with these colours looks really dated, but it is a lot easier to read and that is all I care about.

spherical
03-04-2014, 06:00 PM
Matt Gorner wrote a really nifty tool for setting this stuff that goes far beyond the native color setting choices. Note that the settings it outputs do not go into the LWHUB.CFG file in more recent LightWave versions. They go into the Layout and Modeler configs instead. Of course, with this Borked forum search, I can't find the original thread. So, attached is the copy I have. I'm sure Matt won't mind.

Here's my LW desktop: (Keep clicking the images to get them to full rez.)
120597 120600
Easy on my eyes.

120599
120598

LWHound
03-05-2014, 03:20 AM
Matt Gorner wrote a really nifty tool for setting this stuff that goes far beyond the native color setting choices. Note that the settings it outputs do not go into the LWHUB.CFG file in more recent LightWave versions. They go into the Layout and Modeler configs instead. Of course, with this Borked forum search, I can't find the original thread. So, attached is the copy I have. I'm sure Matt won't mind.

Here's my LW desktop: (Keep clicking the images to get them to full rez.)
120597 120600
Easy on my eyes.

120599
120598

sperical, if you were a woman I'd volunteer to have your kids! :) Thank you soooooooo much for that. You've just saved an old guy's eyesight. On the flip side of the coin, I'll end up putting more LW hours in now. Oh well ....

dee
03-05-2014, 06:08 AM
I can't find the original thread.

Here you go: http://forums.newtek.com/showthread.php?115493-Interactive-GUI-Color-Tool-for-LW10

LWHound
03-05-2014, 07:37 AM
Thank you dee! This is a GREAT help. Many thanks for making and sharing it. Strangley, I'm using spherical's colour scheme with LW9.6 and the label text, shown white in the example, is still displayed as black. Not sure why that it is.

I should also thank JonW for his previous suggestion too. So I will. :) Thanks JonW.

Snosrap
03-05-2014, 11:02 AM
Here's my LW desktop: (Keep clicking the images to get them to full rez.)
120597 120600

Holy crap - that's ugly! :)

dee
03-05-2014, 12:05 PM
Thank you dee! This is a GREAT help. Many thanks for making and sharing it. Strangley, I'm using spherical's colour scheme with LW9.6 and the label text, shown white in the example, is still displayed as black. Not sure why that it is.

I should also thank JonW for his previous suggestion too. So I will. :) Thanks JonW.

I'm glad it helps. AFAIK they made some changes to the UI in 10.x, not shure if everything works in 9.6.

Shnoze Shmon
03-05-2014, 01:49 PM
... if you were a woman I'd volunteer to have your kids! ....

This is in severe need of being reworded... :ohmy:

spherical
03-05-2014, 04:58 PM
Holy crap - that's ugly! :)

Don't tempt me... :)

Snosrap
03-05-2014, 09:35 PM
Don't tempt me... :):):):)