PDA

View Full Version : Depth Pass question



short223
02-25-2014, 07:47 AM
Forgive my lack of knowledge when it comes to color space and such. I need to use the Composite Buffer Export to create a depth pass. When I hit F9, I am able to see an acceptable depth pass image in the layers of the Image Viewer. When I attempt to save it (I used every extension possible) it always comes up white in my compositor (along with alphas in some 32 bit cases).

The main question is what format and settings do I need to do to properly save out the depth pass? Does Linear colorspace need to come into play? 32bits? 24bits?

Any explanation would be helpful....
Thanks!

Ivan_B
02-25-2014, 11:21 PM
I use a simple jpg for my depth passes..its just a black and white image (or at least it should be). What does the depth image look like in something like photoshop...it could be how your comping app interprets the image..I use after effects and have never had to do anything to import the depth jpeg seq.

This is probably how your doing it, but just in case....

I use "image processing" "add image filter" "composite buffer export" enter the properties ... Destination = Image files...image type = LW_JPEG(.jpg)...File Output = somewhere on your hdd. Below that is the actual buffers make sure you tick "Depth" check to see that your objects are active in the Objects tab...if their not active they probably wont get calculated.

Always work in Linear CS

other than that..not sure what else you could do...good luck!

Waves of light
02-26-2014, 02:45 AM
Here are some screenshots from a current project. I hope they will solve your problem.

My process is:


Processing Tab - Add image Filter - Compositing Buffer Export
In the CSE window - make sure Save on F9 and F10 are ticked
Select 'Depth' from the Buffers list below
Take a look at the 'Depth Options' at the bottom of the screen - Bilinear Filter is a control for more/less edge anti-aliasing
F9 render
In the resulting Image Window - select from your Layer drop down and select the buffer
Export to exr
Select the image and export to jpg (or your preferred format)
Open PS
Load both images into the same document
Select the Depth pass and select all - I use CTRL + Click on the layer for this
Open Channels window
Click 'Save Selection as Channel' - little button at the bottom of the Channel window
Back to Layers and select the jpg image.
Select Filters | Blur | Lens Blur
In the Depth | Source drop down - select Alpha1 (or whatever it was named when you did step X above)
Select Invert
Then play with 'Blur Focus Distance' 'Iris' 'Spec Highlights' and 'Noise' settings, until you're happy with the preview
Click OK


http://forums.newtek.com/attachment.php?attachmentid=120484&d=1393407884

http://forums.newtek.com/attachment.php?attachmentid=120483&d=1393407884

120484

120483

Cheers,

Ricky.

EDIT: This is a good tut from Mis - http://www.youtube.com/watch?v=4Kpa51ID0q8

sukardi
02-26-2014, 03:01 AM
If you are using exr, the depth pass is stored in metre unit. If a certain pixel is at 10m from the camera, the value of that pixel is 10. White is 1.0, so that is why all you see is white. The pixels are basically all super white.

If you use Nuke, you can easily multiply the depth channel by 0.01 or 0.001 to give out a visible value ( ie: between 0 to 1). I am not sure about other packages but the concept is the same.

Mr_Q
02-26-2014, 09:57 AM
Honestly you may find using a "fake" depth far more simpler and flexible. As fake depth can work with LW's built in AA, moblur, and even DOF. It's a more straight forward 1:1 process. Requires less "real" compositing. It also renders fairly quickly.

To make fake depth simple make all objects matte black, set your BG color to white. Then set your FOG radius out to as far as the last object in your scene and make sure the color is also white. Write out a 16bit or higher image for less banding.

Waves of light
02-27-2014, 04:34 AM
Honestly you may find using a "fake" depth far more simpler and flexible. As fake depth can work with LW's built in AA, moblur, and even DOF. It's a more straight forward 1:1 process. Requires less "real" compositing. It also renders fairly quickly.

To make fake depth simple make all objects matte black, set your BG color to white. Then set your FOG radius out to as far as the last object in your scene and make sure the color is also white. Write out a 16bit or higher image for less banding.

Hey, thanks Mr_Q. I will give that one a try too.

short223
02-27-2014, 08:38 AM
Thanks for all the replies. Looks like my issue was with messing with things I shouldn't have, namely unchecking the "Normalize Depth to 8-bit" and limiting the buffer depth. Looked good in the Viewer but would only save as white. By leaving the Depth Options alone, it works fine.

My initial thought was that it would have been better to have more information (more bits) in the depth pass, but I guess that is not necessarily the case?
Thanks!