PDA

View Full Version : Weird glitches in rendering



Sebasvideo
02-24-2014, 09:03 AM
I've been getting these weird white pixels at different places in my rendered images and I have no idea why. They don't show up on VPR, and they change according to the samples chosen. For example, if lighting samples is set to 2, these pixels will show up in one place, if set to 4 in another place, obviously without changing the camera's point of view. Sometimes the one that showed with samples at 2 will show up too it set to 4, but then others will show up.

I attached 3 renders so you could see, and hopefully give me any idea of what could be causing this:

120388

120389

120390

Thanks,

Sebastian

JonW
02-24-2014, 01:59 PM
Have you looked at Statistics "W" while in poly mode for 1 & 2 point polys. Get rid of them.

Non planar polys giving you a problem.

Sebasvideo
02-24-2014, 02:07 PM
Have you looked at Statistics "W" while in poly mode for 1 & 2 point polys. Get rid of them.

Non planar polys giving you a problem.

OK, so it says 3543 non planar polygons, but no 1 or 2 vertices, 79351 3 vertex ones and 137033 4 vertex ones. This is one of the street layouts from the Metropolitan pack from Video Copilot, and these are imported from the OBJ quads version. Other versions are triangle OBJs, FBX, MAX and C4D. I imported the FBX but it kept giving me several errors of files not found even after I saved it as an lws. I even installed the trials of the AD suite to open the MAX ones and Cinema 4D to open its native format, but since I don't have the first clue how to operate those programs I figured it would take me hours just to be able to do anything with them and I preferred to import the Quad OBJ's into Lightwave.

So if you say non-planars are the problem, how do I fix that?

spherical
02-24-2014, 03:07 PM
Triple.

Sebasvideo
02-24-2014, 03:37 PM
Triple.

I thought quads were usually preferred. Either way, executing the triple command leaves 130 planars. After rendering the scene again, I still get the white pixels. I had never seen that before though.

Danner
02-24-2014, 04:05 PM
Quads are preferable for editing objects, but for rendering trinagles are prefered as they can't be non planar. Your glitches don't look like non planar geometry, in a way they look more like one point polygons, but one point polygons don't usually jump around like that. There are other areas where they are also visible, look on the car and on the reflection of a lamp post on the left side. I beleive it's something related to reflection. You have a very dark scene with a few small bright spots that get reflected unreliably. There are performance reducing knobs you can tweak, in the render tab that might work. Increase the ray recursion limit, up the ray precision, lower ray cutoff, give it more shading and light samples. Use limited region on the most problematic area. (seems like the lamp post reflection on the building on the left) But before tweaking the precision and cutoff, make a note of where your original settings were at, because you can really mess the render engine up (ugly or long rendertimes) if it gets out of range numbers in those settings.

spherical
02-24-2014, 05:08 PM
I thought quads were usually preferred. Either way, executing the triple command leaves 130 planars. After rendering the scene again, I still get the white pixels. I had never seen that before though.

Well, quads are preferred but trying to flatten 3,500+ quad or N-gon polys would be a bit tedious; if at all possible. That Triple leaves non-planars is odd. Did you run it on the ones that remained? Could be that the Triple command made other polys non-planar; which would indicate that the model is worse than originally thought. IOW, there may be overlaying polys that the standard analysis won't pick up, so can't be fixed by Unify, etc.

You might try turning on Limit Dynamic Range. As Danner says, I'd up the light samples and check that your surfaces don't have excessive amounts of Diff, Spec and Refl.

JonW
02-24-2014, 08:38 PM
I thought quads were usually preferred. Either way, executing the triple command leaves 130 planars. After rendering the scene again, I still get the white pixels. I had never seen that before though.

Is it some of those 130 polys causing the problem or is it the polys that were flattened.

There must be something else wrong with those 130 polys. Manually weld a few of the problem polys, every point around the poly. Remove a dodgy poly & make a new one to see if the problem goes away.

Stick a camera or 2 in very close & render a close up. it may give you a clue.

"Unify Polygons" ?

Sebasvideo
02-24-2014, 08:52 PM
It might be rather difficult to weld the problem polys, I don't even know where they are. But I'm not sure this is caused by any polygons, it looks like a weird raytracing glitch. These are not really detailed models, basically the windows and most detailed areas are drawn in the textures. They are not meant for close scrutiny, but rather for aerial views.

I will raise sampling more and see what happens.

Mastoy
02-25-2014, 01:20 AM
I had a similar issue when using reflective surfaces and very high luminosity surfaces (with radiosity ON) in the same scene. I had to lower luminosity for some surfaces (and compensate with lightwave lights) to get rid of those white points

EDIT : Looking at your renders, it could be the problem : the white dots appear on reflective surfaces (I guess), and maybe your car lights surface has a high luminosity value ?

spherical
02-25-2014, 02:46 AM
It isn't a "weird raytracing glitch". Artifacts in the render are caused by something. You have to find out what that something is.

When merging points, after having used Automatic, it helps many times to use Fixed with a very small dimension at first and incrementally increase it while watching a zoomed-in perspective view to see if the mesh changes in an undesirable manner. Anything up to that point, where points are eliminated, is usually a good thing.

If the model is so Borked that there are overlapping polygons, polys that do not have the same shape, Unify Polygons does absolutely ZERO.