View Full Version : Animated Cache GI - Darker on the cached frame than on interpolated frames

02-17-2014, 01:34 PM
Interesting problem that needs to be solved.

I routinely create anims using backed/cached anim. GI with good, flicker-free results for years... until now and I think it might be due to using Nodes for one of the surfaces. I haven't had time to confirm as I just discovered it in the midst of rendering going on now.

The effect is that the shading of the node surfaces, in this case a simple 'hand-made' stainless steel material using anisotropic spec and blurred fake-fresnel (incident gradient) reflections via the Standard Material node, is a smidge darker on each baked GI "key" frame, in this case, every 10th frame. All other normal, non-nodal surfaces are unaffected. The result is a barely darker blip three times per second during playback of the image sequence.

I really need aniso specs for this material and simply piping the aniso spec color out to the surface spec input resulted in zero effect, even when I cranked the spec up to 5000%. It only worked when spec color was plugged into surface color, but then the base color turned black and I don't know how you can "add" or multiply two color nodes together.

I will experiment more to see if I can blend two color type nodes together and see if NOT using a Material type node results in the elimination this 'dark frame' cache GI effect.

02-17-2014, 01:51 PM
Colours in nodal are a triplet/vector, so you can add/blend them using the vector tools. As for your specular node... a shader node needs to be plugged to a shading input on the destination node, not one of the colour inputs. I posted more details about this in greg.rayner's recent "shader nodes" thread if you wanna have a peek there.

02-17-2014, 03:40 PM

By 'shading inputs,' you mean scalar (green)? Not understanding why the aniso spec shader has a color output if scalar is the data type used on the specular input on all the other nodes.

Before I got your reply, I plugged the aniso spec node into the bg color of the tools>Mixer node, set the fg color as desired, and plugged the mixer output into the color in on the master surface node. Seems to work ok, albeit the aniso spec is "added" to the standard phong spec of the layer system as I left it set to 80% (60% gloss). So I get a 'combo' spec... aniso + phong. hehe. Not a problem in this case due to the angle of the light... won't see the phong spec on vertical cylinders. Aniso "over powers" phong on horizontal cylinders.

Back on topic... I removed the Standard Material node and plugged the above color, diffuse, and reflection nodes directly into the master surface node and the rerender so far is free of the "darker GI key frame" blips (50 of the 180 frames rendered so far).

02-17-2014, 04:47 PM
Spoke too soon. Now instead of a smidge darker GI keyframe, it's a smidge lighter, but only on the nodal surfaces. Hmmm...

02-17-2014, 05:19 PM
By shading inputs I meant those 4 toward the bottom of the surface destination node labelled diffuse/spec/reflect/refract shading... That's where you plug shaders into. you can connect them to colour inputs (and they use the colour data type) as the CAN deliver basic colour output, but it does give "wrong" results...

If there's still the same problem with things hooked up as they should be in this respect... Id suggest fogging it as a potential bug, whilst perhaps in the meantime just baking out with step 1 to get ur render done.

02-17-2014, 06:50 PM
HA! Didn't see them down there!! Cool. Thanks.

However, something weird is going on. I baked the anim GI cache and never looked in the Radiousity dir. to confirm. But to my "horror" there were MULTIPLE cache.X files, where X is the "keyframe" number. In my case, at a step of 10... cache.0, cache.10... cache.180, etc.

The "Save after each frame" option is NOT checked. So I cleared the cache, but all the numbered files were not deleted. Then I tried baking using a different cache name. No change. Still got a folder full of individual files. Tried with the Save after each frame option ON, still no change. Then OFF, still no change.

I looked thru the general options and don't see a setting I could have inadvertantly set.

Exited, relaunched, etc... still LW 11.6.1 is making multiple files. LW has never done this before. HELP!

02-17-2014, 07:02 PM
That was an 11.6 change... The cache system now saves out a separate file for each stored frame rather than compacting them into one, thats all.

02-17-2014, 07:23 PM
Hmmm... me no like it.

02-17-2014, 10:18 PM
It's nice if your computer crash in a really long time GI calculating scene. You don't lose those hours of calculating as before

02-18-2014, 05:48 AM
OK, after rebaking the GI anim cache and rendering, the GI step frame "flash" is very much still evident. See attached half-rez result MOV.

Any ideas why the GI shading is almost non-existent or of a totally different RPE setting than the interpolated frames (resulting in the shading being lighter on every 10th step frame)?

This is 11.6.1 so I'm wondering if the quote below from the 11.6.2 beta change log is the bug that fixes this issue? Any way to confirm other than stopping, downloading, installing, etc. 11.6.2 and re-rendering it again myself?

"Interpolated radiosity cache is now used when the cache step is more than 1. This makes more sense than using the save radiosity cache feature to trigger radiosity interpolation."