PDA

View Full Version : 11.6.2 beta update: a Valentine's Day gift from LW3dG



jeric_synergy
02-14-2014, 02:09 PM
I guess they do love us: check your accounts for an 11.6.2 beta update. :D

50one
02-14-2014, 03:34 PM
Awesome, ...but why is this open beta? Don't understand?

Phil
02-14-2014, 04:00 PM
Awesome, ...but why is this open beta? Don't understand?

Because it's not quite done yet and they're hoping for bug reports, etc. from users, I would suggest.

mikala
02-14-2014, 04:04 PM
I'm surprised they opened themselves up to the abuse they got the last time they did an open beta.
Very brave people. Thanks

50one
02-14-2014, 04:26 PM
Because it's not quite done yet and they're hoping for bug reports, etc. from users, I would suggest.

I know, but it's bit weird instead of releasing 11.6.2 update and that's it, don't get me wrong not complaining tho:)
I can see lot of fixes with particles, instances and flocking:thumbsup:

Fsoto
02-14-2014, 05:06 PM
Sweet! Thanks Newtek!

jeric_synergy
02-14-2014, 05:33 PM
Well, it's a beta until it's not: you can't release something that hasn't been beta'd and call it "the 11.6.2 update" or there'd be blood in the streets.

Or, worse, bad PR.

sami
02-14-2014, 07:30 PM
http://www.youtube.com/watch?v=YVSAx5BoCo0#t=1m47s

Given that the dev team appears to be in high gear and turning around fogbugz'ed bug fixes quickly (see my reported Lscript bug that was fixed in just a few days of reporting), I'd say news of 11.6.2 is fantastic and if they want to move to a faster release schedule (which I cant confirm), then I'm all for it!

Personally, I would rather support them than rehash stuff 2+ full point versions ago that was probably had different drivers/objectives and different members on the team. In my opinion they are doing great now and much better than years past!

Good work LW3DG!! :D

p.s. i dont really mean to start any big discussion here, just posting to say they ARE fixing bugs and I like where they are headed!

GregMalick
02-14-2014, 09:02 PM
I'm having a problem licensing it. I drag the downloaded LICENSE.LWK onto the Splash Screen, shutdown and restart LW - just comes back and says it can't find the license. Tried a couple times.

Not optimal!


Nevermind... redownloaded key and licensed - all fine now.
I must have downloaded the wrong key.

Snosrap
02-14-2014, 09:49 PM
I think this is great that NT is releasing all these patches. Shows a real commitment to quality. Sending this out to the masses is also smart - the more people that mess with the more chances of things can be found that need attention.

geo_n
02-14-2014, 09:57 PM
Nice work. Some 3dconnexion fixes in there.

sami
02-15-2014, 12:16 AM
I think this is great that NT is releasing all these patches. Shows a real commitment to quality. Sending this out to the masses is also smart - the more people that mess with the more chances of things can be found that need attention.

True. But may I suggest that if a person has a confirmed bug/problem that they fogbugz it with as detailed yet succinct description as possible? It seems it is much easier for the dev group to respond to fogbugzes instead of taking the time to wade through the very long-winded and often digressing forum posts. Report the bug through proper channels and I'm sure they'll fix it. I've been very impressed with their responsiveness via that means.

jeric_synergy
02-15-2014, 12:46 AM
I very much appreciate dot releases, and that's a long list of quashed bugs-- a lot in bits I don't personally use, but generally in the more high-end, pipe-liney end of things that big studios appreciate.

There's so much of LW I've never used that I'm very much satisfied with bug fixes and stabile releases than New! Improved! Whizbang Features!!!! I'm not using the good stuff NOW, new good stuff is wasted on me.

sculptactive
02-15-2014, 01:28 AM
Nice work. Some 3dconnexion fixes in there.

Yep this is great news

spherical
02-15-2014, 01:37 AM
True. But may I suggest that if a person has a confirmed bug/problem that they fogbugz it with as detailed yet succinct description as possible? It seems it is much easier for the dev group to respond to fogbugzes instead of taking the time to wade through the very long-winded and often digressing forum posts. Report the bug through proper channels and I'm sure they'll fix it. I've been very impressed with their responsiveness via that means.

The quality of bug reports that are fogged depends upon proper corroboration by many users who verify that the bug found is reproducible on our end first. Posting and discussing them here is the most efficient way to do that in the shortest period of time. Once the confirmations have come in, fog the bug and reference the thread in the fog, so that the devs can refer to the natty details that all have encountered if need be. Much higher resolution on the problem and less noise from uncorroborated big reports that they have to wade through to no avail, because no one did any peer checking.

Waves of light
02-15-2014, 03:42 AM
Excellent news. Thanks LW3DG.

And this time the email came with a direct link to the Change Log (http://static.lightwave3d.com/downloads/installers/lightwave_11-6/lightwave_11-6-2_change-log_20140214.txt).

50one
02-15-2014, 06:14 AM
Excellent news. Thanks LW3DG.

And this time the email came with a direct link to the Change Log (http://static.lightwave3d.com/downloads/installers/lightwave_11-6/lightwave_11-6-2_change-log_20140214.txt).


Lucky you! i checked my email prefs, register new email address and still not getting any emails...

allabulle
02-15-2014, 07:37 AM
I think this is great that NT is releasing all these patches. Shows a real commitment to quality. Sending this out to the masses is also smart - the more people that mess with the more chances of things can be found that need attention.

Exactly my thoughts. :)

Lewis
02-15-2014, 11:01 AM
Nice set of fixes, congrats LWG3D.

Still now it's time that we all test even more and send as much as possible bug reports so they can squash most of them for final 11.6.2 release.

Waves of light
02-15-2014, 11:08 AM
Lucky you! i checked my email prefs, register new email address and still not getting any emails...


Man, for as long as I have been on here you've had problems with email notifications. Do you have any weird characters in your email address, any spaces at the end in the email box or is the email being blocked at your isp end (i know some isps have spam filters at the route, before they even reach you PC)

Cheers, Ricky.

50one
02-15-2014, 01:06 PM
Man, for as long as I have been on here you've had problems with email notifications. Do you have any weird characters in your email address, any spaces at the end in the email box or is the email being blocked at your isp end (i know some isps have spam filters at the route, before they even reach you PC)

Cheers, Ricky.


Haha, yeah I know:) nope, just a regular gmail account.

Mastoy
02-15-2014, 02:12 PM
Haha, yeah I know:) nope, just a regular gmail account.

I have a gmail account and I never get their emails too ...

adk
02-15-2014, 02:28 PM
Gmail here as well and I get the notifications just fine.
Off to test the 3d Connexion updates. Cheers a bunch LW3DG.

jeric_synergy
02-15-2014, 05:19 PM
..... because no one did any peer checking.
"Peer checking", very good point. I often, but not always, do peer checking, because sometimes I just don't have a good handle on the feature. But if it's one I'm pretty confident on, I'll skip the peer check.

Sample/Example files are also very important, when appropriate. Sometimes explanations are just BAD, some people can't write a bug report, but a sample file can reveal the true issue.

I'd think that 'poison files', files that just mysteriously kill the app, would be desirable too, but I've never quite discerned much interest in them. Don't know why.

spherical
02-15-2014, 05:22 PM
My problem with poison files is that they are usually something I can't send and trying to create one that can be sent that has the same problem never works. I can't even peer check myself.

pinkmouse
02-15-2014, 05:36 PM
And note, they won't even look at anything that uses a third party plugin.

jeric_synergy
02-15-2014, 05:43 PM
The "I can't send it" stuff just makes my eyes roll, like the client's stuff is SO revolutionary that letting it out will, I dunno, bankrupt the company. Riiiiiiiight.

spherical
02-15-2014, 06:59 PM
Posts like that make my eyes roll. You don't know what the IP property is. What's with this kind of stuff, anyway? What's the point of being snarky?

mikala
02-15-2014, 07:04 PM
Posts like that make my eyes roll. You don't know what the IP property is. What's with this kind of stuff, anyway? What's the point of being snarky?

NDA's don't let some of us just throw content around. I guess some don't get that.

spherical
02-15-2014, 07:19 PM
Exactly. When I'm doing work for the NASA Headquarters Office Of The Chief Technologist, I do not release anything until they explicitly sign off on it. Period.

LW_Will
02-15-2014, 09:43 PM
Just checking the obvious... have you guys checked your spam folders in gmail?

Just asking...

gordonrobb
02-16-2014, 01:46 AM
It's not a Europe thing is it? I haven't had any email telling me either. I have Microsoft Ecgange email and use Outlook.

pinkmouse
02-16-2014, 02:12 AM
Might just be Scotland? :)

50one
02-16-2014, 03:23 AM
Just checking the obvious... have you guys checked your spam folders in gmail?

Just asking...

I wish it would be that simple;)

Who knows, maybe it's the location as pinkmouse pointed out;)

Luc_Feri
02-16-2014, 04:39 AM
I was in the same boat as 50one. I started off receiving the first newsletter when I purchased LW and then got maybe one more newsletter then nothing at all ever.

My account was ticked to receive stuff but I never did. Around 3/4 months ago after resaving my preferences in my account, I might have saved a couple of times the account settings, I now receive all newsletters and product update announcements, weird. :D

Snosrap
02-16-2014, 08:57 AM
"Fixed Case 67282: Added the bit-ness and product version number to the Windows Start Menu shortcuts." Thanks NT! A small thing, but something I found myself always having to do it on my own and now I don't have to. :)

JohnMarchant
02-28-2014, 11:27 AM
Well just installed it and of course now i have licensing issues. I got the license.lwk file from my account dragged and dropped, restarted and it still in discovery mode :(:(:(. Any ideas folks :):)
New install and new configs used, still no way out of discovery mode.

hazmat777
02-28-2014, 11:41 AM
Well just installed it and of course now i have licensing issues. I got the license.lwk file from my account dragged and dropped, restarted and it still in discovery mode :(:(:(. Any ideas folks :):)
New install and new configs used, still no way out of discovery mode.

I was able to get out of Discovery Mode by changing the USB port my 9.6.1 dongle was on, but then I launched Modeler and switched back to Layout and the text changed so small I could barely read it.

Thinking of resting from LW for awhile (again).

JohnMarchant
02-28-2014, 11:56 AM
Yeah i feel your pain. If NT cant even get something like this right and the pa lava with configs, menus and everything else, i think i might join you. I do not have my dongle in as i have no plugins that rely on it and as its 11.6.2 it should not need it.

Funny as i did not have an issue before with licensing at all.

Waves of light
03-01-2014, 04:32 AM
John, take a look at this thread: http://forums.newtek.com/showthread.php?139334-Problem-Installing-11-6-1

JohnMarchant
03-01-2014, 05:36 AM
John, take a look at this thread: http://forums.newtek.com/showthread.php?139334-Problem-Installing-11-6-1

Thanks mate, i actually saw it. Eventually i re downloaded LW 11.6.2 and ran it. Opened Layout dropped the license file onto the screen, restarted layout and it worked. Go figure that one. Anyway all seems to work now. I hope LWG3D sort out this and the problems of transferring configs and menu's. The saving tabs is all very well and good but time consuming, there has to be a better way to transfer from on install to another.

Waves of light
03-01-2014, 05:44 AM
Thanks mate, i actually saw it. Eventually i re downloaded LW 11.6.2 and ran it. Opened Layout dropped the license file onto the screen, restarted layout and it worked. Go figure that one. Anyway all seems to work now. I hope LWG3D sort out this and the problems of transferring configs and menu's. The saving tabs is all very well and good but time consuming, there has to be a better way to transfer from on install to another.

I have it down to a fine art now. The problem comes when a new feature is included in an update, like New Colour Pickers, new functions that require a menu/tab entry. If you save out your configs from, say 11.2 and then load them into 11.6.2, it will eradicate any new menu/tab entries.

I now install the new version, set me content directory, point to my plugins, point to my surface directory and then hack the configs to bring in my keyboard shortcuts and RMB/MMB/LMB menus.

I was speaking on skype with another LW user (think it was Michael Wolf) and he pointed me in the direction of one of Kevin Philips' plugins - IF_Tab (http://kevman3d.blogspot.co.nz/2013/12/and-even-more-free-scripts-ho-ho-ho.html) But I couldn't get it to work properly and don't have the time to look into further at the moment. You may have more luck.

Cheers,

Ricky.

JohnMarchant
03-01-2014, 07:24 AM
Thanks Ricky, yeah i had stopped loading IF Tab as it was not working in 11.6 or maybe before. I really hope that Kevin has some time to update some of his scripts, its funny how some of these older scripts and plugins are still handy.

finn_the_human
03-01-2014, 01:58 PM
Does anyone know if this update fixes the bugs with Windows 8.1?

JohnMarchant
03-01-2014, 03:22 PM
Sorry Finn, i could not say as im running W7 64Bit.