View Full Version : Curve keypoints/nodes >>>TO>>> Curve w/evenly distributed nodes???

01-30-2014, 09:55 PM
Say you've got a Curve like the one pictured.
But you are using a plugin that is sensitive to the Curve's nodal points distribution. To get the effect you want, you need a curve:

in the same shape, but
with nodes evenly distributed along the length of the Curve.

How might one accomplish that?


01-30-2014, 11:38 PM
How about Rail Extrude>Uniform Lengths? Get path off of that?

01-31-2014, 01:39 AM
Joe, Immediately upon reading your suggestion I copied the first point in the curve, copied it to a new layer, put the curve in the background, used rail extrude:uniform lengths and BOOM! Modeler crashed.

I'll try again tomorrow.

01-31-2014, 11:15 AM
Seems to do a decent job. A couple more points than the original to try and keep the shape true.

01-31-2014, 11:24 AM
Huh. Did you polygonize that point before extruding? I got a crash twice when I tried.

I expected RailExt to work like Extend on points, but just got a full crash. :(

I'm slightly surprised there isn't a native function to do this, but it would be a fairly simple lscript:


Select first point
copy to new layer
polygonize point (if necessary)
put original Curve in background
rail extrude w/equal lengths

Probably already exists somewhere.

01-31-2014, 12:22 PM
Fully expected to have to polygonize, but turns out, no.

I did get an "error" message: "Source contour contained no edges. Only points were generated."
But, the error message had an "ok" button, so.....

01-31-2014, 02:36 PM
Just gave it another go: see image:

What version of LWM are you using? I'm using 11.6.1, bld2727, Windoze 7

Man, I'd hate to think a CFG file even could have any effect on something like this...
EDIT1: nope, nuked my LWM config files (but only them, 2 files) ---still getting crashes.

Joe, did you line up your point w/the Curve? Come to think of it, the first time I just dup'd the first point of the Curve, so that shouldn't apply.

A bit nonplussed now.... I can work around it, but of course shouldn't have to, and of course I shouldn't be able to crash the app either.

01-31-2014, 03:16 PM
I'm in 9.6. And, no, I didn't line anything up. Just copied the first point like you did.

BUT.... this will work. You just might have to do two extra steps.

Option 1) Did you try the point to poly thing?? that worked for me too, you just copy the points of the new poly chain into another layer and make open curve.

Option 2) make a teeny weeny tiny poly (this you might want to line up, but that's just one click too)>rail extrude that > select an edge> switch to points> copy/paste to another layer> lasso select all points at once > create open curve.

01-31-2014, 03:43 PM
Yeah, like I said, if I polygonized the point, it worked fine. For the tests, I didn't always use the first point, but that shouldn't matter.

BUT, it should not be possible to crash the app with simple steps, and this is about as simple as things get.

AND, it used to work, as in your 9.6. Although I'd prefer if....OOO HOh!!! I was gonna type "worked like EXTEND does when you Extend a point", but I double checked and using EXTEND on a single non-polygonized point ALSO crashed LWM. It's interesting in that LWM doesn't crash until you attempt to Move the new point.

(#2 is clever but unnecessary: a 1-point poly works fine.)

Just for fun I'm attaching the DMP file generated by this crash.


68250 (Open) LWM: Rail Extrude on single point, crash
68251 (Open) LWM: crash on EXTEND on single point