PDA

View Full Version : Python version?



sami
01-16-2014, 08:30 PM
Dumb question as I've probably already asked this before (but cant find it) and haven't really started porting/rewriting old LScripts to Python until now, but what version of Python works with LW 11.6.1 ?

i.e. do I install Python 2.7 or can I install Python 3.3 ? Or do I not need to install anything - does LW 11.6.1 install it? And if so, can I use v3.3 Python language features in LW scripts?

thanks :)

tayotain2
01-18-2014, 06:48 AM
I think its 2.7.

sami
01-19-2014, 10:59 PM
Thanks :)

Is 2.7 installed by Lightwave automatically? Does having 3.3 on your system conflict with it in any way?

clintonman
01-21-2014, 05:33 PM
Lightwave installs it's own python and no other python installs will conflict with it. Here is a page that shows how to get the python version info:
http://www.lawson3d.com/lwpywiki/index.php?title=Getting_Started

sami
01-21-2014, 08:35 PM
Lightwave installs it's own python and no other python installs will conflict with it. Here is a page that shows how to get the python version info:
http://www.lawson3d.com/lwpywiki/index.php?title=Getting_Started

thanks!

Celshader
04-16-2014, 02:33 PM
I realize this thread is a few months old, but I want to note that the PCore Console reports what version of Python it's using when you first launch it. I have attached a screengrab here:

121475

sami
04-25-2014, 06:19 PM
I realize this thread is a few months old, but I want to note that the PCore Console reports what version of Python it's using when you first launch it. I have attached a screengrab here:

121475

Thanks! I eventually found that - but I have a feeling it is new to 11.6.2 and wasn't in the earlier builds before 11.whatever I was using when I asked - but I totally could have missed it... :)