PDA

View Full Version : Change 24 hour clock to 12 hour clock in LiveText



frank.leggett
01-15-2014, 07:45 AM
Hi,

Please can someone tell me how to get LiveText to display the time as a 12 Hour clock instead of a 24 Hour clock, I'm using %Time% and my windows clock is set to 12 hour.

Regards
Frank

m4a2000
01-17-2014, 02:26 PM
Try this: %Time(hh)%:%Time(MM)%:%Time(SS)%

frank.leggett
01-18-2014, 07:51 AM
I'm afraid this didn't work. Is there no simple way?

m4a2000
01-18-2014, 03:01 PM
Dose %Time(hh)% work? That should give you 24 hour hours.

kanep
01-18-2014, 03:14 PM
Perhaps I'm not understanding correctly. When I put in %Time% into LiveText, I get a 12 hour clock. Are you looking for it to be 24 hours?

frank.leggett
01-19-2014, 04:08 AM
Thanks Kanep,

I do the same and get a 24 hour clock. I have changed the windows clock setting to 12 hour but that made no difference. My previous laptop did it OK but that was a Win 7 and the new laptop is Win 8.

So to confirm I want the time displayed as 2.00:00 NOT 14.00:00.

kanep
01-19-2014, 09:05 AM
It looks like this setting is controlled by the 'Region and Language' settings found in Control Panels. I don't know if it makes a difference, but I'm using LiveText 2.57.

frank.leggett
01-19-2014, 10:15 PM
Brilliant that worked, just got to get rid of the am pm now as I'm pretty sure every one watching the screen at the venue now sits 2:00 in the afternoon and not 2:00 the morning.

Update I've done it using the above suggestion "%Time(hh)%:%Time(MM)%:%Time(SS)%" but it didn't work just by typing this in I had to call up the variables from the list to make it work.

Thanks for all your assistance.

frank.leggett
01-21-2014, 07:03 AM
Sorry I checked this to early. This afternoon it is still showing 24 hour time e.g. 13:41:20 and the time settings in windows for long and short time are both set to h:mm:ss. Somewhere Livetext is getting it's display settings from somewhere else. I can get it to display 1:41:20 PM but I can't get it to display 1:41.20, I have tried %Time (hh)%:%Time (MM)%:%Time (SS)% but that just shows 24 hour.

kanep
01-21-2014, 09:01 AM
I think I get that you are looking for. You want the Time (hours:minutes:seconds), but without the AM/PM on the end.

Here is how you can get this.

In Control Panels -> Region and Language. Click on the 'Additional Settings...' button at the bottom.

In the new window, click on the 'Time' tab.

Under the 'Long time' field you can manually edit the time format. Here is what the characters mean.

h = hours (12 hour)
H = hours (24 hour)
m = minute
s = second
t = AM or PM

Edit the long time to 'hh:mm:ss'. LiveText should follow this new format using the %Time% DataLink field.

frank.leggett
01-21-2014, 10:38 AM
Thanks Kane,

It is now displaying the time without the AM or PM and in 12 hour mode.

Thanks

m4a2000
01-22-2014, 11:20 AM
Sorry. I thought you want 24 not 12.