PDA

View Full Version : Enable Instance Info - Index ID for nodal access in clipmaps...



adk
01-12-2014, 08:05 PM
Heya LW3DG folks,

Just wondering if there's any chance of enabling access of Instance Info - Index ID so that it enumerates and one can access it via Denis's -Texture Node Editor?
Using transparency works but you need crazy ray recursion limits not to mention it's totally inefficient for this sort of thing.

GIF shows that what I'm trying to achieve. This uses one object & one surface and it's meant to be for building facades rather than the volume shown.

And the other is the same node setup replicated via Clipmap & the node setup = does not work.

It's about time clipmaps got a total overhaul imho. Pretty please.

adk

PS: I'll try this with discrete parts per skin as opposed to instancing them but I hazzard a guess that that might also not work.
PSS: Just tried the above using Denis's part info / move & as suspected does not work.

dpont
01-13-2014, 01:59 AM
Node Texture node editor ("Node Texture") has no LW11 version for taking account of LW Instancing system,
because you have now a native Texture Node editor in LW11 ("Node Editor"),
indeed DP Instancer Instance Info node doesn't work in the Clip Map context,
DP Instancer Instance Info is not ready to work for ClipMap
for the moment and its interface is not correct.
I can't see a proper Instance ID returned by Layout in this context.


Part Move node needs some geometry access and info
which are not accessible in a Texture, only in nodal displacement and surfacing,
while the preprocess is done, the evaluation is not possible.

Denis.

adk
01-13-2014, 05:11 AM
Node Texture node editor ("Node Texture") has no LW11 version for taking account of LW Instancing system,
because you have now a native Texture Node editor in LW11 ("Node Editor"),
indeed DP Instancer Instance Info node doesn't work in the Clip Map context,
DP Instancer Instance Info is not ready to work for ClipMap
for the moment and its interface is not correct.
I can't see a proper Instance ID returned by Layout in this context.


Part Move node needs some geometry access and info
which are not accessible in a Texture, only in nodal displacement and surfacing,
while the preprocess is done, the evaluation is not possible.

Denis.

Thanks for chiming in here Denis.
It appears that I am using the native Node Editor in this case then (pic attached).
Apologies for the mix up as previously I recall that the only way to access nodes in clipmaps was via a procedural texture with you node.
I assumed incorrectly that this was again the case.

In this example I'm just using native LW instancing, not DP Instancer & the part move trial was just a test to see if I could do this another way.
Thanks for explaining the technical bits on why none of these work in those contexts.

I guess the ball is in NT's court with regard to clipmaps ... hopefully as a surface/object attribute as that appears to be the only solution. To my non-technical mind anyway.
I know that this is a long standing issue that's been beaten to death in various threads, but it would be good to know if there's perhaps some progress we can expect with regard to clipmaps?

jameswillmott
01-13-2014, 06:04 AM
Have you filed this as a Fogbugz report?

adk
01-13-2014, 06:17 AM
Have you filed this as a Fogbugz report?

Nope, but I will now James. Just let me simplify the scene and get it better organised. Cheers.

jameswillmott
01-13-2014, 06:18 AM
Excellent, thanks!