View Full Version : Split Bone not working

01-06-2014, 06:36 PM
The Split Bone tool is not working. I have a bone that I want to split, and when I try and use the tool, whether it's activated or not, it doesn't work. If I make a child bone, the child bone is fine. The troublesome bone was originally a skeleton, if that helps.

01-06-2014, 07:24 PM
Is it working with other bones for you? That may determine if it's a problem with Split Bone or with your skeleton. Create a null, add a bone, and test it on that 'rig'.

Split Bone is working here. Click anywhere on a bone once to select it and then click the red line in the middle of the bone to split it. I seem to recall that this behavior was a change from a previous release some time ago, which confused me at the time.

Hope this helps.


01-07-2014, 07:04 AM
When I create a child bone it works.

01-07-2014, 07:12 AM
I just split bones along a spline and worked well. What more, the newly split bone conform to the spline!

01-07-2014, 08:11 AM
@SonicN2O, That's weird. Can you upload the scene file with the troublesome bone in it? I don't think I've seen that behavior before.

Just to be clear, are you talking about Split Bones for Bones in Layout or for Split Bones for Skelegons in Modeler? Not that it should matter--either one seems to be working here but I was just wondering.

Oh, yeah, and which version of LightWave are you using? Which platform? I'm running 11.6 x64 for Windows.


01-07-2014, 08:22 AM
Layout with Bones. I'm using 11.5 I think...

01-07-2014, 08:25 AM
I think it has to do with the fact that they were originally skelegons. I just made a null with a bone and the tool worked fine.
The rig I was having problems with is so simple that I've decided that it's not worth the effort to make it IK and therefore I don't need to use the tool. It was originally intended as an FK rig and I was trying to adapt it, so I had to split a bone.

01-07-2014, 09:42 AM
Once a skelegon has been converted to a Bone, it's no different than any other Bone, so that seems unlikely.

(But, stranger things have happened.)

01-07-2014, 09:54 AM
Yeah, it is strange. As Jeric said, converted Skelegons are just Bones, so they shouldn't behave any differently.

FWIW, I just tried converting a Skelegon in 11.5 Layout and Split Bone worked. Probably worth mentioning that at first I thought it wasn't working--Split Bone did nothing when I clicked on the bone. But then I noticed that I was actually clicking on the null generated by Convert Skelegon. When I 'opened' the null in Scene Editor and selected the bone directly, then I was able to split it. That's probably not what you're running into but I thought it should mention it just in case.

If that's not the cause, I might suspect a problem with the scene file or your configs. But, yeah, it's probably a lot easier to just start over.