PDA

View Full Version : Trackball problems w/ Logitech M570



Ma3rk
01-05-2014, 11:02 AM
I'm posting this as it turns out this problem is a lot more widespread than I'd imagined. I'm open to alternatives but there doesn't seem to be any.

The problem is with the LMB and dragging in particular. In Lightwave, I'll select something to move and as I'm dragging it to a new position, it'll instantly switch to some other item behind what I'm trying to move. I then have to undo and try again very slowly as at normal working speed it'll almost invariably do it again. Very productive.

In Illustrator, it's nearly ridiculous to work with. A single LMB click will often act like a double click making tool selection impossible. Trying to drag a symbol onto the artboard is an exercise in frustration. Similarly with trying to drag select items such as a line of text.

I've used trackballs for decades and had to replace one awhile back when it died mid drag. The only model offered now days by Logitech is their M570. When I first got it, I loved it. Silky smooth, tiny RF receiver, longer battery life, etc.

I didn't notice any problem at first and when I did I just thought it was me. I only seemed to happen with Lightwave which was going through various updates. When it kept happening and began I noticing it outside of Lightwave, I started experimenting with different settings, updated drivers, etc. but nothing helped. A couple days ago, I switched it to a different system and the problems persisted.

I went onto Logitechs forums and was flabbergasted at all the hits I got for this same problem. And it's been going on for some time (years) yet Logitech seems to be just sitting on their collective thumbs while still selling the M570. Their tech support response was quite lame and a temporary band-aid solution at best.

If your interested in reading more, here's the link to the main thread. You'll need to be registered on their forum of course:

http://forums.logitech.com/t5/Mice-and-Pointing-Devices/The-M570-Trackball-LB-RB-Bugged-Click-Thread/td-p/1050449

In any case, what are others using for their rodentia? Mind you, it needs to be trackball like and 3-button in order to do middle button drag/select/menu capable in Layout.

Thanks.

Phil
01-05-2014, 11:23 AM
I've got an M570 here; it's probably been in my hands since just after it was released commercially - so that's over three years ago. It's been pretty good although I have to admit that cleaning off the ball supports is annoying. Battery life is incredible, though. I also have a lovely Logitech Performance MX laser mouse for occasions where the trackball doesn't suit (e.g. gaming) - my old MX Revolution had microswitch failure and replacement/repair is non-trivial as, like so many things, Logitech opted to glue it all together.

spherical
01-05-2014, 04:40 PM
I have a wired version that they'll have to pry form my cold hands if it lasts longer than I do. Why they stopped making USB connected versions is beyond me. Ummm.... it's a trackball. It doesn't move. Wireless is a useless extra set of points of failure. Besides, we have enough wireless stuff around here that needs to be. Crosstalk is going to be an issue sooner or later. Already has been once.

My SO's wireless TrackMan FX went ball-up some time back and we got her a wired replacement but when I work on her machine installing stuff and fixing problems, I can't stand the center ball placement of the new one (mine is at my thumb). I've been using thumb trackballs since they were serial port and the ball was light cyan. Now, in order to replace this, I'm looking at stupid prices at Amazon, if they still have any.

On to the dropping selection issue: I haven't had any problems with LW but one application that I do have the many-click issue with is iTunes. Scrolling the apps window by a single click works the first time. The second click and it sequence jumps all the way to the last screen. Really annoying. Never found a cause or workaround and it, so far, is the only application where the problem arises.

What your issue sounds like is that the micro switch has become momentary from use. The contacts have built up a resistive coating, worn off or dusty and the circuit is broken unexpectedly. Either that or the cable conductors are broken inside the sheath or USB plug needs some rework in order to maintain better contact.

Ma3rk
01-06-2014, 12:07 AM
In a posting on the Logitech forum just today, one person mentions being on his 5th M570. Another post mentions an entirely different model having the same issues. The common element is that they both use the same micro switches from an outside vendor. That's what I'm suspecting is the true culprit.

In my case, I bought the M570 in July 2012 and started to notice quirks a few months later even after light use. So, it's not that old nor had anywhere near the use of the others I've owned. I presently have 3 total; one wired easily over 10 years, a wireless probably 5-6 years, and then this new one that's having issues.

Phil
01-06-2014, 08:15 AM
I have a wired version that they'll have to pry form my cold hands if it lasts longer than I do. Why they stopped making USB connected versions is beyond me. Ummm.... it's a trackball. It doesn't move. Wireless is a useless extra set of points of failure. Besides, we have enough wireless stuff around here that needs to be. Crosstalk is going to be an issue sooner or later. Already has been once.

I have come to like the wireless. I've had mice die due to cable failure (particularly when travelling), so wireless is more robust in that sense. I'm a little surprised that they didn't go with Bluetooth, though.

Jimtee
03-07-2017, 08:37 PM
I too had the left click problem and finally found tear down help. I found the post that actuates the left click switch has a molded in depression in the area of contact with the switch plunger. I stuck a tiny square of plastic electrical tape in that depression. The tape thickness measures 0.0066 inches. I reassembled the case and have had not one lost drag or had an unwanted double click since. The left click also feels much better now. I probably should have done the same fix to the right click as well but so far have not had trouble there. Jimtee