PDA

View Full Version : Objects disappear in render



kdreiopzet
12-11-2013, 11:47 PM
I am working in layout v 11, when i work in perpective, wire frame, texture solid, it all works. But when i try viewing a preview in viper or rendering, some objects disapear.
Example i have a spaceship, i made it into seperate parts. The body, the wings, thrusters, and cannons. In regular wireframe or texture solid everything seems normal but when i selevt viper mode or rencer the whole BODY is missing, all the other parts are just floating around it. If i could get some help that be great, my project is due tomorrow... so its kinda urgent. Any sort of help tips would be much help.

prometheus
12-12-2013, 12:43 AM
I am working in layout v 11, when i work in perpective, wire frame, texture solid, it all works. But when i try viewing a preview in viper or rendering, some objects disapear.
Example i have a spaceship, i made it into seperate parts. The body, the wings, thrusters, and cannons. In regular wireframe or texture solid everything seems normal but when i selevt viper mode or rencer the whole BODY is missing, all the other parts are just floating around it. If i could get some help that be great, my project is due tomorrow... so its kinda urgent. Any sort of help tips would be much help.

hmm..hard to tell, how are the parts splitted? layers, or unconnected parts in the same layer?
might want to check use double sided for all surfaces, you could select all surfaces in layout and check double sided, might be that the body part has flipped poly´s?
and which object format are you using? premade lwo object, or some spaceship downloaded in other format?
downloading objects in obj, or fbx might cause such issues, and might need to be corrected.

you could check in modeler too, select all parts of the item, and go to preferences,display, and make sure to check the show normals, that
will give a visual to which direction all polys are facing.

Michael

Danner
12-12-2013, 01:28 AM
Things I'd check

In Layout:
1. Scene Editor/dope sheet, is there a checkmark on your object?
2. Object properties, is Seen by camera on?

If that didn't fix it..

Modeler: (in order)
1. Merge points, unify poligons
2. Delete 1 point and 2 point poligons
3. Select non-planars and triple them. Sometimes after tripling them there are still some left, those are garbage, delete them.

kdreiopzet
12-12-2013, 11:55 AM
Thank you guys. The problem was the scene editor. It was unchecked. This was driving me crazy, something so small took me hours. Thanks!!!!!!!!!!!!!!!!!!!!!!!!