View Full Version : How to render Flocking on LWSN?

12-04-2013, 09:49 AM
I'm trying to render my flock animation but the render farm just won't render flocks. I've checked use cache but that does nothing at all. Also reopening the scene doesn't show the cache file. I've to resimulate every time I open the scene.
I tried baking the instances connected to the flock but that doesn't bake the rotation. I also tried to use particle scan to cache it into a pfx file but that also doesn't show the rotation.

Is it even possible to render flocks with LWSN?
I really need a solution fast because the deadline is closing in.
Does any one know how to render flocks with the right rotation etc on LWSN?

12-04-2013, 11:40 AM
Worked for me.

Clicked 'Save Cache' to save a file.
Enabled 'Use Cache'.

Scene re-loaded with the Flock behaving as I expected based on my cache and it rendered on the farm correctly.

12-04-2013, 12:01 PM
Oh that's strange. Are you using 11.6 like me? I've got a flock traveling over a path. Is that working for you as well?

12-04-2013, 12:15 PM
I tested this in 11.5.1 and 11.6.0.

Both worked though my mockup was really simple.

12-04-2013, 12:38 PM
I tested it in 1.5.1 and it's working there. (locally) The only problem is that the farm is running 11.6 and rendering the 11.5.1 scene in 11.6 on the farm has the same result as rendering the 11.6 scene. Tomorrow I'm going to make some little testing scenes. For now I've no clue what the problem might be.

Good to know it works on your setup.

12-04-2013, 12:53 PM
Hm, maybe mixing scene versions and lwsn versions is the problem? I created my tests from scratch and when I submit shots it automatically detects which lwsn version to launch. We don't mix scene and render engines.

12-04-2013, 01:12 PM
I only used 11.6 when working on the scene. I checked if 11.5.1 did use the cache generated by 11.5.1 but when loading the 11.6 cache in 11.5 LW crashed. I don't know if its possible to install multiple versions of LW on the farm. I'm using butterfly on the farm. The pity is that the 11.6 results look way cooler than the 11.5.1 ones.

12-04-2013, 01:17 PM
Been awhile since I used BNR... With Rush we just tell Rush which lwsn to launch via scripts.

12-04-2013, 03:23 PM
How do you like Rush? Does it play nice with lightwave? Can your just throw in a scene without having to manually point to the config and output directory?

12-04-2013, 03:30 PM
I only use Rush, don't have any experience setting it up. We have IT ppl that deal with that. 8)

I submit scenes to Rush via a custom lscript that then invokes the necessary Rush scripts and passes along the necessary information. So in that regard, yes I don't have to manually do anything.

It's been great in working with our LW/AE files. It's pretty much like any other render controller, it just invokes the command line.

12-09-2013, 04:28 AM
I have the same problem. The path of the flock cache is not stored inside of the lws file. So how does LightWave know where to get it from?

12-09-2013, 05:22 AM
Save the cache inside the content directory structure somewhere and it should be found correctly. If there are still issues, put in a fogbugz report asap so we can fix it!

12-09-2013, 05:48 AM
Thanks. Done.

12-09-2013, 06:23 AM
So I've struggled with this problem whole week. I loaded the scene on a render node to render it locally. Guess what happened!? The rendernode did save the cache file and reopened the scene like it should. Now it also works on the render farm.
There is definitely something wrong with the flocking cache save function in 11.6.

SaT. Did you fogbugz it already?

12-09-2013, 06:38 AM
Hi 3DGFXStudios,

yes I have done it already.

12-09-2013, 06:53 AM
I've checked the scene file in note pad and found:


RenderRangeType 0
FirstFrame 69
LastFrame 350
FrameStep 1
RenderRangeObject 0
RenderRangeArbitrary 1-120
PreviewFirstFrame 0
PreviewLastFrame 350
PreviewFrameStep 1
CurrentFrame 86
FramesPerSecond 25
ChangeScene 0
Plugin MasterHandler 1 FlockMaster
UseCache 1
CacheFilename "ynamics\\Flock_v002.fcache"
StartTime 0
EndTime 14

Note the missing "D" in the word dynamics?

So problem found....but not solved...

12-09-2013, 10:29 AM
Was this an auto-generated directory, created by Layout?

If you designate the directory manually, is it correctly entered into the scene file?

12-09-2013, 11:33 AM
It was an auto-generated dir but I've pointed LW a lot of times to it but I think it's always a relative to the content dir. I haven't tried to save it in a different dir yet.

12-09-2013, 04:33 PM
Any idea as to how the "D" went missing?

12-19-2013, 07:24 PM
I've had the same problem, and someone stole my D, too! I wondered why I couldn't even find it in LW when loading file, but I could see it in Windows explorer. Hopefully, this will make a difference.

03-28-2014, 01:12 PM
Is anybody having trouble with network rendering Flocking with 11.6.2? I can render Flocking perfectly fine locally but nothing happens when I send files to the farm at my current workplace. I checked the scene files in a text editor and the correct CacheFilename path is there, so I'm stumped.

We're using Deadline here. I'm going to try this at home this weekend using BNR 5.


03-28-2014, 01:16 PM
One thing I noticed is that the CacheFilename path is using double forward slashes instead of single back slashes like every other entry in the file. Could that be the problem? (Using Win 7, if that matters.)

I guess I could just change the entry in the text editor and try submitting the modified scene. Will try that later today.


03-28-2014, 01:31 PM
Nah. When I manually edit the path to have single back slashes, the scene no longer loads the cache when it's opened in Layout. I'm almost sure it won't load the cache on the farm now but will check that later.

03-28-2014, 04:41 PM

Sorry for the OT...

Re. multiple versions of LW in BNR... yes you can. If you have BNR 5 it's simply a matter or running the Add New Platform Wizard and changing the shared BNR folder where all the LW files are copied to. I have 11.0 and 11.6.2. Only thing is, BNR doesn't auto-sense scene versions. You have to know what version of LW the scene was created/edited/maintained with and select the platform (LW version) you want to render the scene with. I identify scene versions by appending the scene file name with "11_0_3" or "11_6_2" etc.

Why do I use both? Cuz 11.6.1 changed the way radiosity is cached from a single file to one file per frame/step. In 11.6.1 this resulted in a one-frame visual "pop" in GI shading values (lightness/darkness) at every frame/step. That is, if I baked GI every 10th frame, a cache file was created for every 10th frame. When rendered, every 10th frame was just a tad lighter/darker than all the in between frames (depending on scene lighting, view, and GI calcs). So, I went back to 11.0's single GI cache system for the current client project I'm working on for the last month and a half. Never good to change versions mid-project. In my case I didn't. I changed between projects, but used previous 11.0 scenes to build new 11.6 scenes for the new project when I discovered the GI 'glitching.'

Anyway, don't remember if BNR 4 can do multiple LWSN versions, but don't see why not.

03-28-2014, 07:21 PM
A while back, I was using both 10 and 11.5x at my home studio because I needed to re-render 'Happy Box' at HD res--it was created in 10, and it looked totally different in 11.x (sorry, don't know which version of 11 I was using at the time.) I was still using BNR 4 back then so yes, you can run multiple versions with it.