PDA

View Full Version : 11.6 gradient stuck in Linear colour space?



raw-m
11-17-2013, 11:45 AM
Anyone having trouble with the Gradient node in the colour channels? Seems to be stuck in Linear colour space not matter what the input is. If I attached a db&w Colour Space node to the output and map it to sRGB I get what I was expecting.

Checked CS settings elsewhere and all is good. Everything else behaves as expected. Anyone conform and I'll fogz it if an issue for everyone else.

RebelHill
11-17-2013, 12:59 PM
Yeah... known (and reported) bug going back a ways. its not only gradient, but other nodes as I recall... colour mixer I believe also suffers.

Only way round it is, as you say, connect a colour correction node on the inbetween.

raw-m
11-18-2013, 03:27 AM
Surprised those slipped through the net for release! Roll on the update...

RebelHill
11-18-2013, 11:18 AM
Yeah...

I reported it, like... 15 months ago.

...

pinkmouse
11-18-2013, 12:24 PM
It would actually be quite nice to have a drop down in the gradient node that gives you the option of using any colourspace, that way you could use linear gradients for nodal motion in a sRGB render setup.

raw-m
11-18-2013, 12:27 PM
Really like that idea! Would be really useful when using colour channels for Displacements!

raw-m
04-07-2014, 03:28 AM
[I thought I'd bring an old post back from the dead rather than open another.]

On 11.6.2 and still the same story for the Gradient Node still being in Linear Colour Space. My question now is, is that's the way it's going to be?

I don't mind if it is (as mentioned, great for displacements) but I'd expect a native colour conversion tool rather than rely on db&w's Colour Space tool. I'd just rather get an official yes/no as I'd like to try and future-proof my object files where I can and not have to strip out unnecessary nodes in future LW updates.