PDA

View Full Version : Editing Boned Model -pics inside



A.Russell
11-15-2003, 01:24 AM
I am using a motion capture animation package called Life Forms. Unfortunately the company that produces it offer no support whatsoever.

After animating in Life Forms, the bones come back into Lightwave looking like this:

http://www.clubvarie.com/Pictures/bonebackward1.jpg http://www.clubvarie.com/Pictures/bonebackward2.jpg

An extra bone with a null on the end of it has been added to the root bone of my original model. The documentation then says to replace the null with the mesh, and the mesh will be attached to the bones. It is, however it is around backward and at a different height.

I haven't found a way to get the mesh back onto the bones properly. I've tried sending the model with its new, backward bones back to modeler for editing, but this doesn't seem possible. I can get the mesh back into in modelerby saving transformed object in Layout, but the bones are gone.

I think Life Forms should really answer this question, but I've mailed their support twice in just over a week now, and they don't reply. Funny, they were quick to reply when I had pre-sales questions. Anyway. if anyone knows what to do about this, and can save me tearing any more hair out, I'd be very happy.

Axis3d
11-15-2003, 06:44 PM
Hi, A.Russell

This situation is much easier to solve than you think. It is really just a matter of unresting the bones, repositioning all of them, creating a key for them at 0, then resting them again. The whole procedure is described in detail at this link: http://www.geocities.com/rgkovach/mocap_tut.htm

It sounds basically like the LifeForms export - a null object with the skeleton attached, then you replace the null with the object. This should help.

A.Russell
11-15-2003, 09:19 PM
I haven't had achance to go through it all yet, Axis, but it looks like exactly what I was after. Thank you very much.