View Full Version : This can't be right

11-14-2003, 06:38 PM
When I go to edit an image in photoshop while still having Lightwave open with the image loaded into the scene, if I then try and save the image in Photshop it tells me it can't because it's in use. Obviously it's in use in Lightwave but I'm pretty sure I never used to have this problem when I used Lightwave 5.5. How are you possibly meant to experiment with images if you can't do things on the fly like that, please don't tell me you have to close down Lightwave each time. Is it Windows XP or something, they're must be a way of changing it so it doesn't do this. I'm probably being really stupid but please help.


11-14-2003, 06:47 PM
The easy answer could be that the lightwave uses the image not a instance of it like photoshop does. So when you have the image in use or loaded in Lightwave and you try to access photoshop is trying to make a copy or instance so you can edit it but it is getting an access denied message from windows as of course LW has control of it. I would suggest you either deselect it from your object and choose a place holder texture then try again or delete it from your Image Editor list then try again and if that does not work I'm out of ideas short of calling Newtek.

John Fornasar
11-14-2003, 08:36 PM
It might be your setup or OS...

I just tried it, Win2000, LW7.5, PS 6 and it worked fine...
opened .jpg in PS, changed it and saved ok... then Image Editor, Replace and had the new pic in LW, with it still open in PS

11-15-2003, 12:05 AM
I sometimes have this problem with Lightwave. It grabs a file and then refuses to let go of it. Sometimes what I do to fix it is to save it into another file format in Photoshop and then use replace under image editor to swap it out. Usually then I will no longer have any trouble.

11-15-2003, 04:27 AM
when it comes to Image managment, LW is the bad guy....

Read my post....

11-15-2003, 06:40 AM
Thanks for the replies. I can't believe Lightwave can be that rubbish. I'm going to try the things you just said see if I get any joy.

11-15-2003, 07:04 AM
I'm confused. If I make a new version of the texture in PS say by putting 02 at the end of the file name, then load that into Lightwave I can the adjust it in PS and save out no probs. But I then tried to do the same with the original texture. I kept Lightwave and PS open but deleted the texture from Lightwave and had it open in PS. If I then re-loaded it back into Lightwave while still having it open in PS and tried to then save over in PS it would come up with the same message. How is this different to creating a new texture I don't get why windows had a prob with that first image?

I Just tried out of curiosty to save over the bumpmap version of the same image. I made all the images at the same time so it's been in Lightwave along with the colour image. If I open PS and try and do the same thing to that, it will let me, so what is it with this one colour image?

11-16-2003, 05:29 PM
I have had this problem, but only with TGA's and only photoshop has this problem. If I use any other format it works fine. I think it must be at the photoshop end, because I've had this with other packages other than LW. Try another format.