PDA

View Full Version : Weird render error when using simple skin, or skin material.



ksunde
09-15-2013, 04:11 AM
Hello, I'm returning to lightwave after a 18 year Hiatus. I have mainly used Maya and 3D studio max, but thought I may as well upgrade my 5.5 to 11.6 and use it as a freelance artist.

This afternoon I did a head sculpt in zbrush 4r6 and wanted to texture it in Lightwave. If I use the fast skin shader I really don't get what I'm looking for and it doesn't render correctly in VPR. So I've been trying to use the simple skin shader or the skin shader and In the VPR window and render window I get the same thing, a big patch on my models face, and 80% of the object is the default diffuse grey.

The screenshot I've provided I haven't done anything to the scene, just loaded the character head into Lightwave, opened the surface node and connected the simple skin to the material. Everything is at the default level. I've checked my maps and there is no Alpha. If I just use the default surface shader and apply a texture the model looks completely fine (except no SSS of course). So I'm pretty sure it's not the maps. I've looked at the map generation settings in Zbrush from other tutorial videos and I'm using the same settings as the tutorial (http://www.youtube.com/watch?v=lzntw-H-KfI).

Again everything is on a default setting. I get the same error in lightwave 11.5 and 11.6.

117109

Thanks for any help anyone can provide.

Cheers,
Kent

djwaterman
09-15-2013, 06:36 AM
Its hard to say what we're looking at here. I would suggest throwing in a simple sphere object into the scene that is the same size as the head and applying the same surface to it, just to make sure that the shader actually works.

The next thing I would try is to make radical changes to the shader node's settings, just to get some idea of what is going on. It could be a epidermis distance issue but I'm not heavily experienced with this. These shaders don't display in VPR either. (Edit; I got this wrong)

Must be frustrating to have such a nice sculpt and not be able to render it.

ALPforce
09-15-2013, 09:17 AM
what is the size (bounding box) of your model ? I will try to replicate the error ...

ksunde
09-15-2013, 06:17 PM
what is the size (bounding box) of your model ? I will try to replicate the error ...

The object was about 110m x 90m x 90m, I've scaled to a real world size, and it still has the error. The button Exclude from VStack appears to help it some, but not all the way

Hail
09-15-2013, 06:38 PM
Hello, I'm returning to lightwave after a 18 year Hiatus. I have mainly used Maya and 3D studio max, but thought I may as well upgrade my 5.5 to 11.6 and use it as a freelance artist.

This afternoon I did a head sculpt in zbrush 4r6 and wanted to texture it in Lightwave. If I use the fast skin shader I really don't get what I'm looking for and it doesn't render correctly in VPR. So I've been trying to use the simple skin shader or the skin shader and In the VPR window and render window I get the same thing, a big patch on my models face, and 80% of the object is the default diffuse grey.

The screenshot I've provided I haven't done anything to the scene, just loaded the character head into Lightwave, opened the surface node and connected the simple skin to the material. Everything is at the default level. I've checked my maps and there is no Alpha. If I just use the default surface shader and apply a texture the model looks completely fine (except no SSS of course). So I'm pretty sure it's not the maps. I've looked at the map generation settings in Zbrush from other tutorial videos and I'm using the same settings as the tutorial (http://www.youtube.com/watch?v=lzntw-H-KfI).

Again everything is on a default setting. I get the same error in lightwave 11.5 and 11.6.

117109

Thanks for any help anyone can provide.

Cheers,
Kent

Fast skin and simple skin can be quiet tricky to get to look right and they often don't render accurately in VPR.
Use "Skin" material node, it is very easy and straight forward to set up and also more predictable and renders quiet fast and well in VPR

ksunde
09-15-2013, 07:39 PM
Fast skin and simple skin can be quiet tricky to get to look right and they often don't render accurately in VPR.
Use "Skin" material node, it is very easy and straight forward to set up and also more predictable and renders quiet fast and well in VPR

The Skin material node gives me the same result. The only one that sort of works (renders) is the fast skin. The renders of simple skin and skin look the same rendered as they do in VPR, at first I assumed that VPR didn't support SSS like the 3DS realistic mode and maya's viewport 2.

Dodgy
09-16-2013, 01:40 AM
That normal map looks like a world space normal map, while LW uses Tangent space normal maps. You can tell the difference because TSNMs tend to be a light blue overall. You should be able to export the correct map from Zbrush by playing around with the export settings. Also, LW has its y normal channel inverted in comparison to other packages, so check that is on.

Danner
09-16-2013, 01:58 AM
... The button Exclude from VStack appears to help it some, but not all the way

Exclude from VStack is a legacy button, designed to let refraction on surfaces from older versions of lightwave behave as it did before. That makes me think it has something to do with your ray recursion limit, have you tried a higher number? (eg. 10). Increasing shading samples might also help.

ksunde
09-16-2013, 04:34 AM
Thanks for all the suggestions everyone.

I'm still getting the error after I've implemented all of the advice given in this thread.

In the picture attached I have 3 heads; the first head is a pure mesh with no UVs and has simple skin material applied to it. The second mesh is a simple skin material with some rough textures applied to it. And the last head, is an OBJ import of the 2nd head with the Skin material, with no texture maps at all applied to it (no displacement, or normal map).

The first head is exactly what we would want to see here, SSS is working throughout the entire model. The second and third head are rendering the SSS, but not throughout the entire object. The only real difference between the 1st and 3rd head, is the 3rd has UVs and is a different base mesh (the first being a 80k ish dynamesh sculpt, the third being 7k poly model with UVs). I'm pretty sure the UVs are good and so are the normals of the polygons as only the SSS material shaders are having a problem with the object, the basic material shaders show the object with no problem.

117115

Hail
09-16-2013, 11:11 AM
Not sure about what is going on with your shaders there but if you can share your nodes network or better still the scene a kind soul can sort it out for you here:)

Matt
09-16-2013, 02:13 PM
The object needs to be a closed mesh if you're using the Skin shader node.

RebelHill
09-16-2013, 02:16 PM
As Matt said... heads 2 n 3 arent closed... the bad areas are those where the backside of the poly is facing out into space... basically the scattering rays for those parts of the surface are shooting through an infinite volume, so to speak.

ksunde
09-17-2013, 03:54 AM
Thanks everyone it turned out to be what Matt and RebelHill had said, the model needed to be a closed mesh.

It renders fine now, just need to tweak the heck out of it (and figure out what all the settings do).

117135

Cheers,
Kent