PDA

View Full Version : Can anyone confirm on the newest build if this Spline Control bug takes place?



probiner
08-27-2013, 01:32 PM
I'm still on 2706 and if someone could confirm it I would fogbugz it, even though I still don't have reproduction steps.

Open the scene, scrub the timeline and see the rolling orange cube following the spline. Now, delete the green cube which have no connection to the spline control rig and see the feature simply stop working. It's still assigned on the spline control menu but nothing works. If I try to assign a new object, doesn't work either.

The Orange cube was cloned from the green one. That's my only hint.


Thanks

Tobian
08-27-2013, 03:18 PM
Confirmed on 2708 - very weird!

probiner
08-27-2013, 03:27 PM
Thanks

This seems a bit catastrophic to me in terms of scene management.

DogBoy
08-28-2013, 01:42 AM
send a bug report. That's wierd

Jarno
08-28-2013, 02:20 AM
You're right, it's broken. When an item is deleted that comes before the spline in the scene tree, some item references kept in the spline are getting messed up.

---JvdL---

probiner
08-29-2013, 03:47 AM
Cool Jarno.
Probably not needed, but fogged (https://fogbugz.newtek.com/default.asp?65064_rsn0vhrv).
Cheers

Celshader
08-29-2013, 07:25 PM
Cool Jarno.
Probably not needed, but fogged (https://fogbugz.newtek.com/default.asp?65064_rsn0vhrv).
Cheers

Thank you for finding and reporting this, probiner.

rikka+
09-02-2013, 02:18 AM
You're right, it's broken. When an item is deleted that comes before the spline in the scene tree, some item references kept in the spline are getting messed up.

---JvdL---



This seems a bit catastrophic to me in terms of scene management.

It's definitely catastrophic :o, i'm actually working on a scene with many spline controls and i can't delete any item, argh. Tested on osx too.

jwiede
09-08-2013, 05:36 AM
You're right, it's broken. When an item is deleted that comes before the spline in the scene tree, some item references kept in the spline are getting messed up.

Jarno, any word as to whether this will be fixed in whatever comes after 2708? Thanks!