View Full Version : Instancing Issue

08-11-2013, 10:32 AM

I am new to using instancing in LW 11.5.
When I set up some instances on a object the instances always appear a set distance away from the original object, and I cannot seem to work out why this would be.
Is it not possible to make the instances at the original object position and then set up spaces from that position?

08-11-2013, 12:25 PM
Check the pivot point for both the instances and the parent in modeler. Of course your models you want to instance should sit at the origin.
top menu row:: Layers :: Pivot Tool
for some reason the pivot can be displaced by some unknown force

08-12-2013, 09:04 AM
In modeler make sure to hit F2 to center your object at base origin 0,0,0, that brings the object to that center based on the pivot center of that object, hit F3 and it centers almost the same but place the object on ground so to speak.
once in layout, do not move the object away from origin..otherwise you will get wonky placements when instancing, you can hide the original object if needed, and see above made comments from bazsa73.


08-12-2013, 09:37 AM
The issue you're dealing with is probably what the other guys have mentioned. Instancing goes by the origin (pivot) point of the object, not the geometry, so if your object is not centered in Modeler any instances you make will be offset the same amount. So if your object is a box modeled one meter off to the side, and in layout you place a null where the box is and try to instance more boxes at that location they will be an additional meter away. Without seeing your content, it's hard to troubleshoot exactly what's going on.

Something else you might consider:

By default the instance generator is set up so that when you move/rotate/scale the base object, the instances will move as well. If your base object is 10 meters to the left then all of your instances will be 10 meters to the left of your flock.

There's a setting in the instance panel to control how the instances are placed. The options are World / Local / Parent. You may want to try playing with those settings.

08-16-2013, 01:33 PM
Thanks so much for your help. Once I go to Local on the instance panel it sorts out the problem, instancing is great though a fantastic addition.