PDA

View Full Version : Radiosity Render - Artifacts on Skin



ImpactD
08-03-2013, 11:20 AM
Greetings! I am having a problem that I cannot seem to figure out how to fix so I am hoping someone could possibly assist me with it. I am rendering a scene with Global Illumination Radiosity and for some reason, a black tatoo-like pattern is visible on my character's arm only during renders as seen here:

116083


The strange thing is that the artifact is not there in VPR and is not there at screen resolution:

VPR Snapshot View:

116084

Layout Snapshot

116085

I spent some time disabling all lights and gradually enabling them in an attempt to find what could be creating this artifact, which is only in the render. No luck. I then disabled all objects close to the character in the scene and the render still shows the artifact. I also changed the GI settings and renders continue to show the artifact.

Could anyone please provide some advice as to how I can fix this?

Thank you very much in advance!

Wade
08-03-2013, 11:50 AM
It looks to me that you have "non-planer" polygons or that you have some double polys or one sidded polys that are flipped inside out.

ImpactD
08-03-2013, 12:02 PM
Thanks Wade! I'll check that out.

ImpactD
08-03-2013, 12:16 PM
Hi Wade,

I checked out the mesh and I do not see any flipped polygons, as seen here:

116088

And here:

116089

Waves of light
08-03-2013, 12:37 PM
Make a copy of the object first and then run 'Unify Polygons' and then run 'Unify Normals'. This will get rid of any double polys.

Danner
08-03-2013, 12:41 PM
what are your radiosity settings? For a moving character you should use animated cache.

Wade
08-03-2013, 01:38 PM
Hi Wade,

I checked out the mesh and I do not see any flipped polygons, as seen here:

116088

And here:

116089

This needs to be checked as well - doubled polys.

ImpactD
08-03-2013, 02:11 PM
Thank you Waves of light,

I performed the actions you mentioned and unfortunately the problem remains. The strange thing is that this problem does not occur throughout the entire animation, only at certain times.

- - - Updated - - -

Thank you Danner, I checked my radiosity settings and i did NOT have animated cache active. I activated it and re-rendered but the problem still remains. Ugh!

ImpactD
08-03-2013, 02:14 PM
Hi Wade, I joined unified polys and unified normals in modeler and even merged points but unfortunately no luck.

ImpactD
08-03-2013, 02:18 PM
Is there anyone out there that I can hire to quickly fix this issue for me so that I can get rendering? If so, please email me at: [email protected] with a price estimate. Thank you everyone!

bobakabob
08-03-2013, 03:17 PM
Is your character sud d or a frozen obj, quads or tris? Looks something like non planars, unwelded points, flipped polys or junk geometry as suggested above. If all else fails this can drive you nuts. Try deleting the arm causing trouble and mirror the 'good' arm, weld and take care to edit weight maps if they're present. Any luck? :)

JonW
08-03-2013, 05:12 PM
If you do not have too many polys it may be easier to hit the issue with a sledge hammer. Copy the points to another layer, check if each point is Welded one by one & redraw the polys & past them back in.

ImpactD
08-03-2013, 05:54 PM
Bobakabob, you were correct! I made the basic mistake of not sub d-ing the mesh before using it in Layout. Once I Sub-D'd it, the problem went away! Thank you everyone for taking the time to help me out with this! I'm sure it was a combination of everything that helped the Sub-D fix things. I appreciate it very much!

Another quick question for you all though: For character animation and high polygon objects, is it best to set sub-division order to last or after motion or??? Any tips on this?

Thanks again! :thumbsup:

Waves of light
08-04-2013, 04:18 AM
Glad it's sorted. I usually set sub-d to last.

EDIT: Here's a breakdown by RebelHill (post 2) on the reasons:
http://forums.newtek.com/showthread.php?114570-Simple-question-Can-someone-succinctly-explain-the-Sub-D-order-modes-!

ImpactD
08-05-2013, 04:50 PM
Thank you very much!