View Full Version : LightWave 11.6 Export to STL format doesn't seem to work

07-25-2013, 07:11 AM
Hi there.

Anyone tried out the new export to STL format for 3d printing in LW11.6?
I built a simple object in Modeler but it doesn't show up in my slicing software (RepG) or even any STL viewer out there.

It's either I'm doing something wrong or it's completely useless(the feature in LightWave).

07-25-2013, 07:19 AM
It's done correct with addendum from page 6?

07-25-2013, 10:25 AM
Just loaded your lwo into Modeler and exported it as STL and it was seen in MeshLab. You did export as STL, right?


07-25-2013, 01:02 PM
Yes I did export to STL of course. Meshlab can't see it. Tried on Mac and Win.
I tried all kinds of things like increase export unit size, ascii and binary etc.
Went back to LW11.5.1 with Chilton's Export STL 2.0 LScript. Way better results!
Thanks for trying! Appreciate your help!

07-25-2013, 01:10 PM
I'm getting good results exporting for PreForm, the print software for the Form 1, and also for MeshLab. I set the exporter's Up Axis to Z and Scale to mm to make it load correctly in my printing software.

This is an obvious question but I have to ask: are you certain the object is valid for STL export? If not, it might not export anything in the file. This happened to me with one of my tests; once I corrected the object it showed up on PreForm just fine.


07-25-2013, 01:20 PM
It worked fine for me. Did you try the result I posted in Meshlab? If it doesn't load for you I'd suspect the Meshlab installation. Other posters to this thread, please try the STL I exported too?


07-25-2013, 01:51 PM
Hi Ben
Yes I tried your version and it looked fine in Meshlab. I wonder why you can do it successfully while I can't. Used Meshlab and also Pleasant3d(STL viewer). I'll try again and see.

Hi Mike
Nice!!!! A Form 1! Wish they'd sell it to my country!
Anyway yes the object is valid for STL export. Otherwise I wouldn't have been successful with Chilton's Export-to-STL v2.
I've already printed out the bushings earlier with the LScript from Chilton.

Thanks all


07-25-2013, 01:57 PM
I found the problem. My bad. I unchecked the 'positive quadrant' and everything went fine. I'm such an idiot.

07-26-2013, 05:22 AM
I've used it already, and it's working great. Nice options, and very neat implementation.

Would be cool to have the clean-up tools as a button in LW though, rather than on export! :D

07-26-2013, 08:49 AM
;) There is. Hit Alt F10 and have a look...


07-26-2013, 09:49 AM
Haha... Typical! Knew you guys would have been on the case, but I just didn't even check!

Thanks Ben! :)

07-26-2013, 01:30 PM
I found the problem. My bad. I unchecked the 'positive quadrant' and everything went fine. I'm such an idiot.

Oh yeah, I tried that early on and got an empty file, so I stopped doing that. Sorry, I should have mentioned it. :p