PDA

View Full Version : File permissions problem in OS X



noiseboy
11-11-2003, 05:10 PM
Has anyone experienced any "unable to write file " issues with Lscript generated files. Heres the scenario, I have a modeller script which exports a file. If the file path is set to the root directory it saves ok, but anywhere else I get a "cant write file error". It sounds like a read write permission problem, but my account is the admin account so that shouldn't be the case. I've tried pretty much everything to get it to work, reinstalling LW etc.
I have another machine running the same OS and same version of LW which saves the files wherever I choose. Have any of you OS X gods any suggestions.

riki
11-11-2003, 06:21 PM
I think the save file command in Lscript doesn't work anymore on the mac. I use to have an Incremental Saver that stopped working with the 7.5 update and a number of Lscript devs tried to fix it for me, and we tested others. But no joy

We discoverred his bug has been reported and documented elsewhere. In the Yahoo Lscript forum.

eblu
11-11-2003, 08:22 PM
i've had hub related issues when saving models, in modeller, that reports being "unable to write file" the only way for me to retain my hard work at that point is to save under a new name. Perhaps it isn't just lscript.

noiseboy
11-12-2003, 01:01 AM
The weird thing about this is that its only files saved via Lscript that have the problem. Riki, I've long since gone back a step to vanilla 7.5 bacause of the issues in 7.5c. I have an install on a G4 machine that works fine (and on a G4 laptop), but the install on my G5 is the one causing problems..I cant believe its machine related !?
Eblu, Good thought but it happens with Hub on or off.
Very frustrating.

riki
11-12-2003, 01:33 AM
Here's the thread on Incremental Saver, if you follow it through you see we find a problem with the Save File function

http://vbulletin.newtek.com/showthread.php?s=&threadid=5910&highlight=incremental+saver

I was using OS9 at the time.