View Full Version : There's always one...(Linux, Wine, etc)

07-16-2013, 09:58 PM
Hey all :)

Has anyone by any chance ever managed to get 11.5 running over/under Wine? I've read two threads here and a couple at other places (that I didn't look at the names of, too busy just reading by that point at night) where people have gotten 9 and 10 working with a lot of pain and some have gotten 11 to demo mode and apparently assumed it will work in full mode due to not needing the dongle anymore.

I have a laptop running Ubuntu 13.04 (okay technically it's Edubuntu just in case that actually does matter). Downloaded both 64bit and 32bit (just in case 64 didn't want to play nicely) Windows versions of 11.5.1. Installed with Wine (right click on the installer and run with wine vs running from commandline doesn't make a difference and I only had one on there at any one time jic). Odd aside, doing a "typical" install where it wants to install Visual C stuff made Lightwave unable to find/write to/something the licenses directory it wants to write to, but doing a minimal/custom install with only docs worked as expected. Anyway, install went beautifully, program/s started beautifully, and with the min/custom installs dragging the license.lwk file onto the splash screen wrote the file to the licenses directory.

However I'm stuck in demo mode.

So I tried copying the stuff from the lwk into the Enter License item from the Help menu in Layout, which writes a license.key where it wants to write the license.key (I check it and all the stuff that should be there is there) and asks for a restart.

Still stuck in demo mode. I read though the stuck in demo mode hell thread from earlier, none of those helped (probably because I'm not actually using Windows :). Kind of puzzled as it's writing to the folder so no idea why it wouldn't read from it. I'm guessing there's more involved than simply checking for the presence of the license key file and ensuring it has the appropriate contents that is tripping it up on.

Any tips/suggestions/stuff to try welcome (except for "just use Windows", not worth $99 to use it just for Lightwave which is ALL I would use it for on a non-Mac and I hate it that much I wouldn't waste bandwidth pirating it). Thanks! :)

07-16-2013, 11:00 PM
I kind of remember someone speculating that it would not work dongleless under wine, so if you can get the dongle to work in ubuntu, you might have luck that way. LW may be reading the license but not seeing the dongle/bit of code to match the license against.

07-17-2013, 02:36 AM
I've read all the same threads I think and not got it to work either. I run Ubuntu 12.04 and though it installs and runs under wine in demo mode it has the same problem recognizing the new licence system as the old dongle and I don't see any easy way round that.

07-17-2013, 12:26 PM
The dongle-less system only works in Windows 7 (and probably OSX). I don't know what WINE has done to come forward from the 2k/XP version of Windows as part of their library replacement model (since WINE is Not an Emulator).

07-19-2013, 08:01 AM
Yep dongle-less works fine in OSX (my main rig is a large iMac). Wine 1.6 has Windows 7 and 8 as things that can be emulated, I have most things defaulting to Win7. Re-investigated trying to get the dongle to work and I think it's going to have to be a mission for when I get back (going to a place where the internet is slooooooowwwwwww). Thanks for the replies :)