PDA

View Full Version : FiberFX causing odd smoothing artifacts



Spinland
07-11-2013, 04:50 AM
Here are a couple of renders, the only difference being FFX is disabled on the darker surface in the second render. I can only conclude this is some sort of bug, unless someone has some ideas as to how I can fix this with render settings. Ideas?

115555

115556

Spinland
07-11-2013, 05:09 AM
Please note that I've tried cutting and re-pasting the white surfaces so there's a break between the two surfaces, and also tried moving the white geometry to a different layer; no effect on the renders. Something about FFX seems to be mucking with the geometry near it so far as I can tell.

Spinland
07-11-2013, 05:25 AM
Just to cover my bases: fogged as issue 63128.

Spinland
07-11-2013, 05:39 AM
I also just tried splitting the two surfaces into two LWO files and bringing them into Layout separately. FFX still caused the artifacts along all the adjacent edges of the white surface. Fog report updated with that info.

Spinland
07-11-2013, 06:02 AM
I don't believe this is a Mac issue. I opened the scene in 11.5.1 running under Windows 7/64 and had the same artifacts when I ran a test render.

JoePoe
07-11-2013, 08:32 AM
Maybe it's not smoothing at all on the white surface. Perhaps those are "fly away" fibers along the edge of the dark.

Have you tried taking the white object out of the scene altogether.... for the time being.

If the fibers are still there....
try:
1) changing the fibers specs a little.... density, length etc.
or
2) up the mesh density or subd level of the dark object.
or
3) give the dark object a little breathing room around the edge. One loop of polys with different surface name with same surface attributes minus fiber.

VermilionCat
07-11-2013, 08:50 AM
How about disabling FFX shadow(set to 0)? That's only I can think of...

Spinland
07-11-2013, 06:03 PM
Thanks, Joe, but as I posted, this issue crops up even when the two surfaces are on distinct objects, layers, or even loaded as separate object files. Something about the FFX render is affecting polygons adjacent to it even if they are not in the same layer, or even object.

VC, I'll do a test with the shadows as soon as I can and see if that helps, thanks.

NT has responded to my fog report, and it seems to be a valid issue because they're sending it on to the devs.

Thanks, guys!

Spinland
07-11-2013, 06:14 PM
Eureka! Changing self shadow to zero had no effect, but setting cast shadow on the FFX surface to zero also eliminated the artifacts.

Thanks, VC, that's a good workaround for me right now. I'll update the fog report accordingly.

VermilionCat
07-11-2013, 09:18 PM
Glad to hear it sorted out :)