PDA

View Full Version : Partigons and collision



Galleddrim
06-13-2013, 05:21 PM
Hi, I have been searching the internet for the answer to this and I am totally stumped. I am trying to animate a shower of sparks flying off of a solid surface and have them come back down and bounce/rest on said surface. I figured out the partigons and have them looking like I want them, but I am confused about the generator itself.

The partigon emmitter, unlike the HV emitter, loads up with a double bounding box, only one of which I can move. But the partigons seem to be emitting from the fixed (dotted line) box and being effected by the movable (solid line) one. So I have partigons shooting up from UNDER my generator box. This completely throws off any dynamics that I try to place on the collision surface since they sort of wildly bounce of from underneath and every which way.

I've attached a screenshot of what my scene looks like. I am (like everyone else) on a deadline to get this animated, so any help would be appreciated. Thanks!

~Chris

114912

Galleddrim
06-14-2013, 10:34 AM
Okay, still racking my brain on this issue, if anyone could offer some help. Here's what I get when I enable collision dynamics on the plate beneath my emitter. I can't seem the keep the particles above the plate. They keep shooting down through it. What am I doing wrong?

114918

prometheus
06-14-2013, 11:57 AM
use hv emitter instead if you donīt have any special purpose for using partigons?

the dotted line is most likely only usefull as particle emission bounding box representation, nothing useful except for representation.
it is the other box that decides the size of the vectors.
the line under the box ..is merely a sort of velocity display, not actual particles beneath it, if you were to activate hypervoxels on these
partigons, and show particle size ..you can see that particles are only born from the box emitter and they are not active along the line beneath it.

so use hv emitter and hypervoxels instead I would recommend.

did you apply fx collision on the object surface, and set it to bounce? should work.

do not use any bullet dynamics since it isnīt working with particles properly yet.

Michael

dwburman
06-14-2013, 12:15 PM
I've attached a test scene based on your first pic. Hopefully it will help. I was not able to get the bounce to work right in the short time that I worked on this, but the particles don't go through the floor (a collision object set to plane). For some reason the particles don't bounce with the bounce/bind set at 100%, and raising that setting even a little causes the particles to vibrate up and down rapidly. Maybe it's a scene scale thing. I tried calculating the particle movement (often necessary when particle actions get complex) and I tried changing the collision and emitter settings, but did not find a solution.

I hope it helps.

prometheus
06-14-2013, 03:48 PM
I've attached a test scene based on your first pic. Hopefully it will help. I was not able to get the bounce to work right in the short time that I worked on this, but the particles don't go through the floor (a collision object set to plane). For some reason the particles don't bounce with the bounce/bind set at 100%, and raising that setting even a little causes the particles to vibrate up and down rapidly. Maybe it's a scene scale thing. I tried calculating the particle movement (often necessary when particle actions get complex) and I tried changing the collision and emitter settings, but did not find a solution.

I hope it helps.

I think that it always has been like that, the particles dont bounce at 100% unless setting a roughness at 100%, they will more scatter out than bounce though, unless raising the bounce power above 100%

I did not have any issues with it anyway.

Michael

Skywatcher_NT
06-14-2013, 04:14 PM
Does this do the trick ?

Galleddrim
06-14-2013, 04:28 PM
Thanks guys! I will try these out as soon as I can and let you know how it goes.

JoePoe
06-14-2013, 04:56 PM
Not exactly my wheelhouse, but.....

Maybe the vertical velocity and the -9.8 gravity are fighting each other to create the rapid bouncing.
Using DBW's settings.... First I set the birthrate to "frame" to get them all in going in one shot and tried to envelope the vertical velocity (down to 0 right after birth, but that didn't work).
So I just lowered gravity to -2. Like DBW said.... maybe it's a scale thing? And also enveloped the Bounce/Bind power. 175% to start down to 100% for the reasons Michael said... anything under 100% and they fall through. :)

(reduced the # of particles and made then solid instead of sprites just to see what was happening better.)

Seemed to work....


http://www.youtube.com/watch?v=4t6mXtx4Dcc

JoePoe
06-14-2013, 10:31 PM
Soooo, the whole velocity vs gravity thing..... nevermind.

Still a bit on the rough side, but his example is more to the point. Gravity back to -9.8.


http://www.youtube.com/watch?v=qj3-_TgnruQ

Galleddrim
06-17-2013, 11:24 AM
Thanks everyone! This was all really helpful. I think my problem was that the geometry on that plate I was trying to use for collision was too detailed (lots of polys because there is going to be displacement on it), so it was messing up the calculations. Using an invisible simple ground plane did the trick. Now it's just tweaking.

Galleddrim
06-18-2013, 10:35 AM
Okay, followup question. I have played around with both HV and partigons for this animation and have sort of settled on partigons because I generally like how they render better, and also because their luminosity is factored into global illumination. However, I did really like the control I had over the shading on HV, being able to change the color and luminosity relative to particle age. Is there any way to do this with partigons? If not, it seems a big oversight. Maybe somehow through nodes?

EDIT: I know these are a lot of questions without posting my progress. I promise to post when I feel that things are headed in the right direction! In the meantime, any suggestions are appreciated.

prometheus
06-18-2013, 11:15 AM
Okay, followup question. I have played around with both HV and partigons for this animation and have sort of settled on partigons because I generally like how they render better, and also because their luminosity is factored into global illumination. However, I did really like the control I had over the shading on HV, being able to change the color and luminosity relative to particle age. Is there any way to do this with partigons? If not, it seems a big oversight. Maybe somehow through nodes?

EDIT: I know these are a lot of questions without posting my progress. I promise to post when I feel that things are headed in the right direction! In the meantime, any suggestions are appreciated.

You can have hv surface or hv sprites lighting up the environment too, if you go to render global illumination and activate volumetric radiosity.
You have to set very high amount of luminosity for sprites or surfaces or have high radiosity intensity.

Michael

Galleddrim
06-18-2013, 12:24 PM
You can have hv surface or hv sprites lighting up the environment too, if you go to render global illumination and activate volumetric radiosity.
You have to set very high amount of luminosity for sprites or surfaces or have high radiosity intensity.

Michael

Ah! Excellent, thanks! Bracing for loooooonnnnng render times.

Galleddrim
06-24-2013, 09:50 AM
Okay, all! Here are the results of my work so far. I am still not quite satisfied with the "look" of the sparks. They seem to get this sort of fibery look as they extend out. But I think it's headed in the right direction. If anyone has any suggestions or comments, feel free to share! And thanks.


http://youtu.be/2hgqOeCUWek

jwiede
06-24-2013, 12:10 PM
It's coming along nicely, but the color feels too "warm" to be the output of a plasma cutter, both in the sparks close by the metal "cutting point", and of the cooling cuts themselves. Just a thought, YMMV, etc.

Galleddrim
06-24-2013, 12:29 PM
Quick question. Does anyone know how to turn off particle shadows? Not shadows cast ON the particles, but shadows cast BY them? I have tried adding an exclusion of the emitter to the light source, and doesn't seem to be working. Shadow is still there.

EDIT: Nevermind. Got it!

prometheus
06-24-2013, 04:52 PM
Okay, all! Here are the results of my work so far. I am still not quite satisfied with the "look" of the sparks. They seem to get this sort of fibery look as they extend out. But I think it's headed in the right direction. If anyone has any suggestions or comments, feel free to share! And thanks.


http://youtu.be/2hgqOeCUWek
The strecthy fibery look is probably due to velocity stretching in the hypervoxels tab, you could control that or turn
it down to zero.

or it could be because of using particle blur ..check that in camera properties motion effects and if you have particle
blur on.

Michael