PDA

View Full Version : Transform gizmo snapping



Philbert
05-30-2013, 06:04 PM
I've noticed this before but hadn't posted until this time. I'm seeing the Transform gizmo snapping to an invisible grid that's really huge for a small model, about 0.3". Is there some way to turn off this snapping? I've tried the grid snap options in the Display panel without any luck.

Here's a little video:
http://screencast.com/t/8ma3t03se

steve0077
05-30-2013, 11:24 PM
Is that snapping or a delay in processing mouse movement? Worked OK for me on a simple geometry model.

MSherak
05-31-2013, 02:53 AM
I've noticed this before but hadn't posted until this time. I'm seeing the Transform gizmo snapping to an invisible grid that's really huge for a small model, about 0.3". Is there some way to turn off this snapping? I've tried the grid snap options in the Display panel without any luck.

Here's a little video:
http://screencast.com/t/8ma3t03se

Did you try changing the options in modeler?? Options>Units. Grid Snap is controlled from there.

Danner
05-31-2013, 04:55 AM
The further away you are from the center this "snap" becomes bigger and bigger, it's sort of a precision limitation, it happens in most 3d software.

Philbert
05-31-2013, 06:31 AM
Is that snapping or a delay in processing mouse movement? Worked OK for me on a simple geometry model.

It's not the annoying mouse delay because it keeps doing it as I keep dragging.


Did you try changing the options in modeler?? Options>Units. Grid Snap is controlled from there.

Actually it's in the Display Options, which I said I tried in my post.


The further away you are from the center this "snap" becomes bigger and bigger, it's sort of a precision limitation, it happens in most 3d software.

I do know of this limitation, but in the video example I'm only working about an inch from 0,0,0.

Oedo 808
05-31-2013, 03:09 PM
It doesn't make sense, I had a play about with it and it the left viewport I could drag it smoothly using the blue translate handle, but that same handle in the back viewport jerks around and is unusable. I noticed that in some instances I could change the pivot and it would become usable, but using right-click to align often had it 'snapping'.

So yeah, it ain't working well. Seems quite a happy chappy in the perspective viewport though, thankfully.

Philbert
05-31-2013, 03:32 PM
I tried it again and same thing, though only the Y direction. The others, plus scaling and rotation, are smooth. And like you said, Perspective works fine.

http://screencast.com/t/A8jGv7OxXm4o

Amurrell
06-01-2013, 05:04 AM
Yeah, I have had this happen and it appears to be viewport dependent. It will snap in one but not in another, so I hunt around to find the one that works the best. Not an ideal workflow, and not sure of a solution.