View Full Version : Clipmap troubles

03-04-2003, 11:48 AM
Ok, starting to be annoyed on this now.
I got a few polys, I UV map them with a colortexture and with a black'n white clipmap texture in the clipmap channel.
I render this, and everything looks as it should.
Then, I go to modeler and copy/paste these few polys to get some more, and adjust the position of them, save it, and go to layout and render this again.
Now, some of the polys refuse to render the clipmap correctly, even though they are exact copies of the original, fully functional clipmapped polygon.
Anyone else experienced this? It happened for me several times now.

03-04-2003, 11:37 PM
Clip maps are great things, but if I am not mistaken you must apply them to an object in layout, and as you know each layer is treated as its own object so you will have to specify for each object in layout that you want to clip map the object.

Hope you find the soulution if I am missing it here.

:confused: :)


03-05-2003, 12:40 AM
clip maps are saved based on scene, not the object.

03-05-2003, 12:52 AM
I had ALL clipmapped polys in ONE seperate objectlayer.
Still didn't work 100%.
A few polygons here and there inside the object would loose the clipmap somehow. Don't make sense.
It works on ONE poly, and on the poly right next to it, they are even welded togheter, it do NOT work.

I tried placing the clipmap as a colormap, and I can see that the clipmap is placed perfectly. It's just like the clipmap just dont wanna render on some polygons.

03-05-2003, 07:06 AM
I've been using loads of clip maps on a recent project and they have caused me no end of headaches. I've previously only used the odd one in a scene but this latest project uses about 15. On certain models the clip map has proved very unreliable, in one test render it is fine then on another it will refuse to work. Test rendering this scene on both a Mac and PC hasn't helped. I discovered, after much hair pulling, that the PC didn't like the alpha channel (accidentally) saved in the clip images TIF file, even though the Mac wasn't bothered by it.

The only thing I can guess is that when you dupped the existing polygons the UVs didn't get copied, some of LW clone tools don't clone the UVs. This is another oddity between Mac and PC, Point Clone Plus on the PC doesn't clone the UVs although the Mac version does.

03-05-2003, 07:14 AM
I'm afraid that's not my problem here.
I tried several clipmaps, and I removed the alphachannel from them.
And the UV's are copied and functional. I used the standard Copy/Paste commands, and they copy the UV's just fine.

I've done everything the way it's supposed to be done, and still it behaves like this.

03-05-2003, 11:44 AM
render with threads set to one see if it helps.

I had a similar problem a while back and it seem to work once I made sure I was not running more than one thread.