PDA

View Full Version : NVidia Quadro cards - best settings?



MannaTheBerserk
04-13-2013, 10:12 AM
Here I am again, your worst nightmare ( I think you all are going to regret for having brought me to Lightwave side! Hahahahahahaha :lol: )

Anyhow, here is my simple, I hope, question: as you know Quadro drivers have a lot more settings and professional apps presets available to chose from, and they are very application focused.
What are, in your experience and opinion the best settings for Layout and Modeler?

I give you an example, Maya, for a change :D : for Maya you definitely want to activate Overlay planes by switching "Enable overlay" option on, and surely you want to activate the "Compatibility performance mode" in the "Multi-display/Mixed-GPU acceleration mode field... And so on and so forth.

I am really looking forward to knowing something about this.

One more thing: why the heck Modeler and Layout names appear like "CST Microwave Studio (modeler.exe)" and "Google SketchUp (layout.exe)" in the applications list? :stumped:

Again, thank you all very much for any answer.

Much appreciated.

Mauro :)

Lewis
04-13-2013, 04:10 PM
Sadly LW isn't really that much supporting Quadro cards and you won't see much of performance vs 200$ and 500$ GFX cards. Quadors are faster in Wire and duoble sided materials but that's just for tumbling speed in modeler. Rest is pretty much similar. Set your LWModeler openGl like on my screen and that's giving you fastest tumbing speed in modeler openGL. Bare in mind that I have transparency turned OFF so in case you need to see transparent surface turn it on but speed will drop noticably (not so much visible on low poly objects) and turn it off back when you don't need it :). As for your GFX card settings oyu shoudl turn off Vsync and all kind of AA stuff in drivers. Vsync woudl limit oyu to 60FPS max if you use 60Hz LCD monitor so you can turn off that for LW just to be sure you aren't limiting it to 60FPS only if it could go faster in certian situations/models.

cheers

MannaTheBerserk
04-13-2013, 05:33 PM
Sadly LW isn't really that much supporting Quadro cards and you won't see much of performance vs 200$ and 500$ GFX cards. Quadors are faster in Wire and duoble sided materials but that's just for tumbling speed in modeler. Rest is pretty much similar. Set your LWModeler openGl like on my screen and that's giving you fastest tumbing speed in modeler openGL. Bare in mind that I have transparency turned OFF so in case you need to see transparent surface turn it on but speed will drop noticably (not so much visible on low poly objects) and turn it off back when you don't need it :). As for your GFX card settings oyu shoudl turn off Vsync and all kind of AA stuff in drivers. Vsync woudl limit oyu to 60FPS max if you use 60Hz LCD monitor so you can turn off that for LW just to be sure you aren't limiting it to 60FPS only if it could go faster in certian situations/models.

cheers

Lewis, you are beyond the rockstar!

As always, thank you mate!

:bowdown::beerchug:

Danner
04-13-2013, 05:59 PM
http://forums.newtek.com/showthread.php?133958-Tip-for-a-HUGE!!!-Increase-in-OpenGL-Performance!!-Lightwave-11-to-11-5&highlight=quadro+settings

Found this thread looking for something else, but it might be of use to you.

MannaTheBerserk
04-13-2013, 06:03 PM
http://forums.newtek.com/showthread.php?133958-Tip-for-a-HUGE!!!-Increase-in-OpenGL-Performance!!-Lightwave-11-to-11-5&highlight=quadro+settings

Found this thread looking for something else, but it might be of use to you.


Thank you very much Danner. :)

Yes, this looks really useful, I'll read it thoroughly.

OFF
04-13-2013, 08:33 PM
"Set your LWModeler openGl.."
And turn On Legacy OpenGL option if you working with big objects (>>100 000 polys, lot of textures).

Lewis
04-14-2013, 03:45 AM
"Set your LWModeler openGl.."
And turn On Legacy OpenGL option if you working with big objects (>>100 000 polys, lot of textures).

Hmm not sure how would that help 'coz that would probably disable VBO (which come around Lw 9.2) and lsowdown tumbling speed massively i.e. I just tested on 800k polys mesh and it's unusable when legacy OGL is on (hence the name legacy ;)) tumbling speed is 3-4 FPS comapring to 300-400FPs when it's OFF.

So u still think my screengrab shows fastest OGL settings in LWM ;).

OFF
04-14-2013, 04:01 AM
Maybe yours, Lewis, settings are urgent for the Quadro cards, but my clarification regard to gaming graphics cards - and this can significantly affect their performance in the modeler.

Lewis
04-14-2013, 04:12 AM
Maybe yours, Lewis, settings are urgent for the Quadro cards, but my clarification regard to gaming graphics cards - and this can significantly affect their performance in the modeler.

Can you show me video where 1million polys (just make BOX and subidivide few time) tumble faster with LegacyGL ON, i'd like to see that, thanks.

BTW I have gaming card(s) (660GTX, 610GT, 430GT, 240GT, 9800) and not seeing your clarification as true with any of my models here 'coz like i said this effectively kills VBO settings whcih speeds up Tumbling very much so i still dont's ee how would work better on any moder GFX card if VBO is off. Maybe if somene uses on-board GFX card them it might be faster to switch to Legacymode (which effectiely means put all load back to CPU only) but i can't really see anyone doign serious or even hobby 3D wiht those on chip/on-board GFX cards anyway, even laptios have dedicated GFX cards nowday ;).

P.S. VBO isnt' working on all modes so maybe oyu ar eusign soem othe rmode and not seeign the speed fiference? VBO work in Texture, texture shade and wireframe but not so much in weight mode and flat shade.

cheers

OFF
04-14-2013, 04:22 AM
"Can you show me video where 1million polys (just make BOX and subidivide few time) tumble faster with LegacyGL ON, i'd like to see that, thanks."
Sure, will try to do today. I will show no primitives and their "mechanical" density increased to 1 million polygons, but the objects with which I work - buildings, trees with dozens of surfaces and texture mapping. This picture of OGL performance is quite different, very unlike the manipulation with clean geometry in the Modeler.

MannaTheBerserk
04-14-2013, 04:42 AM
"Set your LWModeler openGl.."
And turn On Legacy OpenGL option if you working with big objects (>>100 000 polys, lot of textures).

That was the first thing I tried when I was tweaking settings by myself, but unfortunately it turned Modeler into the slowest application on the Earth. Even tumbling the camera around became a pain.

After all it is completely normal: "legacy OpenGL" is supposde not to take advantage of the graphics card driver at all.

OFF
04-14-2013, 05:02 AM
Legacy OpenGL on and off:
http://youtu.be/UFUqnJEpJf0

Lewis
04-14-2013, 05:07 AM
Legacy OpenGL on and off:
http://youtu.be/UFUqnJEpJf0

You are in "wrong" mode, check what my setings are showing, you are using GLSLS mode, switch to MTS and your mesh tumlbing will be fast as hell, and as you can see from Maouros' reply it's same with Quadro card.

OFF
04-14-2013, 05:18 AM
Lewis, i was tried any combination, but for my Graphics card (GFX 560Ti, before it was 570) a Multitexture Mode (Legacy off or no) and GLSLShaders mode (with Legacy On, when it OFF = freezing vewport) - no different. But maybe Multitexture mode is slightly smother.
btw: Is there something like FPS Meter for Modeler?

Lewis
04-14-2013, 05:25 AM
Sadly no FPS option in modler, I use FRAPS (www.fraps.com) to measure FPS.

Try exact settings i showed on my screengrab, Trasnparency/Reflections will kill any GFX card in modeler (sadly) :(. But those setting i showed are fastest tumbling mode in Texture/Texture Wire and wireframe modes.

Another thing you should be carefull is double sided surfaces, turn OFF double sided surfaces for ALL materials (surfaces), that also slows down Nvidia cards considerably.

Lewis
04-14-2013, 05:26 AM
Sadly no FPS option in modeler, I use FRAPS (www.fraps.com) to measure FPS.

Try exact settings i showed on my screengrab, Transparency/Reflections will kill any GFX card in modeler (sadly) :(. But those setting i showed are fastest tumbling mode in Texture/Texture Wire and wireframe modes.

Another thing you should be carefull is double sided surfaces, turn OFF double sided surfaces for ALL materials (surfaces), that also slows down Nvidia cards considerably.

OFF
04-14-2013, 05:33 AM
Yes, Multitexture mode faster in most situation except when you editing the objects with dozens and hundreds surfaces with textures on it - at least this is so for gaming video cards, non-quadro-like.
P.S. "Transparency/Reflections will kill any GFX card in modeler" - ! Can't understand why i'm not trying turn off Transparency options earlier? Without Transparency "on" performance in LW Modeler at the level of Modo or Cinema4d. Heh.. Thanks Lewis!

MannaTheBerserk
04-14-2013, 03:01 PM
Today I went through another noticeable slowdown, but this time in Layout.

When I send an object with skelegons to Layout from Modeler everything looks and works fine.
I convert skelegons into bones, again everything is alright, fast and smooth.
As soon as I tell the object to use the bones, so the bones are actually affecting the geometry, the frame rate drops a bit and tumbling, zooming and panning becomes slower.

Any idea? :question:

Lewis
04-14-2013, 03:30 PM
Deformations are kind of slow in layout if you have higher subdivision level. So go to object properties (select mesh and hit "p") and set subpatch Display level to 1 or even 0 if you have dense mesh/character in subDs.

New thing is to turn on Threade dMesh Evaluation if is not already on - Hit "d" key for display options, go to "Gen" TAB and click on Checkmark called "Threade Mesh Eval". Also check you BoundingBox threshold level (at display tab) and play with poly number and settings "delayed/Interactive".

MannaTheBerserk
04-14-2013, 05:52 PM
Deformations are kind of slow in layout if you have higher subdivision level. So go to object properties (select mesh and hit "p") and set subpatch Display level to 1 or even 0 if you have dense mesh/character in subDs.

New thing is to turn on Threade dMesh Evaluation if is not already on - Hit "d" key for display options, go to "Gen" TAB and click on Checkmark called "Threade Mesh Eval". Also check you BoundingBox threshold level (at display tab) and play with poly number and settings "delayed/Interactive".

Thank you Lewis!

I'll check those things out and let you know how it goes! :)

MannaTheBerserk
04-14-2013, 06:51 PM
Ok, I tried everything but nothing really change.

Then I tried to change the Bounding Box threshold from the default value ( 4000000 I think ) to something like 500000;
the result is that when I tumble/pan/zoom the camera the geometry disappear living just the bounding box and speeding up the whole lot. When I stop the geometry comes back to visible ( almost like the interactive feedback in Maya ).

I think that I will stay with the default values for the moment, because the slowdown is still manageable. If the situation becomes too compromised then I'll bring the threshold back to something small.

Lewis
04-15-2013, 12:13 AM
Yes BoundingBox Treshold is for telling Lw after what polycount to start making meshes to well bounding boxes and then when you let go it comes back to mode you set in window.

What's the polycount in your scene (hit "w" to get statistic in layout) and do you use subPatches (SubDs) or ?

Danner
04-15-2013, 02:19 AM
If your scene is subpatches, lower the display subdivision, It will go down to 0 if you need more speed. BTW Catmul Clark sub-D is terribly slow in LW. On heavy scenes triple any ngon and convert to regular subDs.

MannaTheBerserk
04-15-2013, 10:29 AM
Yes BoundingBox Treshold is for telling Lw after what polycount to start making meshes to well bounding boxes and then when you let go it comes back to mode you set in window.

What's the polycount in your scene (hit "w" to get statistic in layout) and do you use subPatches (SubDs) or ?

Alright, here are my scene data:

1) Polygons: 794768

2) I am using Catmul Clark subdivision surfaces.

I am thinking of converting the Catmul Clark into standard subpatch, after all I have modeled everything in quads, so I shouldn't have any problems in doing this.

- - - Updated - - -


If your scene is subpatches, lower the display subdivision, It will go down to 0 if you need more speed. BTW Catmul Clark sub-D is terribly slow in LW. On heavy scenes triple any ngon and convert to regular subDs.

Yeah, I think I will go for subpatches and get rid of the subdivision surfaces.

Thank you.

Lewis
04-15-2013, 10:32 AM
ohh yes CCs are at snail pace in LW, switch to Subpatch ASAP :)

MannaTheBerserk
04-16-2013, 02:57 AM
If you are not hearing from me soon is because I have to model properly from scratch the wings of the bat in the "animation tutorial" :)

The body is fine, all quads, but the wings aren't :D

Lewis
04-16-2013, 03:01 AM
Hehehe well you can hit Shift+t to Triangulate and then use "mergeTrigonX" free plugin to automatically make Quads where possible ;).

Btw if you didn't see by now just bookmark this page - http://www.lwplugindb.com/ for searching/downloading of LW plugins ;).

OFF
04-16-2013, 04:27 AM
Everything is fine for me now for OGL performance in Modeler, but periodically i got freeze (~1 min.) Modeler windows and any tools when use the "hide selected polygons" command.
How to deal with it?

Lewis
04-16-2013, 04:30 AM
Everything is fine for me now for OGL performance in Modeler, but periodically i got freeze (~1 min.) Modeler windows and any tools when use the "hide selected polygons" command.
How to deal with it?

I remember you use lot of textures? Is your GFX card maybe spent all VRAM ? I had similar issues when opened few apps or meshes with lot of textures so my VRam usage gets close to 1.9-2GB.