PDA

View Full Version : Vanishing objects in Bullet (bad bad fracture)



Dennik
04-05-2013, 07:51 PM
I have an object that fracture is giving me a very rough time with. I just can't get it to behave well with Bullet.
On the first frame it either freaks out or it vanishes completely.

Is there any way I can remedy this?
I guess there won't be any sleep tonight.

pinkmouse
04-06-2013, 04:13 AM
I've had many issues with Fracture and Bullet. First things I would try is to set Glue to 100%, turn off Breaking Angle and Distance, and make sure that your object isn't intersecting any other polys, such as the ground plane. Do you have any other object in Layout with Dynamics turned on?

Dennik
04-06-2013, 08:22 AM
thanks for the suggestions pinkmouse. Those have been applied already. However the problem is with fracture in modeler. It just generates bad geometry that bullet won't accept. Its most definitely a self intersecting geometry within the model itself. I passed the model through netfab to fix anything bad it could find, and then went to fracture it again. It generates a lot of "spike" polygons which cannot be good. So the problem still remains.

pinkmouse
04-06-2013, 11:25 AM
Hmm. I've never used netfab, so can't comment on that, but I would just make sure you have no extra points or unconnected polys in the model. Have you tried just selecting a poly manually, using select connected, then copying to another layer to see if anything is left behind? The other thing is Fracture really mucks up with polys of more than four sides, so check your stats panel and subdivide if required.

Dennik
04-06-2013, 11:44 AM
Yep, thats what I have been doing yesterday night and today. Fixing the parts one by one. Fracture doesn't save me any time at all. I might as well cut the object manually.

Celshader
04-06-2013, 04:42 PM
I have an object that fracture is giving me a very rough time with. I just can't get it to behave well with Bullet.
On the first frame it either freaks out or it vanishes completely.

Is there any way I can remedy this?
I guess there won't be any sleep tonight.

Last week I had an object that exploded on the first frame of the Bullet calculation. Changing the type from Mesh to Convex Pieces (which creates a proxy for each piece) fixed the problem.

However, I had a clean Fracture from the start. I did not have any spikes.

Dennik
04-06-2013, 05:36 PM
I finally had enough of it today, and sectioned it manually. The easiest manual labor ever. At least there was success in the end!