View Full Version : Object is readonly and cannot be modified?

04-02-2013, 03:35 PM

I very often get this errormessage, when I try to modify a object in lw11.5

"Object is readonly and cannot be modified"

Im loading a scene, go into modeler and want to modify a object, and then this message appears.

This happens only on one system. On the other system everything is fine.

Of course, the object is not writeprotected.

Does anyone knows more about this problem or/and a solution?


04-02-2013, 03:41 PM
This has happened to me occasionally as well - and only on one computer. So far, rebooting the system removes the problem and I can make changes to the object.

But it WOULD be great if a solution is found that would remove this annoyance.

04-02-2013, 03:46 PM
Yes, I just close LW, then start agian.

04-02-2013, 04:51 PM
Could it be that the UAC is preventing you from editing it? Sometimes it can be a pita when editing or moving files.

04-02-2013, 05:27 PM
Disable the hub.

04-02-2013, 05:51 PM
Disable the hub.

I like AND use the Hub. Disabling it is not an option for me.

I'd like to know the reason WHY this is happening and how it can be remedied - without disabling another helpful feature.

04-02-2013, 07:42 PM
You probably forgot the .lwo extension while saving your model. I had this error several times and got it fixed by adding the .lwo extension. Very weired actually.

04-02-2013, 08:52 PM
You probably forgot the .lwo extension while saving your model. I had this error several times and got it fixed by adding the .lwo extension. Very weired actually.

Not on my end. It doesn't matter if the model was created with 9.6 or 11 or 11.5 - all with the .lwo extension - we get that read only message.

04-04-2013, 10:46 AM
I've had this and found that opening the model in 9.6 and saving as a different file name works.
Pita indeed.

04-04-2013, 11:40 AM
Quick question. Have you tried to run Lightwave with administrator privileges? Right click on icon and "Run as Administrator"

04-04-2013, 12:01 PM
Strange, because the same thing happened to me, from time to time... It would be silly to rename every file again. Must be a bug!

04-05-2013, 11:04 AM
thank you all very much for the hints. I dont think that the problem is the admin mode, that files are saved without .lwo or something like this. But rebooting helps. However, I would really appreciate if Newtek could fix this bug soon.

04-06-2013, 01:15 AM
Might not be a "bug". Might be an issue with the OS. Are you sure they really are missing the extension (as opposed to Windows hiding the extensions for files with known programs, like .xlsx -> Excel or .docx -> Word).

04-08-2013, 09:53 PM
I'm getting the same problem and turning off the hub fixed it but I like the hub.

04-08-2013, 10:57 PM
Same issue here. My workflow now is to leave the Task Manager open and "End Process" the Hub everytime Layout or Modeler locks up or when I can't save. One click on the "End Process" button will kill the Hub and then wait 10 seconds and Modeler and Layout will start to respond and I can save. Also the Hub starts working on it's own after I kill it so updates to and from Layout and Modeler work fine - for awhile. :) Rinse and repeat as needed! :(