PDA

View Full Version : Lightwave 11 system requirements



CWinn
03-24-2013, 05:23 AM
I'm still working with 9.6 and I'd love to upgrade to the current version. But my computer meets only the minimum specs. Is it realistic to think I can upgrade with that? I always felt meeting the minimum specs only was a little hairy.

Lewis
03-24-2013, 09:24 AM
I didn't notice that Lw 11.5 needs anything more than 9.x needed from hardware specs, only thing I'm not sure anymore is how it works on windowsXP (in case your old machien is still on winXP) especially new software licensing system.

Sensei
03-24-2013, 09:37 AM
LW v11.5 works fine on WinXP. Just licensing system doesn't work. So you have to have dongle plugged.

CWinn
03-24-2013, 10:08 AM
I'm actually on a Mac. OS X 10.6. 4GB ram.

BeeVee
03-25-2013, 05:44 PM
Hi CWinn,

OS X 10.6 should be fine to run LightWave 11.x. In any case, why not take the trial for a run and check for yourself?

B

CWinn
03-26-2013, 01:48 PM
True true. I'll just try it.