PDA

View Full Version : TrueArt Global Materials GI Transparency - Please Crosscheck



madno
03-10-2013, 07:22 AM
Hi,
I started to use TrueArts GlobalMaterials in LW 11.5.
Noticed that GI only works if "Use Transparency" in GI is activated. But in the attached sample scene (and the others I tried), there is no transparent surface at all. Can somebody crosscheck if I am doing something wrong, or if this is an expected behaviour?

112380

Thanks a lot in advance.

Sensei
03-12-2013, 03:25 PM
I can only guess what is happening.

Node has special flag whether it should be called while calculating shadows or not. Actually it's returning information whether node will return transparency data or not.

Intercepting node doesn't know what will be plugged to Global Materials, whether nodes connected to it will return transparency data or not, so it's setting this flag always on.

Apparently GI code in LW is doing some optimizations based on this flag.

Toggling on Use Transparency is not a big deal after all.

madno
03-12-2013, 09:14 PM
Thanks Sensei,
just wanted to be sure, its not me doing something wrong.

MrFurious
07-28-2013, 09:15 AM
I also noticed this issue with Global Materials but what's actually annoying is how this plugin doesn't seem to like Draft Mode in VPR when radiosity is active... or is it just my system? Seems like a major oversight.

Sensei
07-28-2013, 09:29 AM
Draft Mode is unpredicted optimization. At least cutting ray recursion earlier than it should be.

But show screen-shots of VPR Draft Mode and F9 render to compare. Or include scene for tests.

Sensei
07-28-2013, 09:52 AM
I noticed funny thing in LW v11.5.1. Not using Global Materials at all.
VPR Draft Mode, renders in 15.64 seconds.
VPR No Draft Mode, renders in... 4.31 seconds..
Check bottom status bar in Layout window.

So actually Draft Mode is increasing previewing time, not decreasing... ;)

MrFurious
07-28-2013, 10:41 AM
That's bizarre Sensei,.. I can pretty much guarantee every scene I work with is much quicker in Draft Mode especially scenes with large number of objects and surfaces. Will post some screenshots shortly..

p.s. thanks for the tip re: rendertime statistic in the status bar, can't believe I never noticed it.

Sensei
07-28-2013, 10:44 AM
I loaded scene, opened VPR options, clicked Draft Mode, waited, and recorded value, clicked again Draft Mode, waited and recorded value. Scene has no GI.

That's crazy that this value is higher. I could swear in LW v11.0 it was faster in Draft Mode. But it's LW v11.5.1 build 2525.

Sensei
07-28-2013, 11:09 AM
I loaded other scene. Same result. But scene was using area light, which allowed nailing down issue.
Without Draft Mode VPR is grainy, pixels are not anti-aliased, rendered in 1.41 seconds.
With Draft Mode On VPR is anti-aliased, rendered in 10.8 seconds (nearly 8 times slower).

MrFurious
07-28-2013, 11:45 AM
Did a few tests myself and it seems Draft Mode is optimised for GI. When not using GI, non draft mode appears to resolve quicker but also doesn't look as refined either.

However....

When using a more detailed scene with GI active, Draft Mode resolves much quicker and also looks better when using GI, single or multiple bounces. So in this real world test I'd say Draft Mode is much quicker.

115911

Note: second example in my screenshot
Non Draft Mode: 54.39 seconds and looks soft & pixellated
Draft Mode: 38.37 seconds and is a more refined & detailed result

MrFurious
07-28-2013, 12:32 PM
This is what Draft Mode looks like with Global Materials active.. please note that Use Transparency is checked in the GI Options panel. I have attached a jpeg and packaged scene.

cheers.

Sensei
07-28-2013, 12:41 PM
I don't have plug-ins nor textures that you used so skipped them while loading.

115915

115916

MrFurious
07-28-2013, 12:47 PM
Thanks Sensai.. hmm I'm thinking may be a graphics card issue, my laptop has an ATI card but have another PC at home with an nVidia card will try that tomorrow.

Sensei
07-28-2013, 12:52 PM
Turn off Sun sky motion etc. and start moving lights manually to see whether it changes anything.
I don't think so it's gfx card issue.

I have SK_Sun at -2,2,-2
and SK_Sky at 0,0,0
Tried moving them to other places. But draft, not draft looks the same.

Sensei
07-28-2013, 01:05 PM
So you're using custom LightHandler SK_Sun_Light... Try changing it to point/distant light..

And EnvironmentHandler Sunsky_Env, try turning it off.. Why using Textured Environment together with Sunsky Env? Aren't they mutually exclusive?

MrFurious
07-29-2013, 09:45 AM
Your right it's not a gfx card issue, I have the same problem on my office pc, I tried messing with different drivers etc but no luck. I tried your suggestion and loaded that house model into a fresh scene with no plugins, just the default scene with Global Materials active, same thing happens though... I'm totally at a loss as to why its happening I've checked and unchecked just about every option in every dialog box in LW and nothing works. Any other suggestions before I give up?

Many thanks,
dino.

MrFurious
07-29-2013, 09:52 AM
oops double post...

Sensei
07-29-2013, 10:08 AM
This is what I have after loading your scene, clicking ignore load textures & plugins, using the same GM that you received but 32 bit one. LW 11.5.1 build 2525 32 bit.

I plug this red standard material to show that GM is intercepting materials.

There is slightly difference between Draft Mode and not Draft Mode, but nothing looking like what you showed earlier.

115951

115950

115949

115948

Load this scene as-is in your computer. I saved scene & objects, so references to 3rd party plugins are lost permanently.
We will see whether there will be difference.
There is absolute no plugins other than GM.

MrFurious
07-29-2013, 10:20 AM
Im doing this as we speak, but I noticed in your last screenshots, the ones which Draft Mode is selected.. there is no GI in the scene..

Sensei
07-29-2013, 10:24 AM
??? They have all Enable Radiosity toggled.. I didn't change anything in this scene. It's pure yours, just loaded and resaved.. Clicked Global Materials and added red standard material. I didn't change anything.

115952

MrFurious
07-29-2013, 10:25 AM
Radiosity may have been toggled but there is no GI in those renders, just hard flat shadows

MrFurious
07-29-2013, 10:30 AM
Here are my resultant renders from your scene... same as yours :(

Sensei
07-29-2013, 10:46 AM
I have set red standard material to surface material (no GM), then copied it to the all surfaces.
And it looks the same.
Not visible GI, when material is used.

115957

115956

No Global Materials is used in this scene!
Same (incorrect) result with Draft Mode and lack of GI. Just because of using materials.

MrFurious
07-29-2013, 10:52 AM
Correct, same on my end as well.. How can the surface prevent GI bounces? strange

Sensei
07-29-2013, 10:58 AM
It looks like intentional behavior.
Materials can be very slow, especially in GI. It would not be draft mode anymore, just crawling.

I am glad it has nothing to do with Global Materials anyway.

MrFurious
07-29-2013, 11:11 AM
hey not so fast!.. ;)

That material you have plugged directly into the surface after disabling GM.. where did it come from?

MrFurious
07-29-2013, 11:15 AM
select all the surfaces and set transparency to zero.. theyre currently at 25 for some reason. voila! GM is back..............in draft mode

MrFurious
07-29-2013, 11:19 AM
looks like there's some issue with the standard material being plugged into the surface if it has transparency set to anything above zero

Sensei
07-29-2013, 11:22 AM
hey not so fast!.. ;)

Scene from #23 post- has no Global Materials at all used. But issue is present.

You're right- clear up Transparency, set it to 0%, in the main Surface Editor, and GI is appearing.
Then set it to some value, and GI is still, then uncheck Node Editor checkmark, and check again, and GI is gone.

MrFurious
07-29-2013, 11:27 AM
yup..

Sensei
07-29-2013, 11:28 AM
I tried Shaders > Diffuse > Lambert -> Make Material -> Material, same.
It has nothing to do with Standard Material.

MrFurious
07-29-2013, 11:29 AM
I would have expected the 'standard material' transparency (even if zero) would override the surface setting?....

MrFurious
07-29-2013, 11:33 AM
true,.. I just tried something else..

gave all surfaces the 'default_smooth' surface preset, then set transparency to anything above zero, and GI disappears in draft mode

MrFurious
07-29-2013, 11:45 AM
Draft Mode ignores the 'Use Transparency' flag in GI Options

MrFurious
08-09-2013, 07:49 AM
Sensei I need to pick your brain once again.. an annoyance with (possibly) Global Materials: I have fresh scene, dropped in an object and applied GM. Added 'standard material' to the GM channel but the scene goes all black. I have to frame advance for the changes to take effect. the same happens if I change the diffuse colour in the standard material, I have to step frame backwards or forwards to see the chance take effect. If I do this in the standard material editor I don't need to frame advance.. Is this normal?

Sensei
08-09-2013, 08:01 AM
I suppose so you're talking about updates in VPR..
Do you have nodal previews turned off?
If they're turned off GM doesn't receive information from LW about rendering, and can't pass it back to custom Node Editor, if I recall correctly.

Sometimes LW doesn't send update request when user plays with some control. If scene is heavy, and rendering takes long, change happens during rendering, and is taken into account. But if scene is light weight, rendering is instant, and change to control in GUI is not seen by VPR (because control didn't send proper update request). Large amount of bug reports in LW v11.x is about "this or that doesn't cause update VPR".

BTW, don't use GM with LW v11.6 pre-release, it's too buggy ATM.

MrFurious
08-09-2013, 09:04 AM
Sensei.... you're the man! It was indeed the 'Disable Preview' checkbox in Node Preview options. I never would have guessed that inconspicuous little toggle would have effected VPR. Confusing actually One would assume that toggle simply did what it says- which is to hide the preview thumbnails in the node editor. As for 11.6 VPR seems quite buggy all round but thanks for the heads-up.

May I make a suggestion for a future release version of GM... Global Materials 'per object' (see attached image). I am loving this plugin btw. Originally I just wanted this for a streamlined passes/masks solution but It's also a brilliant tool for roughing out lighting without having to save 'white' versions of all my objects.

Sensei
08-09-2013, 09:41 AM
Sensei.... you're the man! It was indeed the 'Disable Preview' checkbox in Node Preview options. I never would have guessed that inconspicuous little toggle would have effected VPR. Confusing actually One would assume that toggle simply did what it says- which is to hide the preview thumbnails in the node editor.

GM Intercepting node is receiving Init/NewTime/Cleanup only when Disable Previews is turned off. GM intercepting node is passing these functions to custom Node Editor. No previews, no properly initialized custom Node Editor, and some nodes are rendering incorrectly, black. If VPR would inform Master plugins that it's starting rendering and ending rendering this would be not needed and would work with Disable Previews. But it does not inform.


May I make a suggestion for a future release version of GM... Global Materials 'per object' (see attached image). I am loving this plugin btw. Originally I just wanted this for a streamlined passes/masks solution but It's also a brilliant tool for roughing out lighting without having to save 'white' versions of all my objects.

That's nice grouping. But unfortunately not possible in LWSDK..

MrFurious
08-25-2013, 06:44 AM
That's nice grouping. But unfortunately not possible in LWSDK..[/QUOTE]

Pity would have made life easier not having to connect all the material for a given object for a per-object override