View Full Version : Fiber FX in 11.5 does not play well with endomorphs

03-03-2013, 10:57 AM
I added some facial morphs to my bear character, which is of course covered in fur. I soon discovered that if I enable Morph Mixer and try to do any renders with morphing, either I have to leave the displacement order at After Bones (which of course means the fur does not follow the morphed geometry) or I can try setting it to after displacement or last and have Layout crash when I try to do a render.

To add to the fun, once it crashes, if I've saved the scene just prior to hitting F9, trying to re-open that scene freezes Layout at the loading plugins phase and it has to be force quit.

This is mostly on my Macs in Mountain Lion, but I did see a lot of similar behavior when trying it on my Windows 7/64 virtual machine.

Fogged, #57589.

Sigh. This bug pretty much kills my plans for using this bear. Are there any other fur solutions out there that still work with LW11.5?

03-03-2013, 12:39 PM
Here's a sample of the problem. This is a simple subdivided sphere, one morph included. If in Layout you set the subdivision order to last and apply the morph, in OGL you can see the visible fur doesn't compress with the geometry, it holds the old spherical shape. Then when you try an F9 Layout crashes.

03-03-2013, 02:04 PM
works fine here. Win64... its the mac version Id imagine.

03-03-2013, 02:05 PM
I had the same behavior in a Win7/64 virtual machine, though. Even had the Layout lockup trying to load the saved file and had to use Task Manager to kill it.

03-03-2013, 02:09 PM
Another thing that happens, is even if it's not crashing (the simple version I posted), if I change the subdivision order and then move the morph slider the original geometry changes but the fur stays in the old shape, both in OGL and in renders. In the attached screen shot I expanded the sphere (using -100% morph) with subD order at first, then changed order to last and ran the slider over to 50%. As you can see the fur didn't follow the geometry.


03-03-2013, 03:55 PM
Okay, spent some more time in the Windows VM trying stuff. It was hit or miss but most of the time it seemed like I could instantiate FFX over the morphed geometry without a crash. Once a file got to the point where OS X froze opening it at plugins load, though, Windows was also 100% unable to load it, locking up at the same point. This point is reached by instantiating FFX then saving before hitting F9. That's the kiss of death in both operating systems.

It's possible you need more complex geometry than just the sphere. I did these tests on a folly-rigged character model with seven endomorphs applied. I also sent NT one of the scene files that can't be opened.

03-03-2013, 04:25 PM
I had the same behavior in a Win7/64 virtual machine, though. Even had the Layout lockup trying to load the saved file and had to use Task Manager to kill it.

Yeah... virtual machine... not the same as windows proper, where it works fine.

03-03-2013, 05:14 PM
I am playing around with your sample file and can reproduce your results. However, when I changed the subdivision level to 1 then back to 3 it seems to work. Moving from a range of -100% compression to 100% compression over a series of frames. I am using OS X Mountain Lion and LW 11.5.


03-03-2013, 05:20 PM
Also, no crashes thus far (after playing with for the past fifteen minutes and several F9 renders). Perhaps you have a conflict with a 3rd party plug-in?

03-03-2013, 05:25 PM
Hmm, interesting. Thanks for trying that. I already tried removing all my third party plugins and that had no effect. I'll have to try lowering the display subD on the original model and see what that does.

I just tried reverting to LW 11.0.3 and that seems to be working perfectly, full subD, morphs, FFX and all. Doing a test render of facial morphs animating to make sure it's really working there. If nothing else, then Ill know the short term solution is ditch 11.5 and revert.

Thanks again! As soon as this test animation finishes I'll try that.

03-03-2013, 05:30 PM
Works here. I didn't change a thing, just set the morph to both extremes in MM and F9 rendered. OS X Still on Lion here (Too many of my tools still have issues with Mtn Lion) and 11.5.

03-03-2013, 06:06 PM
Okay, I now have two workarounds, thanks to you guys. LW 11.0.3 works perfectly, but I can also use 11.5 if I set the Display SubPatch Level of the character model to zero before applying FFX. If it's even at 1, the instant I instantiate FFX Layout crashes.

It's far from ideal to have bugs like this, but I no longer seem to be completely dead in the water, and for that I'm grateful.

Thanks again!

03-03-2013, 06:24 PM
Okay, I guess I spoke a little too soon. I just tried to do a test render of the 11.5 file I saved in LWSN and the nodes hung forever until I quit the job. Tried to open the scene file again and it hung at the loading plugins again. Dead.

I went back to the version where I instantiated Fiber FX in LW 11.0.3, was able to open that okay, and LWSN seems to be happily munching the frames right now.

There's some kind of major problem in saving the FFX-instantiated files from LW 11.5, even when it's not crashing. I can F10 render right from inside Layout but once I close Layout the file is unusable again.

03-04-2013, 07:47 AM
Was the fur done totally in 11.5 or did u start it in 11.03 and then bring it into 11.5 ?

03-04-2013, 08:23 AM
It was totally created in another 11.5 scene, and there is where I'm starting to think the trouble lies.

It's not possible to save 11.5 FiberFX settings on the Mac, all you get is a load dialog if you try. So, I wanted to use the settings I created for this same character in another scene. I opened that scene in my Windows 7/64 virtual machine and saved both FFX settings to files.

It's looking like the hung scene file is created as soon as I save the scene after loading those two FFX settings files. If I go through all the steps but create fresh FF settings from scratch (my model uses two instances of FFX for two different surfaces) instead of trying to load existing ones it appears--thus far, at least--that I'm still able to open the scene files after saving.

This bears more testing but I think I'm onto something.

03-04-2013, 09:56 AM
Okay, so it's not necessarily the endomorphs FFX won't play well with, rather it's the settings files. Either they were created incorrectly, or they're being read incorrectly; in either case, just re-creating the desired fur settings by hand seems to have fixed the problem. I can now both load the scene and render it over Screamernet.

I still think there's an issue either with changing the subd order after FFX is applied or not having the display subpatch level at zero--or some combination of both--but that's a minor annoyance that can be worked with.

03-06-2013, 10:39 AM
I hope you packaged that all up and squirted it to FogBugz.

03-06-2013, 11:17 AM
I did, indeed, and followed up the original report with a pile of additions and examples.

They're probably tired of me by now. :)

Oh, and Lino has a copy as well, and is looking into it.

03-06-2013, 11:41 AM
Thanks Spinland: please don't be offended if I happen to suggest this again in the future-- I can't remember who are the Good Reporters and who forget/never knew about fogbugz. :bowdown: :beerchug:

Oh, and they never get tired of bug reporters: they LUVVVVVV me!

03-06-2013, 12:51 PM
Hey, absolutely not a problem. It's not something a lot of people would know about if they weren't told by someone. I'm good with it. :)

03-11-2013, 02:52 PM
Okay, guys: thanks to Sensei in another thread there's a workaround to save FFX settings from the Mac.

First create a blank text file for each setting you want to save, name it however you like. Then when you try to save an FFX setting, and it gives you an open dialog instead, navigate to and open the blank text file you created. FFX will save the settings into that file for you.

This method worked for me using a simple object with two different fur settings applied to two different materials, so hopefully it'll get you rolling.

Many thanks to Greenlaw and Sensei for their efforts in helping me work around this issue.