PDA

View Full Version : Tip for a HUGE!!! Increase in OpenGL Performance!! Lightwave 11 to 11.5



jboudreau
02-27-2013, 03:26 PM
Hi Guys

I was having serious openGL performance issues with my new Dell T7600 Dual XEON 2687w 64gb RAM system runing the Nvidia Quadro K5000 GPU. It wasen't performing as well as a powerful system like this should.

I spend most of the day yesterday trying to figure out what the problem was, testing all the different drivers, installing different version of lightwave etc. Well I managed to figure out what the problem was and would like to share
this with everyone. If I go into the Nvidia Control Panel under the manage 3D settings tab and use the Baseline profile or the Default 3D app profile I get horrible openGL performance in lightwave 11.0 - 11.5. Slow Viewport drawing in,
Polygon intensive scenes taking forever to load in if at all and most of the time complete lockup of my system.

Then I tried turning off some of the setting under the 3D managed setting profile. I tried turning everything off and still same performance problems. I then tried some of the preset profiles in the 3D managed settings and
guess what the 3D app - video editing preset worked I immediately noticed faster response with my system. But guess what lightwave performance increased at least 30% or more. The viewports are super fast, the
performance mammoth scene in the lightwave 11.0 new content, instantly loaded in and the performance rotating/zooming around the scene in perspective view was incredibly smooth with super fast performance with no lag or any issues and the crashing and lockups were completely gone. (I would say it was performing around 40+ FPS with 100 instances of a 1.5million polygon object (150,000,000 polygons)

Also on top of this the flying probes flocking scene from the lightwave 11.5 content, instantly loaded as well and the viewport came in super fast even in quad view with 1000 instances all set to shaded view inside the instance tab. Going back in forth from expanding the viewport to one view back to quad was fast as well no more re-drawing of the viewports.

All I can see is this preset turns off a lot of settings (Grays them out) that the default and other profiles dont. I tried setting the base line and default profile to the same settings as the 3D App - video editing preset but still no performance increase. What ever that preset turns off on the GPU is probably what is causing the problem because using that preset increases performance like crazy.

Please give it a try if it does the same on your machine that it did on my machine believe me you won't be disappointed. Unbelievable performance now!! I did this with my M6700 Laptop using the K5000M card and it gave the same
results Incredible performance increase.

Hope this helps. Please let me know how your system responds to that preset. All you do is change it and click apply and that's it no need to restart your computer.

This tip may work on previous version of quadro cards and drivers and lightwave versions as well but I can't verify this. I know for a fact that it has given me a huge performance boost (30+%) on the K5000 and K5000M GPU's

Oh this has worked on the Nvidia 314.07, 310.90 and 307.45 versions but I'm pretty sure it will work on all the drivers available on the Nvidia Site.

Hope this increases the performance on your system like it did on mine and others.

Thanks,
Jason

Waves of light
02-27-2013, 03:39 PM
I know you can set different profiles on a per-software basis, but I was wondering what your optimal settings were as I don't have a 3d-app video preset?

jboudreau
02-27-2013, 03:49 PM
I know you can set different profiles on a per-software basis, but I was wondering what your optimal settings were as I don't have a 3d-app video preset?

Hi

Here are my settings,

Ambient Occlusion - off (Greyed Out Can't change)
Anisotropic filtering - Application-controlled (Greyed Out Can't change)
Antialiasing - FXAA - Off (Greyed Out Can't change)
Antialiasing Gamma correction On (Greyed Out Can't change)
Antialiasing-Mode - Application controlled (Greyed Out Can't change)
Antialiasing-Setting - Application controlled (Greyed Out Can't change)
Antialiasing-Transparency - Off (Greyed Out Can't change)
Buffering-flipping mode - Auto-select (Greyed Out Can't change)
CUDA-GPUs - All (Greyed Out Can't change)
Deep color for 3D applications - Allow (Greyed Out Can't change)
Enable overlay - Off
Exported pixel types - Color indexed overlays (8bpp) (Greyed Out Can't change)
Maximum pre-rendered frames - Use the 3D applications setting (Greyed Out Can't change)
Multi-display/mixed-GPU acceleration - Multiple display performance mode (Greyed Out Can't change)
OpenGL rendering GPU - Auto-select (Greyed Out Can't change)
Power management mode - Adaptive
Stereo-Display mode - Custom
Stereo-Enable - Off
Stereo-Swap eyes - Off
Threaded optimization - Auto (Greyed Out Can't change)
Triple Buffering - Off
Vertical sync - Use the 3D application setting

I can't gurantee it will work by changing the settings on a per software basis. I tried matching the setting in the 3D app - video editing preset but no performance increase. All I can see is with the 3D app - video editing preset a lot of setting get greyed out completely where you can't even change anything it's different from just setting it to off. But give it a try and let me know how you make out. Hope it works for you. :)

Thanks
Jason

bobakabob
02-27-2013, 03:51 PM
Nice tip, I'm about to invest in a good Dell workstation. Thanks for the info.

jboudreau
02-27-2013, 03:54 PM
Nice tip, I'm about to invest in a good Dell workstation. Thanks for the info.

Awesome well the T7600 system is sweet!! I was talking to tech suport at first about this issue I was having and now that I found a fix they have now set their system to use the 3D App - video editing preset because of the increasse in performance.

Thanks,
Jason

Waves of light
02-27-2013, 04:07 PM
Interestingly, the only one different to yours is Triple buffering is On (and some additional items - which I presume is down to a newer card).

jboudreau
02-27-2013, 04:14 PM
Interestingly, the only one different to yours is Triple buffering is On (and some additional items - which I presume is down to a newer card).

Hi

The ones that have greyed out can't change don't go by the setting it says. Because when you use the 3D App - video editing preset it completely disables that setting it doesen't set it to anything. I'm trying to see if I can set up the same settings using the program setting you were talking about.

Thanks,
Jason

Waves of light
02-27-2013, 04:18 PM
Hi

The ones that have greyed out can't change don't go by the setting it says. Because when you use the 3D App - video editing preset it completely disables that setting it doesen't set it to anything. I'm trying to see if I can set up the same settings using the program setting you were talking about.

Thanks,
Jason

Yes, what I have are two tabs. One where you can set a default for all your programs and another where you can specify profiles for different programs (overwriting the defaults).

Ricky.

jboudreau
02-27-2013, 04:20 PM
Interestingly, the only one different to yours is Triple buffering is On (and some additional items - which I presume is down to a newer card).

Do you have any presets what kind of video card do you have?

Thanks
Jason

Waves of light
02-27-2013, 04:25 PM
I only have an ageing GeForce 9500GT. The default settings were all the same as yours apart from the triple buffering, which I have set to On. I have changed it to Off and booted LW, but can't see any difference. I seem to remember looking into this a long time ago and that's maybe why I have changed the defaults.

Will have a more detailed 'google' on Triple Buffering tomorrow and see what affect the settings have on 3D apps.

Ricky.

jboudreau
02-27-2013, 04:29 PM
I only have an ageing GeForce 9500GT. The default settings were all the same as yours apart from the triple buffering, which I have set to On. I have changed it to Off and booted LW, but can't see any difference. I seem to remember looking into this a long time ago and that's maybe why I have changed the defaults.

Will have a more detailed 'google' on Triple Buffering tomorrow and see what affect the settings have on 3D apps.

Ricky.

Yeah it might not work on a GeForcee card, Since mine is a quadro card that's why I have the preset for different applications. You woule of the presets for games correct?

jboudreau
02-27-2013, 04:34 PM
I only have an ageing GeForce 9500GT. The default settings were all the same as yours apart from the triple buffering, which I have set to On. I have changed it to Off and booted LW, but can't see any difference. I seem to remember looking into this a long time ago and that's maybe why I have changed the defaults.

Will have a more detailed 'google' on Triple Buffering tomorrow and see what affect the settings have on 3D apps.

Ricky.

Hi

Under the Global Settings I have a preset called 3D App - Video Editing everything is completly disabled except for the following settings:

Enable overlay = off
powermanagement mode = Adaptive
Stereo Display mode = NVIDIA recommended
Stereo-Enable = Off
Stereo-Swap eyes = Off
Triple buffering = Off
Vertical sync = Use the 3D application setting

All other settings are greyed out and can't be changed. Only the above can be changedl. If you can duplicate this on your end use your program settings then it may work.

Thanks,
Jason

Amurrell
02-27-2013, 04:53 PM
Hmm these settings are the default settings on my card, so no changes needed, but was wondering why GLSL crawls in modeler.

jboudreau
02-27-2013, 04:59 PM
Hmm these settings are the default settings on my card, so no changes needed, but was wondering why GLSL crawls in modeler.

Hi it has nothing to do with the settings. If I set those exact setting by chaning the default 3D app preset it doesen't give any performance increase you have to change it using the preset 3D App - Video editing then you will see an increase. It might be just for quadro k5000 and k5000M GPU's

Thanks,
Jason

Matt
02-27-2013, 08:38 PM
Some other tips (for Modeler at least).

Smooth shaded OGL is faster than flat shaded, so if you want a flat shaded look (poly edges not being smoothed into one another) without the OGL performance hit, set all surfaces to have 1% smoothing. It will look the same as flat shaded but will be faster.

A big OGL hit is transparency, this is something we wish to fix, but in the meantime, turning that off will really help.

erikals
02-27-2013, 10:48 PM
indeed, quite a lot too >
http://www.youtube.com/watch?v=czWBYThz-Zo

JonW
02-28-2013, 06:53 AM
I smooth all surfaces a least the 1% since I first heard about this & will keep doing it so everything is consistent. On my box with a GTX280 even with say 70x70x70 cubes on a 30" screen refresh rate is quick either way. With 100x100x100 cubes, moving the cubes is getting a touch slow but it appears to be similar whether the cubes are smoothed or not. In both cases Modeler & Layout have comparable performance.

erikals
02-28-2013, 09:10 AM
also remember, the different modes affects the speed too >
http://www.youtube.com/watch?v=0LWsRrHnul8

erikals
02-28-2013, 09:25 AM
jboudreau, if you use the default settings instead, but turn "Vertical Sync - Force Off"
is the result / speed the same as the "3D app - video editing" preset?...

The Dommo
02-28-2013, 11:48 AM
I'll check my Quadro drivers to see if they have this preset setting. Probably will have it.
Looking to get a K5000 myself, but currently on a FX3800 which is still 'fairly' decent but lacking CUDA oomph by today's standards.

stevecullum
02-28-2013, 01:38 PM
change it using the preset 3D App - Video editing then you will see an increase. It might be just for quadro k5000 and k5000M GPU's

Seems to have fixed some openGL slow downs I was getting on my quadro 4000 - thanks for the tip!

probiner
02-28-2013, 02:29 PM
Some other tips (for Modeler at least).

Smooth shaded OGL is faster than flat shaded, so if you want a flat shaded look (poly edges not being smoothed into one another) without the OGL performance hit, set all surfaces to have 1% smoothing. It will look the same as flat shaded but will be faster.


Is this gain real? I mean in theory 1% Smoothing would keep the vertices' normal splitting in the OGL. 180 would actually do the gain no?

Anyway, maybe I did something wrong but I tested with 70x70x70 cubes in Modeler and all the options were slow In Texture (Multishaders, VBO).
What display setting are you guys using and couldn't "Smoothing", even set to 1%, trigger some internal change on those that apparently gives gain, but it's not smoothing at all?

erikals
02-28-2013, 02:32 PM
yep, it's quite real, check my video posts on this page

probiner
02-28-2013, 02:48 PM
I saw it. You didn't answer my last question concerning the Layout video, though, the last bit I don't know if you can.

Let me get fraps! :D

Edit: Well I got the same max (6fps) with Texture and Smooth Shade either with Smoothing Off or On (1% and 180%). Flat Shade is just plain bad (1fps). This in Modeler, Multitexture Shaders, VBO, Transparency OFF.

(and yes, it's time to upgrade ;) )

Cheers

jboudreau
03-01-2013, 02:54 AM
Seems to have fixed some openGL slow downs I was getting on my quadro 4000 - thanks for the tip!

Hi

Just wanted to let you know that the 3d app - visualize simulation preset is even better give it a try and let me know what you think

Glad it helped your opengl slowdowns. opening up the performance mammoth scene is a great comparison of how much performance increase you get using these presets

I thought the video editing preset was fast until I used the visual simulation preset its even faster and no issues with sometimes the viewport not coming in when you press the f3 and f4 keys back and forth

Thanks
Jason

OFF
04-22-2013, 07:51 PM
Purchased a low-budget professional Quadro 600 graphics card for better performance modeler. Unfortunately in all modes except of GLSLShaders+Legacy OpenGL-on (which is one order of magnitude less efficient throughout the rest) type for the actions like - hide selected polygons, display hidden polygons and when accessing the Node Editor happen "freezing" of the Modeler interface. Tried all possible settings the video card driver - the most productive turned out a Video Edition and Visual Simulation. However, the problem does not go away. Does not anyone have any experience in dealing with this problem?
(Exactly the same picture using Nvidia 560Ti).

jboudreau
04-22-2013, 07:54 PM
Purchased a low-budget professional Quadro 600 graphics card for better performance modeler. Unfortunately in all modes except of GLSLShaders+Legacy OpenGL-on (which is one order of magnitude less efficient throughout the rest) type for the actions like - hide selected polygons, display hidden polygons and when accessing the Node Editor happen "freezing" of the Modeler interface. Tried all possible settings the video card driver - the most productive turned out a Video Edition and Visual Simulation. However, the problem does not go away. Does not anyone have any experience in dealing with this problem?
(Exactly the same picture using Nvidia 560Ti).

Hi

What problem are you having. I have a quadro k5000 video card and was the one that found the Visual Simulation settings gave the best performance.

Thanks,
Jason

OFF
04-22-2013, 08:03 PM
My problem is - when executing commands hide selected polygons, display hidden polygons and when accessing the Node Editor happen "freezing" (from 10sec to 1min) of the Modeler interface. This is a big disadvantage.

jboudreau
04-22-2013, 08:08 PM
Hi

Do you have different versions of lightwave installed on your system? Sometimes you can be using the 11.0 hub when running version 11.5 this causes all sorts of problems and crashes. Also have you tried deleting your configs, updating video card drivers etc.

OFF
04-22-2013, 08:39 PM
Yes, thanks, but i tried to delete the config's - without results.. Video card drivers are latests.., latest BIOS for motherboard, etc.

jboudreau
04-22-2013, 08:47 PM
Yes, thanks, but i tried to delete the config's - without results.. Video card drivers are latests.., latest BIOS for motherboard, etc.

Do you get the same results with different versions of lightwave 10, 11, 11.0.3 or is it just in 11.5?

OFF
04-22-2013, 08:57 PM
I have a installed LW 9.6 (x64), the situation is almost the same, maybe just a little bit different in a good way.

allabulle
04-22-2013, 09:07 PM
I'm running LightWave 11.5 on a machine with an ancient Quadro FX1700 (Win7 x64) and it doesn't do that. And that card is really old. Sometimes a complete uninstallation and re-installation is worth a try, although finding the exact problem is always better.

gpktm
11-22-2013, 08:49 AM
I'm facing the same problem with 7990. I was using LW10.1 and after I upgraded to 11.6 I'm getting a terrible delay when switching between single viewport and multiple viewports.

Ryan Roye
11-22-2013, 09:05 AM
In layout, playback performance can be greatly increased overall by using "channel edit mode" in the dope track; this also gives you access to more functionality (IE: being able to disable channels temporarily to delete the keyframes of only 1-2 channels). If you wanna see how huge of a difference this makes, try loading a motion capture clip and play it with and without channel edit mode enabled.

jimiclaybrooks
09-15-2017, 04:44 AM
I have a new machine with a gaming card. Its a GeForce GTX 1080 and I'm very disappointed in the performance I'm having with this machine. I was in the graph editor just yesterday and I had a really hard time working because the response was so slow. In both, modeler and layout, the intous pen sticks and then jumps when modeling or animating. Its so frustrating, but I don't have that all important feature that you mention, so my question is, am I stuck with a new machine that won't work right? Do I have options or am I gonna have to buy a new graphics card?

rustythe1
09-15-2017, 05:35 AM
Have you got an AMD machine by any chance?

erikals
09-15-2017, 06:30 AM
did you uncheck Vsync ?


https://www.youtube.com/watch?v=rs4YnBd4zvE

jimiclaybrooks
09-15-2017, 09:37 AM
no, my machine is intel, but I so have a vertical sync option I think, I'll check. Yes, I do have it and I have turned it off, so now we'll see what happens. Thanks

jimiclaybrooks
09-15-2017, 09:50 AM
OK, I just checked the performance in the graph editor, no change. It creeps, after a delayed reaction to whatever I try to do. And since the response doesn't sync with the movement, I never really know how far I"ve moved the graph or the points or whatever, so I have to wait for the machine to catch up with my command. I'm getting pissed off just thinking about it. Do you suppose its the graphics card, because I sure can't see it being anything else. All my drivers are up to spec, and it is a new machine, so everything else is working fine. Do I need to post my specs here?

erikals
09-15-2017, 09:54 AM
could very well be the card.

i recommend testing with an old GTX if i had the chance, see if there is a change.

Asticles
09-15-2017, 10:14 AM
Wow, vsync trick makes a great improvement on my laptop. Thanks!

jimiclaybrooks
09-15-2017, 10:22 AM
OK, I just checked the performance in the graph editor, no change. It creeps, after a delayed reaction to whatever I try to do. And since the response doesn't sync with the movement, I never really know how far I"ve moved the graph or the points or whatever, so I have to wait for the machine to catch up with my command. I'm getting pissed off just thinking about it. OUt of sheer desperation, I thought maybe it was the drivers for the wacom pen, so I tried everything with the mouse, but no change. The machine is sluggish at best and everything gets stalled or stuck, like its on some flypaper, when I try and do any kind of a movement. Im gonna google the graphics card to see what Nvidia has to say about the problem. Thanks for your help.

erikals
09-15-2017, 10:27 AM
Wow, vsync trick makes a great improvement on my laptop. Thanks!
happy to help, was frustrated myself by slow speed. :)


Im gonna google the graphics card to see what Nvidia has to say about the problem. Thanks for your help.
yes, sorry cant be of more help.
sometimes it's the lack of updated Nvidia drivers,
other times it's because of new architecture and LW needs to add support.

my guess is that it's more of an Nvidia issue. however, hard to say.

rustythe1
09-15-2017, 01:00 PM
actually, I think this may have been brought up before, but I think I have found two things that can cause this, no1, your tablet (it seems to be quite common that people who experience stuttering and lag have a Wacom, maybe try uninstalling it and removing it and see if that helps, no2, if your intel is like mine at idle its running at 1500mhz, then when working with open gl etc some of the cores spike to 4.5ghz, when this happens the pc momentarily freezes and I get funny mouse movements, which will cause problems in aps like lightwave, I don't think its a GPU problem as I cant see how the graph editor would be affected so much by that, also I thought that open GL first has to execute on the CPU to tell the GPU what to do, in which case it seems likely that the way intel processors with turbo and hybrid clocking work could very likely cause a problem

jimiclaybrooks
09-15-2017, 05:48 PM
That's food for thought, and from what I do know about computers, which admittedly isn't much, it makes sense. So I will try and disconnect the tablet. At this point, I doubt that the tablet could do so much damage to the machine's performance. But ya neva know!! I'll definitely have my guy look at that performance issue, you may be onto something there. Thank you for that.