PDA

View Full Version : some particles in 11.5 are taking a long time.



stylus10
02-23-2013, 07:34 AM
i have a scene where a particle generator (6000 total dots) using backlit cloud as a hypervoxel texture is taking 32 hours per frame. does anyone know what's going on? thanks. p.s. i have a bulldozer 8 core on win8.

prometheus
02-23-2013, 03:23 PM
i have a scene where a particle generator (6000 total dots) using backlit cloud as a hypervoxel texture is taking 32 hours per frame. does anyone know what's going on? thanks. p.s. i have a bulldozer 8 core on win8.

probably more related to the hv´s...but have you tested i LW 11.03 and therefore it is faster there? why would it be related to LW11.5 specific and not simply the way the hv´s are set up?

check quality settings in hv render panel and shadow panel, particle size, textured shadows on or off..that is really slow to render, but gives that extra shadow detail, smoothness are slower, and lower opacity values
since that doesn´t cut of rays and must be calculated.

Also how many lights and what light typ are affecting the cloud, also 6000 are alot for particle cloud depending on if you have large voxel size...do you have a screencap of opengl wire and also final render?

otherwise I could spit out 4000-6000 particles..with 500 mm sizes and increasing with particle age gradients for explosions, and get away with some seconds to render...so your way off somewhere.

Michael

prometheus
02-23-2013, 03:51 PM
Also, how close is the camera to the hypervoxels, fly throughs will be slow.
Also ..you can go to volumetric and fog tab, and uncheck volumetric aliasing..a slight speed improvement if you dont even use aa setting of 1 to just render out voxel passes.

But if you crank up minimum camera AA setting to 4, you will raise your rendering time alot, but unchecking volumetric AA will cut down to half probably.
But if you can ..render voxels in different pass than geometry if you can that is.

Speed improvement might be done too in ray recursion or ray cutoff in render tab, but I haven´t investigated that enough.

Michael

stylus10
03-04-2013, 09:43 AM
sorry, i was pulled away with work. thank you for your reply. attached is a still of the work. the problem is of course the big white plume of smoke. the size is 1.5 m with a +/- 100% size variation. i have worked many of the angles you suggested. i have gotten it down to about 4-6 hours per frame now. shortening the lifetime of the particle helped in addition to your suggestions. but still this seems a little absurd. i will try now your idea of 11.3. i will let you know. and thanks for taking the time with this. don

stiff paper
03-04-2013, 11:54 AM
Volumetric HVs can give you outrageous render times. It's always been so.

One standard way of dealing with it is to render the HVs as a separate pass with all your objects as black holdout objects (or deleted if not interacting with the HVs) and the render size multiplier set to 50%. Yes, that's half the res, but half sized HVs often can hold up pretty well when enlarged and comped in post.

Other than that, reducing the number of HVs will always help. A lot of the time people will have multiple HVs occupying the same volume in space, and that's a waste (and slow to render). The solution is a lot of tweaking of your particles.

Also, and this is more general... if you have +/- 100% size, that means that at least some of the HVs will be incredibly tiny. Certainly, too tiny to be useful. 1.65m and +/- 90% or 1.8m and +/- 80% seems more sensible. And that might let you thin out the particles a little.

prometheus
03-04-2013, 04:10 PM
you should be able to push that down more I think, doesn´t seem to be that much of particles or to big sizes.

If you give me your email ..by message forwarded here on the forums private message..I can send you my mail and if you post the scenefile or part of it, it would be easier to track down the issues..if you
can and would like post it that is.

Again, check your quality settings for hv´s both render quality and shadow quality..they are rendering from low,medium,good and very good...most of the time you can get away with medium.
also, in advanced shading..using textured shadows is a render clogger too, it gives that extra grain detail shadowing though for more realistic smoke grain or cloud shadows.
the particle hv size..I would suggest you set a particle age gradient on the hv size..so the particles starts very small at first and then increases in size, you will notice much faster speed at first
but with results that aren´t blending well ..but that´s where you should start and tweak from to find the lowest particle size that looks good and control the size during animation with the help of the
particle age gradient....feel free to start with 0 value in the particle age gradient.

As Cardboard mention, rendering half the resolution might be a good idea and rescale in post if you can..it will smooth voxels out that could look nice, or it can destroy detail grain too of course..depending on what you want, but a lot of guys seem to do that.

feel free to mess me privatly and post the scene and Ill promis to take a look in to it.

Michael

prometheus
03-04-2013, 04:20 PM
something must be way off though, I mean ..I can render 2000 hv´s with particle size of 800mm and textured shadows on my laptop, and medium quality, AA just set o 1/1 within
2min 20 seconds (1280x720 res)..and you get several hours?

It could be your AA setting is affecting the hv´s...try first and lower all that to see what happens.

Edit...I didn´t mean to suggest to try 11.03 if that was what you are going to try, it was a question since you said it was so slow on 11.5, there shouldn´t be any difference in
renderspeed between the two of them.

Michael

prometheus
03-04-2013, 05:06 PM
I would recomend go to the volumetrics tab, where you have fog settings etc..turn of volumetric aliasing, if not that will have an huge impact on rendertimes if you set your camera AA setting higher than 1.

So this is a way to bypass aliasing for voxels, there is only a very slight difference in quality of the rendered voxels...check these images..
the image without volumetric aliasing took 8 min 43 seconds...and the one with volumetric aliasing took 21 min 52 seconds.
I used minimum of 5 samples for camera render settings, lighting and shading all at 1.

medium quality settings for voxel render and shadow, used the texture shadows too.
800mm voxel size but controlled with particle age gradient, and used 2000 particles.

so if you do not have volumetric light´s that needs the AA settings, you might as well turn them off.
Edit..Note, it will of course take longer rendering the image using AA of 5 and turning of volumetric AA than just setting the AA to 1, since it calculates the rest of geometry and shadows.

Michael