View Full Version : Okay, Node Editor for surface just stopped working?

02-21-2013, 02:02 PM
Maybe I'm overlooking something simple, but this is a simple operation and it's not working. I have a UV mapped figure, tried to apply a simple test checker texture to the skin surface using the node editor. Nothing doing, it acts like i never even tried. I can apply the texture just fine using the legacy surface editor. Attached is a screen shot of my setup, which should be a no brainer.

Can some kind soul help me puzzle out why the texture is not showing in the window?

Many thanks in advance.

02-21-2013, 02:28 PM
To add insult to injury, I can send the figure to Layout and the texture renders out perfectly but doesn't show in the Open GL view there, either--but if I open an older object I created that uses nodal textures those show up in the view ports. I also tried a basic ball with a simple nodal texture having only one color constant. No show in the viewport, renders fine. I can't find anything in the display settings to explain it, nor does that explain why the textures show in the older object I checked.

This is really weird. Any ideas?

02-21-2013, 02:55 PM
I spoke too soon: the older objects don't work properly either. If I try to edit their nodal texture definitions none of the changes show up in the viewport, either in Modeler or in Layout, and this is happening on both my Macs. If I surface using the legacy editor the new stuff updates in the viewport right away, but if I switch to node based surfacing none of the surface stuff appears unless I actually do a render. I've tried changing all sorts of display options and nothing seems to have an effect. I've also tried rescanning the plugins folder but since this is happening in both my machines I have to conclude there's just something I've overlooked? I don't recall ever having this problem before and I don't know what I could have changed recently (on two machines) to change this behavior.

Time to start hair-pulling soon. :p

02-21-2013, 03:00 PM
nodes dont show in OGL

02-21-2013, 03:10 PM
nodes dont show in OGL

Sigh. Okay; I thought I was losing my mind. I don't know why I thought I remembered doing node surfacing in Modeler. I think I need a break for a while.

Thanks for setting me straight.

02-21-2013, 04:50 PM
Yeah, sadly, they dont....but we have VPR, at least :)

02-21-2013, 05:03 PM
And it's pretty annoying we don't have VPR in Modeler.

02-21-2013, 05:11 PM
At least a basic vpr would be cool with a generic lightsource. Though I dont do much heavy surfacing in Modeler.

02-21-2013, 05:17 PM
I guess it wouldn't have been an issue except I was digging through some UV mapping tutorials using a trial copy of 3D Coat and when I was done the new .lwo was exported with nodal surfacing. In my fevered state I thought I could just pull it up in Modeler and check how it came out. Result of too many hours at the computer with too few breaks.

Apologies for the somewhat frantic appeals. :p

02-21-2013, 05:22 PM
Too many hours at the computer? Is there really sucha thing?

02-21-2013, 05:23 PM
I should have added: without a beer handy.