PDA

View Full Version : Lens Flare? But only half



We-Co
02-18-2013, 03:42 AM
Hey All,

I seem to be having a problem with lens flare. (It doesn't show in VPR)
For some weird, strange reason when I create a lens flare it flags on my model. Why? I donít know.
Wondering if someone else had the same problem and figured a way around it.

Thanks.

We-Co
02-19-2013, 03:02 PM
Is there no solution?

nickdigital
02-19-2013, 03:49 PM
Where is your lens flare located? Inside the model?

shrox
02-19-2013, 04:10 PM
The lens flare is like an image on a plane that always faces the camera, so if the plane cuts through an object, only part will render. It is centered on the light.

We-Co
02-19-2013, 11:21 PM
Where is your lens flare located? Inside the model?

Yes, it is inside the model.


The lens flare is like an image on a plane that always faces the camera, so if the plane cuts through an object, only part will render. It is centered on the light.

Hm... I'm not sure I understand. The Lens is a plane, okay, but I have three different camera angles and this is the only one creating this weird cut through thing. Also if that is the case, then wouldn't rotating the lens flare correct this? And I tried that and it still stayed the same.

shrox
02-19-2013, 11:53 PM
Yes, it is inside the model.



Hm... I'm not sure I understand. The Lens is a plane, okay, but I have three different camera angles and this is the only one creating this weird cut through thing. Also if that is the case, then wouldn't rotating the lens flare correct this? And I tried that and it still stayed the same.

"a plane that always faces the camera"

We-Co
02-20-2013, 12:01 AM
I see. My reading is horrible.

So there is no way to have a Lens Flare inside an object and not have it cut through it like this?

shrox
02-20-2013, 12:16 AM
I see. My reading is horrible.

So there is no way to have a Lens Flare inside an object and not have it cut through it like this?

Turn off fade behind object

We-Co
02-20-2013, 12:24 AM
Turn off fade behind object

Ahhhhh... Actually I had on "Glow Behind Objects."

Thanks, Shrox. I can't believe I missed that. I feel like a dork. lol.