PDA

View Full Version : 'Invisible' Surface not so invisible



jeric_synergy
02-14-2013, 11:44 PM
I added some geometry to my shadowcatcher object to make it simpler to line it up in the Perspective vuport as if the Perspective vuport was the Top view.

(Desirable since camera track puts geometry at weird angles.)

To prevent the new geometry from appearing in the render, I made it 100% transparent, IOR of 1.0.

BUT instead of not affecting the render, it blocked geometry that was supposed to be rendered, showing the backdrop.

What's up with that?? Why isn't this surface just like perfect glass? "Raytrace Transparency" is ON..
111565

Tnx

stiff paper
02-15-2013, 11:13 AM
Is Ray Recursion Limit set to 0 or 1?

Try upping its value anyway...

short223
02-15-2013, 11:27 AM
Why not instead turn the object dissolve to 100%?

jeric_synergy
02-15-2013, 11:51 AM
Why not instead turn the object dissolve to 100%?
Because I needed other parts of the object to be workin'. :)

And re Ray Recursion: but why didn't 100% transparency work??? And if there'd been a need for higher values of Ray Recursion, what would I do?

Spinland
02-15-2013, 12:53 PM
is this related at all to what I was going through when I first tried the shadow catcher node?

http://forums.newtek.com/showthread.php?133059-Shadow-catcher-node-shows-up-in-renders&highlight=shadow+catcher+node

stiff paper
02-15-2013, 02:09 PM
And re Ray Recursion: but why didn't 100% transparency work??? And if there'd been a need for higher values of Ray Recursion, what would I do?

In this context you can think of the Ray Recursion setting as being equivalent to "Number of transparent polys the ray will go through."

If the Ray Recursion is set lower than the number of polys the ray needs to go through to "see" what's behind the transparent object, it'll give you what you see in your original post, because it knows that the front object is transparent but it can't "see" anything behind it, so you just get the transparency.

You can quickly try it in layout by making a couple of cubes (or spheres, if you're spherically inclined), putting one partly in front of the other and making it transparent, like in your original post. F9 will probably give you a successful render (as in you can see through the transparent object just as you'd expect). Now try turning down the Ray Recursion setting to 0 and you'll find it does exactly what was happening in your render. Assuming the ray only needs to travel through 2 layers, you can increase the Ray Recursion to 1 and it still won't work, but increasing it to 2 or above should make it start working.

jeric_synergy
02-15-2013, 02:11 PM
Thanks Cardboard, I read that 'backwards'. TMK I didn't do anything to the RR count, it shoulda been the default, whatever that is.

stiff paper
02-15-2013, 02:14 PM
it shoulda been the default, whatever that is.

4? 8? Don't remember.

And it might not even have been that! (Although if it wasn't I'm stumped.)