PDA

View Full Version : Cut/Copy n Paste not working with volume selection



dave_paige
02-12-2013, 11:58 AM
I'm playing with 11.5 and it appears as if any mesh select using the "volume" tool, then cut or copied is not going into the clip buffer because you can't paste it back any where. Anyone else experiencing this? Thanks.

Dave

BeeVee
02-12-2013, 02:21 PM
There is something wrong with Volume Selection compared to how I remember it working, but it still cut, copies and pastes. The workflow seems to be to create your volume, select the type of selection you want, then switch to the appropriate mode (points or polys), then do your cutting or copying.

B

jeric_synergy
02-12-2013, 02:30 PM
Ben, to elaborate on that:

first, it's important to remember there's TWO different types of Volume Selection: Inclusive and..... Exclusive? Whether the line is DOTTED or SOLID tells you which you're using. One will select ONLY polygons ENTIRELY within the volume, the other will select ones that merely intersect the volume.

I just used Volume + CUT, and it successfully pasted into another layer. So, that works. Make sure your volume isn't flat in one dimension (easy to do), use the Perspective View.

To COPY elements, TMK you must use the VOLUME STATISTICS PANEL to select points or polys (no edges). When you do select, because you're in Volume mode you won't see the selection. Switch to the appropriate mode to see the selection you've made.

dave_paige
02-12-2013, 07:30 PM
Thanks for the responses. Once you create your volume, if you switch to another mode it disables the volume. This is the first time I've seen this behavior. I've been using Lightwave since version 0.9 and even in version 11.0.2 the volume selection cut/copy and paste works just fine. By the way in 11.5 the cut does work, just the paste results in no mesh. This is true for inclusive or exclusive volumes.

Ok just checked in 11.0.3 and even here it works fine, you can cut or copy some mesh inclosed within a volume and then paste it where ever you want. If I do the exact same thing in 11.5, paste results in nothing.

Dave

jeric_synergy
02-12-2013, 07:41 PM
Please fog this in an exhaustive way. Thanks for finding it.

dave_paige
02-12-2013, 07:51 PM
Already assigned a case number. BTW the other thing I reported is the fact that a new tool in 11.5 mentioned in the first issue of Lightwave Magazine, "Merge Triangles" is no where to be found.

Dave

dave_paige
02-18-2013, 10:15 AM
Ok I'm resurrecting this discussion after not getting very far with the fogbugz submission. The reply from support indicated no problem found.

So I did more detailed trials...

I'm using Modeler 11.5 64bit on Windows 7 Pro 64bit and following these steps...

1. create a sphere
2. click "volume"
3. LMB drag to encompass half of the sphere
4. hit ctrl-x to cut the geometry
5. hit ctrl-v to paste the geometry

The result is no geometry is pasted back in. More specifically no geometry is pasted back in as long as the "volume" mode is still active. If I change to point, edge, or polygon mode then the previously cut geometry is pasted back in with differing results.

in point mode the geometry is pasted back in and nothing is selected.
In edge mode the geometry is pasted back in and all of the edges in the entire sphere are selected.
In polygon mode the geometry is pasted back in and only the polygons in the pasted geometry are selected.

If i click "volume" or hit ctrl-j to enable volume mode and try the paste again no geometry is pasted.

So it appears that paste behavior has been changed in 11.5 as it relates to "volume" mode and may or may not be a bug. But I can't get any further with support to discuss this. BTW, this is ocurring identically and repeatably on two different workstations, home and work. And on both workstations using version 11.0.3 and earlier the behavior is as its always been, I can paste volume selected and cut geometry while still in volume mode just fine. Anyone have any ideas? Thanks

Dave

lertola2
02-18-2013, 04:07 PM
I was just playing around with this and getting confusing results. It looks like the pasting is not available in volume mode with the new paste behavior. But it seems like the pre 11.5 paste behavior is still available. Type control v to get the new paste behavior. Type command v (on a mac) to get the old behavior. You can paste in volume mode with command v.

jeric_synergy
02-18-2013, 07:19 PM
Yuck, that's ridiculous. I'm pretty sure that's not intended: what would be the point?

dwburman
02-19-2013, 01:15 PM
It sounds like the command-v wasn't mapped to the new paste in the Mac build... unless it's just hard coded to paste-which I doubt it is.

jeric_synergy
02-19-2013, 02:27 PM
It sounds like the command-v wasn't mapped to the new paste in the Mac build... unless it's just hard coded to paste-which I doubt it is.
Now I'm confused: i thought I'd worked thru it above, but I just tried it and and COPY/PASTE worked as expected,....so does CUT/PASTE. Yoinks.

(Windows)

lertola2
02-19-2013, 03:34 PM
It sounds like the command-v wasn't mapped to the new paste in the Mac build... unless it's just hard coded to paste-which I doubt it is.

Lightwave provides no way to change the mapping of command key shortcuts on the mac. Which is too bad because if you could you would have a lot of new keyboard short cuts available.

dwburman
02-20-2013, 03:13 PM
Ah, good to know.

Of course there are a lot of empty keyboard shortcut slots with the option key (almost all of them), plus the Shift-Option-KEY and Ctrl-Option-KEY combinations are mostly free as well.

Of course, if you're used to using the command key, then that's what you'd rather be using. :)

jeric_synergy
02-20-2013, 04:05 PM
??? No hotkey editor in Mac-land? --I'm shocked! (Seriously, I assumed all LW installs had this.)

dwburman
02-20-2013, 04:08 PM
??? No hotkey editor in Mac-land? --I'm shocked! (Seriously, I assumed all LW installs had this.)

The hot key editor is there. It just doesn't support the apple (a.k.a. command) key.

jeric_synergy
02-20-2013, 04:37 PM
Ha! I spit on the Apple key!