PDA

View Full Version : CompLete, multi-pass rendering



claw
11-05-2003, 04:39 AM
Hello, this little baby looks really use full.
http://www.pixelpotential.com/

But I can't get it to work on my mac:( Anyone with greater luck than me?

Ade
11-05-2003, 08:27 AM
Wish i knew?!

Triple G
11-05-2003, 02:08 PM
When you decompress the zip file, it contains a .jar file which you need to compile into an OSX app to be able to run it. There is documentation on Apple's site regarding how to do this (I believe there's a link in the readme), but after briefly looking through it, I came to the conclusion that most of it is way over my head. :confused:

mlinde
11-05-2003, 03:47 PM
I tried using the instructions online to build an Application, but it won't run (it just quits automatically). However, I just double-click on the .jar file and it launches "CompLete v0.99" in the Java environment.

I just don't know how to use it yet:eek:

Triple G
11-05-2003, 03:55 PM
Oh....that's cool to know. I thought that in order to be able to use it at all, you needed to compile it into an app.

I wonder what disadvantages there are to running it in the java environment as opposed to making it into an actual OSX application? Speed, I'm guessing would be one...any thoughts?

claw
11-05-2003, 03:55 PM
Yes, I also got it to work by just clicking the .jar file. However, the app doesn't work anyway, nothing happens when I try to load a scene file.

Triple G
11-05-2003, 04:04 PM
Hmm....I just tried double clicking the jar file, and it launches ok, but doesn't seem to do anything once an LWS is loaded...I'm guessing it should show you a list of all the cameras, lights, objects, etc., but nothing comes up. I tried exporting a scene, just for the heck of it, and it writes out a 0kb file. :(

Anyone care to take a stab at compiling this to see if it works that way?...pretty please...? :p :D

mlinde
11-05-2003, 04:17 PM
I tried compiling it first, and it wouldn't launch (open and immediately exit). Somebody ought to contact the developer.

Triple G
11-05-2003, 04:21 PM
Oh...duh...you did say that in your previous post. Sorry, my brain hasn't quite been working properly the last couple of days... :( :rolleyes:

claw
11-05-2003, 04:25 PM
No problem Triple!:)

Ade
11-05-2003, 07:30 PM
Author says hes using java 1.41, this was pulled from Apple support, we are using 1.32 i think...

mlinde
11-05-2003, 09:38 PM
I'm running Java 1.4.1
I can't compile the application (I have the developer tools, and tried both MRJToolkit and Project Builder), or rather I can compile but it won't launch.
I can run the .jar file, Load a scene, but it doesn't do anything. When it creates a file, it creates it one directory above what I've selected, and names the file Scenes/test.lws
The file created is blank.

Triple G
11-05-2003, 11:51 PM
I just sent the author an email regarding the problem...hopefully I/we will be hearing from him shortly. :)

claw
11-06-2003, 03:40 AM
I also wrote to Kevin about the problem, and he came up with a fix. The latest version fixes some filepath bugs, and I've tested it here on my mac and it works now.

kmacphail
11-06-2003, 06:29 AM
Hi folks,

Claw and Triple G pointed out the issue with Macs. Thanks guys. Turns out it was something silly done as a quick fix to one of my problems, and since I don't have a Mac I didn't catch it.

I uploaded a new .zip about 6:30 am central time, so please download that version. If you find anymore bugs like that please give me a shout.

I haven't included the source files with the jar yet, they're still too big and ugly to let loose in public, but once I've gotten things a little more to my liking I think I'll make it all available.

One last thing. A very generous developer is going to try to compile the plug-ins on my website for the Mac too, so keep an eye out, I'll try to get a note out on Flay when they're available

Triple G
11-06-2003, 11:49 AM
Ok...I downloaded the new zip file and launched the .jar file. The program now shows the expected list of lights, objects, etc. However, when I export a scene, the selected objects' positions shift. For instance, I have an object parented to a null, and the null is moved upward on the Y axis. When I export the scene from CompLete, the null's Y position goes back to world 0 for some reason. Guess I'll have to do some more testing.