PDA

View Full Version : Edge rendering problems



neuromancer
02-04-2013, 03:50 AM
Hi!!

Iīm trying to render a simple geometry with edges to work with adobe illustrator. With perspective or shift camera works fine, but with orthographic camera I get this:

111074

Anyone with this problem? Itīs a bug? The geometry are simple boxes, cilinders and capsule.

Regards

Sensei
02-04-2013, 04:05 AM
Instead of searching for issue, I will suggest immediate workaround.

You can try rendering edges using mine technique showed in this video tutorial
https://www.youtube.com/watch?v=UCCov7Shd7M

Or use perspective camera, move it back 10x, then appropriately adjust Zoom Factor.
f.e. if you're replacing position x,y,z of camera by 10x,10y,10z, rescale zoom factor also by 10x.
And perspective camera will pretend orthographic camera.
The farther you will move camera from initial and the higher zoom rescale, the more orthographic effect you will receive.

neuromancer
02-04-2013, 04:18 AM
Thanks, Iīve tried something similar but donīt match with the desired result. Also tried with unReal 2 but antialiasing donīt work with this camera.
Iīll try with perspective camera an move it back.
Is this bug solved in LW 11.5?

Thanks

JoePoe
02-04-2013, 10:04 AM
I'm not sure what your desired result is. Maybe post the image(s) from perspective and shift cameras that you like.
Or at least point out what is specifically wrong with the image above. Are you trying to lose the shading??
Or is it the jagged lines on the inside edges of the capsule? If it's the jaggies, check your geometry.
Ortho camera seems fine on my try.....(v9.6.1)

http://forums.newtek.com/attachment.php?attachmentid=111087&d=1360001198

nickdigital
02-04-2013, 11:30 AM
Thanks, Iīve tried something similar but donīt match with the desired result. Also tried with unReal 2 but antialiasing donīt work with this camera.


Just tried it with unReal + Ortho Cam in 11.5 and lines look clean to me. Are you using the latest unReal version?

Celshader
02-04-2013, 12:01 PM
Hi!!

Iīm trying to render a simple geometry with edges to work with adobe illustrator. With perspective or shift camera works fine, but with orthographic camera I get this:

111074

Anyone with this problem? Itīs a bug? The geometry are simple boxes, cilinders and capsule.

Regards

Is your Edge Z-Scale set to 1.0? In 11.5 it defaults to 1.0 for this reason, but I do not know if you are using 11.5.


Instead of searching for issue, I will suggest immediate workaround.

You can try rendering edges using mine technique showed in this video tutorial
https://www.youtube.com/watch?v=UCCov7Shd7M

Or use perspective camera, move it back 10x, then appropriately adjust Zoom Factor.
f.e. if you're replacing position x,y,z of camera by 10x,10y,10z, rescale zoom factor also by 10x.
And perspective camera will pretend orthographic camera.
The farther you will move camera from initial and the higher zoom rescale, the more orthographic effect you will receive.

If the Edge Z-Scale is not set to 1.0, this workaround will not work.

neuromancer
02-04-2013, 04:56 PM
I'm not sure what your desired result is. Maybe post the image(s) from perspective and shift cameras that you like.
Or at least point out what is specifically wrong with the image above. Are you trying to lose the shading??
Or is it the jagged lines on the inside edges of the capsule? If it's the jaggies, check your geometry.
Ortho camera seems fine on my try.....(v9.6.1)

http://forums.newtek.com/attachment.php?attachmentid=111087&d=1360001198

Thanks everybody!!

Iīm on LW 11. Thats exactly the desired result. I made it with Diffuse 100% and 100% ambient light, turn off all lights except for the test render I posted before. The jagged lines on the inside edges of the capsule are the error, the geometry is ok, it happens in all objets.

In prespective camera works fine as you can see:

111107 The image is resized by half.

But with same setup with orto camera yo get what I posted before with shading.

111109

@nickdigital: The latest version of unReal I use is Xtreme2 1.50 beta4 and antialiasing donīt work with orto camera or shift camera, only with calssic camera.

Orto camera render 111108

@Celshader, yes muy Edge Z Scale is set to 1. In LW 11 itīs also the default.


The result moving back the camera and zoom works, I get what I want, but its not the ideal way.

Celshader
02-04-2013, 05:11 PM
@Celshader, yes muy Edge Z Scale is set to 1. In LW 11 itīs also the default.

Is this double-sided geometry?

If so, does increasing Shadow Offset to 1 cm in the Object Properties > Render tab help? <-- I'm not sure if that matters, but Shadow Offset is meant to resolve raytrace issues with geometry that has a double-sided surface.

neuromancer
02-04-2013, 05:16 PM
Yes is double-sided. But shadows are turn off.

I just tried with LW 11.5. Just installed and works fine the edge render :D Thanks everybody.

I supposse itīs a bug from LW 11, but solved in 11.5. :D

Iīll try with unReal also.

Celshader
02-04-2013, 05:22 PM
Yes is double-sided. But shadows are turn off.

Even though it is called "Shadow Offset," I still thought it was worth a try, since it is meant to help with rendering double-sided surfaces.


I just tried with LW 11.5. Just installed and works fine the edge render :D Thanks everybody.

I supposse itīs a bug from LW 11, but solved in 11.5. :D

Iīll try with unReal also.

LightWave 11.5 has a completely new Edge rendering system. I am glad this new Edge system solved the problem. :)

JoePoe
02-04-2013, 06:33 PM
111107 The image is resized by half.

Ah, I thought this was looking a little familiar!! :D

I posted a solution (hopefully) to your Illustrator tracing question a couple of days ago.
Hope you saw it.... here (http://forums.newtek.com/showthread.php?105575-Render-to-Flash-Vector-Image-Format/page2).

Sensei
02-04-2013, 06:47 PM
Or use perspective camera, move it back 10x, then appropriately adjust Zoom Factor.
f.e. if you're replacing position x,y,z of camera by 10x,10y,10z, rescale zoom factor also by 10x.
And perspective camera will pretend orthographic camera.
The farther you will move camera from initial and the higher zoom rescale, the more orthographic effect you will receive.

I created video tutorial showing this technique.
http://www.youtube.com/watch?v=EJ_2jzam45k

neuromancer
02-05-2013, 03:38 AM
Ah, I thought this was looking a little familiar!! :D

I posted a solution (hopefully) to your Illustrator tracing question a couple of days ago.
Hope you saw it.... here (http://forums.newtek.com/showthread.php?105575-Render-to-Flash-Vector-Image-Format/page2).

hehehe thanks!! I hadnīt seen it!!! finally I solved it with Corel Draw X6, the centerline trace -> technical illustration works really amazing, not perfect but works much better than illustrator. Try it!


I created video tutorial showing this technique.
http://www.youtube.com/watch?v=EJ_2jzam45k

Thank you for the tutorial!! nice work!!

dwburman
02-06-2013, 11:00 PM
Thanks everybody!!

Iīm on LW 11. Thats exactly the desired result. I made it with Diffuse 100% and 100% ambient light, turn off all lights except for the test render I posted before. The jagged lines on the inside edges of the capsule are the error, the geometry is ok, it happens in all objets.


You could also check Matte Object in your object properties and set its color to white. That will keep it from being effected by lights and shading.