PDA

View Full Version : LWO to blender



Philbert
01-24-2013, 12:29 AM
Has anyone successfully sent LightWave objects to blender? No matter what I try the models load in with no texture. And no matter what I try in blender the texture I add to fix it will not display on the model. I've tried LWO and OBJ, Collada just crashes blender every time, Oddly blender says FBX is enabled but it doesn't seem to be in the import / export menus. I updated to the latest blender and that solved an issue with the UVs but I still can't get textures to display on the model.

MarcusM
01-24-2013, 12:44 AM
Hi, im not use this but in Blender -> User Preferences -> Addons -> On the list is: Import Lightwave Object

http://wiki.blender.org/index.php/Extensions:2.6/Py/Scripts/Import-Export/LightWave_Object

Philbert
01-24-2013, 08:32 AM
Thanks but that's how I got it loaded in the first place.

50one
01-24-2013, 09:01 AM
I'm on 2.65a and it loads up lwo with no problem, textures are visible in the viewport too. Think I had similar issue in the past, but I can't remember what I've done to fix it.

Philbert
01-24-2013, 09:22 AM
Interesting... It's not a display issue and the texture doesn't render either.

toeknee
01-24-2013, 09:29 AM
Hey Philbert. I am certainly no expert on Blender but the idea of the texturing engine in LW is unique to LW. I think the only practical way to have the texture is the video game route. This just means UV's that you bark your texture to. I agree that it sucks but it should work just fine.

- - - Updated - - -

I am also trying to see if mine works a well.

Philbert
01-24-2013, 09:53 AM
Yes that's all I have is an object with a UV map and image texture painted in Photoshop or 3D-Coat (I've tried both).

Edit: I installed blender on my laptop and tried it there. Same problem, no textures loading.

phillydee
01-24-2013, 10:32 AM
just tried the following:

1: exported UV mapped object with the UV image in the same folder as the exported OBJ.
2: brought it into Blender, made sure the image was imported as well (I previously had the image in a subfolder, and it wasn't being found by Blender)
3: make sure in the "textures" tab, I have the image set to influence Diffuse>Color (1.0)
4: at this point, the object STILL wasn't showing the textures... so I changed my layout from Default to UV Edit.
5: I fiddled with the view setting until I saw both UV map wires and the image...
6: Switched out the layout back to Default
7: Textures now show up.

I really REALLY don't know how that all happened, a lot of what Blender does and how it does it still does not make sense. But... the textures now show up.

edit: I never used Blender's materials/shaders/textures so I'm sure I'm missing something here.

phillydee
01-24-2013, 10:35 AM
here's my content directory with the Blender file saved within. If you make any other discoveries, I'd be interested.

110583

Philbert
01-24-2013, 10:58 AM
I have found that I can switch to edit mode, open the UV layout, add the texture to the UV map in there. Now it shows on the model but I don't think this is really correct since like you said it doesn't use the material editor so you can change anything else. I have a feeling that's just for testing the UV stretching the way you might with a checkerboard image. This way also wouldn't allow you to apply spec or normal maps.

phillydee
01-24-2013, 11:13 AM
I found this:

http://www.youtube.com/watch?feature=player_detailpage&v=obB9T3jXlak#t=794s

Seems you have to toggle "GLSL" and "Textured Solid". Once I had that done, I went to Textures, under "Influence", toggle "Color" to on.

I didn't have to do anything else....


Seems legit...? I hit render, texture checked out...

50one
01-24-2013, 12:06 PM
I found this:

http://www.youtube.com/watch?feature=player_detailpage&v=obB9T3jXlak#t=794s

Seems you have to toggle "GLSL" and "Textured Solid". Once I had that done, I went to Textures, under "Influence", toggle "Color" to on.

I didn't have to do anything else....


Seems legit...? I hit render, texture checked out...

Yes, that was it - GLSL shading, make sre to be in textured mode and have your textures properly assigned in Blender, should work.

Philbert
01-24-2013, 12:17 PM
Yeah, that solved the problem. Thanks! Now i just have to figure out how to tell it the spec and normal images are spec and normal, not color.

phillydee
01-24-2013, 12:31 PM
Now i just have to figure out how to tell it the spec and normal images are spec and normal, not color.

You may have to toggle these for each texture type?... Just a guess. I had to toggle the "Color" to on so that it'd show...

110584

Philbert
01-24-2013, 12:52 PM
Oh right I didn't see the Normal map one because it just says norm and the spec is written in the group name not to button. OK I got it now. duh.