PDA

View Full Version : Frustrating: all registration "I need to talk to a real person" pages are 404



mgrusin
01-05-2013, 08:59 AM
As of the morning of 1/5/2013, all of the links on register.newtek.com that would provide contact information to customer service, technical support, or sales, don't work.

This is a bit frustrating as I really need to talk to someone on the phone about a registration issue. And as I am on the fence about purchasing an upgrade, this is a bit disturbing as well.

The redesign of the main site isn't overly helpful either; the "ProTek Enhanced Support" section (the only thing that felt like it would apply to me), implies cost, looks like it's for Tricaster only, buries contact email and the existence of the forum, and doesn't even include phone numbers. (That the old web site included "community" at the top level was a point of pride for me.)

Fortunately, if you do find the "contact us" button at the upper right of the main site (not in the large number of links at the bottom!) it does include phone numbers. And as they're for business hours, I'll have to wait until Monday to talk to someone.

If anyone at Newtek sees this, they might mention to whoever runs register.newtek.com that all of those links are broken. And that the main site support section could use some love as well.

Dexter2999
01-05-2013, 09:51 AM
Are you talking about a Lightwave upgrade? Last I heard all registration had moved to lightwave3d.com. Are you using a bookmark to get to the old page? Because I think navigating the website automatically redirects.

And it has been some time but my understanding was that support was email only. Even if they had phone support, I wouldn't expect to find anyone working sales on a Saturday.

Good luck.

mgrusin
01-05-2013, 10:56 AM
Are you talking about a Lightwave upgrade?

No, SpeedEdit.


Last I heard all registration had moved to lightwave3d.com. Are you using a bookmark to get to the old page? Because I think navigating the website automatically redirects.

Register.newtek.com is where my software goes (and stays) when you click a register button.

To see the problem, go to register.newtek.com and try any of the customer service links in the bar at the top of the page.


And it has been some time but my understanding was that support was email only. Even if they had phone support, I wouldn't expect to find anyone working sales on a Saturday.

Fair enough, but I couldn't get even that information due to the broken links. ;)


Good luck.

Thanks for reading and replying!

SBowie
01-05-2013, 11:22 AM
Customer Support is open 7 days a week: http://www.newtek.com/support/overview.html

Thanks for pointing out the busted links on the Reg web page. It looks like these were omitted when the whole site was revamped some months back. (The Support links from the main website do work ok). I know that the reg. system is under review for redesign, so it may be that's why it's not been attended to, but in any case I'll point it out to those involved - sorry for the inconvenience.

mgrusin
01-05-2013, 01:45 PM
Thanks VERY much Steve, that's the Newtek I know and love! :)