PDA

View Full Version : Not getting alpha masking a texture decal



Spinland
01-03-2013, 03:36 PM
I'm applying a texture on a planar map as a decal, and added another layer above the normal one set to alpha blending using a mask texture. I thought I was doing this right, but the background of the main texture is not getting masked away. Attached is a screen shot of my texture editor setup and the results. Is there some extra step I'm missing in order to get rid of the white BG and let the underlying surface show through?

Many thanks in advance!

110185

Sensei
01-03-2013, 03:55 PM
FORGET this legacy texturing... Plug node... done..

Lewis
01-03-2013, 03:57 PM
Try "invert" alpha or if you didn't try yet go to OpenGL settings and switch to GLSLS mode (be aware that's much slower mode than MTS but will show much deeper surface settings).

- - - Updated - - -


FORGET this legacy texturing... Plug node... done..

That will be even worse for what he is trying to see without rendering but in OpenGL i.e. nothing but flat grey (or picked) color in OGL :(.

Spinland
01-03-2013, 06:14 PM
Thanks, Lewis. GLSLS mode in the display options fixed me right up.