PDA

View Full Version : Generally confused when it comes to UV-mapping



TheSnidr
01-02-2013, 07:26 AM
Hey! I thought I had an okay grasp on UV-mapping, but it is now apparent I don't.
My first problem is that I don't know how to delete UV-maps, and I don't know how to remove geometry from the UV-map once it's been placed there. This leads to the extra points on the side of the UV map as can be seen in this (http://imageshack.us/a/img831/8821/pic1gku.jpg) picture.
My second, and biggest problem, is that the UV-maps are completely changed when I export to OBJ and import them again:
This (http://imageshack.us/a/img831/8821/pic1gku.jpg) is what it looks like before I export it as an OBJ.
This (http://imageshack.us/a/img233/7388/pic2pg.jpg) is what it looks like after I import it back into lightwave modeler.
Exporting and reimporting is all I have done to the model between the pictures.

What am I doing wrong?

Nicolas Jordan
01-02-2013, 08:30 AM
To answer your first question on how to delete a UV map. Go to the Windows > Vertex Maps Panel and right click the map under texture drop down to delete the map.

djwaterman
01-02-2013, 08:43 AM
Second question, removing geometry from a map, select the polygons that you want removed from the UV map, and select the "Map" tab and then over to the side and look for Clear map. It may not work how you expect it to work, I just tried it on a box and selected one side, cleared the map and in the UV view all but one side of the box got removed. Odd.

RebelHill
01-02-2013, 08:56 AM
Second question, removing geometry from a map, select the polygons that you want removed from the UV map, and select the "Map" tab and then over to the side and look for Clear map. It may not work how you expect it to work, I just tried it on a box and selected one side, cleared the map and in the UV view all but one side of the box got removed. Odd.

Thats because removing from a map doesnt remove POLYS... it removes VERTICES. A simple cube is defined by 8 verts, clear 4, only one face remains.

btw, if not the clear button... u can use _ key shortcut (underscore).

Marcia
01-02-2013, 12:11 PM
It looks like your UV map may be screwed up due to stretching to include the old points -- best guess.

You can remove the stray vertices/points by selecting them on the UV Map then clicking Vertex Maps > General > Clear Map. Only the selected points (which were originally shared with other geometry before you deleted certain polygons) should vanish. You can avoid this issue in the future by unwelding the part before deleting it... just remember to merge points again afterward.

Also when moving or scaling geometry on the UV map, make sure you select its points, not just the polygons, or you may create artifacts like what's seen above. Select the extra points to see if they're still connected to the model. If not, go ahead and delete them. If so, unweld all the related geometry first, then delete the extra points, then reweld the geometry.

Edit: removed parts of post that may be irrelevant right now.

TheSnidr
01-02-2013, 05:20 PM
Thanks so much for answers! My first problem is solved, but my second one is still annying the crap out of me. I figured I had probably done something wrong with that model, so I went ahead and made a new one - but I have the same problem here:
Before exporting (http://imageshack.us/a/img90/4816/pic1dr.jpg)
After reimporting (http://imageshack.us/a/img856/7467/pic2lr.jpg)
The .iwo can be downloaded here (https://host-a.net/u/playway/Spherepig.lwo). Do anyone else get the same glitch?
I can't see any stray geometry on the UV-map this time.

Marcia
01-02-2013, 10:03 PM
It looks like the source of your troubles may stem from "Heal UV Map Vertices" -- that was the closest I could come to replicating your second render.

Before exporting the LW model next time, check your OBJ export options. To view these, press the letter 'o' key in Modeler to bring up the "General Options" preferences. Select the OBJ tab. Make sure "OBJ One Layer," "OBJ One VMap," "OBJ Write Normals," and "OBJ Merge Points" are checked. OBJ Pivot at Center can be unchecked; OBJ Reverse Ka and Kd should definitely be unchecked, unless you're exporting for Poser or another app that requires this setting.

Export as an .obj.

Reimport your model. The mesh should come in with points welded, so you won't need to merge them manually.

Next, set one of the viewports to UV, select your pig UV Map from the Texture drop-down list (bottom right corner of screen), and observe that the entire map is covered with red dots. This is because the UV points are unwelded, even though the model points are welded.

Now go to the Vertex Maps tab > UV Maps > Edit UVs > and select "Weld UV Map vertices." This will merge coincident points on the map, but leave control points (red dots) along your UV seams (where different disconnected parts of your UV Map share vertices). Leave those as they are -- they're supposed to be there.

Whatever you do, don't select "Heal UV Map Vertices". This will cause the red control points to find their mates, leaving your UV Map in a tangled mess and resulting in the render shown in your second image. "Heal UV Map Vertices" is a great tool, but one you want to use selectively not on the entire map at one time.

Note that making certain changes to the model (such as welding or merging model points) with the UV Map open in a viewport can sometimes cause the same problem as selecting "heal UV map vertices."

(BTW, the .lwo file you uploaded does have a stray point on your UV map just above the top of the page. It belongs with the last point on the far right side of the top row of the snout.)

Hope that solves the remaining problem. :)