PDA

View Full Version : Why is FX collision cancelling out FX wind?



Franco-Jo
12-06-2012, 10:05 AM
As my title suggests should FX wind cancel out FX collision?

I have a simple scene consisting of particles being emitted from a toroid. They are being attracted towards a FX collision object set to attract placed within a sphere. The sphere has a collision FX added to it. Everything works fine until I try to add a wind object set to rotation. What I want to happen is that the particles rotate as they are being sucked in towards the null and move up over the sphere. However when I apply the rotation wind with the attract FX switched on the wind doesn't work. When I switch off the attract FX the spiralling wind works.

I've tried all the different blend and falloff modes for the wind.
I've tried grouping all the FX into a new group.
Re-ordering the objects in the Scene Editor makes no difference.

I must be missing something simple so that they can work together? Can someone enlighten me please.

Thanks,

Mark

fgreen
12-07-2012, 01:59 PM
The short answer is that Wind and Collision both should work at the same time.

Did you render the motion? Particles will preview to some extent when playing the timeline, but they are not accurate. The "calculate" button is found in the Object Properties / Dynamics tab.

Another problem can be that the collision object doesn't have enough vertex's. Too few and the particles leak through the collision object. This doesn't sound like the problem though if the collisions work without the wind.

If you can't get it to work, the best thing would be to post a simplified version of your scene, and we can take a look.

Franco-Jo
12-09-2012, 04:15 AM
Thanks for replying to my question. I'm in a good habit of using calculate instead of relying on the preview as I tend to mostly use particles with TurbulenceFD. I've tried calculating each element individually on the off chance that you had to do it like that but it still doesn't seem to work. I'll post the simplified version of the scene i've been using for test purposes. Hopefully it will open fine for you.

Thanks!

109683

fgreen
12-10-2012, 06:27 AM
Go into your attractor Collision settings and set the radius/Level to 40cm (just a little larger than the sphere object).

Is that the effect you are looking for?

Franco-Jo
12-10-2012, 07:20 AM
That is certainly a step in the right direction! I'm aiming to have the particles swirl up around the sphere as they are attracted inwards. I'll continue to experiment with the settings unless you have any further suggestions? Maybe the answer is to have two particle emitters. One for the particles on the ground swirling around the sphere and another for on the sphere itself.

Thanks for having a look at the scene.

Franco-Jo
12-10-2012, 07:29 AM
Looking at my last comment I realise I might receive a suggestion to use the sphere as the emitter. The problem with that method is that when I then use the particles with TurbulenceFD the sphere is also included as the emitter. Maybe there is a way to switch off the sphere once i've used it to calculate the particles. I'm going to look into that as well.

fgreen
12-10-2012, 07:36 AM
For what you are describing, I'm thinking you should only have one collision object-- the sphere. As the particles can technically only "collide" with one thing at a time, trying to have two collisions affecting the motion at once is a problem. I think the solution could be to have two wind effectors. Maybe try a separate wind effector that is the same diameter as the sphere and place it to blow upwards. when the particles get close they should then start to blow upward, while continuing to swirl around the sphere.

Thomas Leitner
12-10-2012, 07:38 AM
Maybe there is a way to switch off the sphere once i've used it to calculate the particles. I'm going to look into that as well.
Hi Mark,
you can save the motion of the particles (FX_Emitter > File tab) and use it with another emitter (without an object)(FX_Emitter > File tab > load motion). Voilą the sphere is gone.

ciao
Thomas

fgreen
12-10-2012, 07:55 AM
I've attached a v2 of your scene showing what I mean (v002). I also subpatched the sphere to make it round-- the particles swirl better with no sharp edges. Maybe this is more what you are looking for?

Franco-Jo
12-10-2012, 08:05 AM
Thanks for the revised version of the scene. I had just started following your suggestions when I saw your new message. This works perfectly. Thanks so much for all your help!

Thomas, that's great to know about saving the motion data. That will definitely come in handy!

Lightwave Forum FTW!